Что это?
Первые три буквы в названии [image] abcAVI Tag Editor расшифровываются как "Add, Browse & Change" - в переводе с английского - "Добавь, Просмотри, Измени". Соответственно, программа [image] abcAVI Tag Editor позволяет добавлять, просматривать и изменять текстовую информацию, хранимую непосредственно внутри AVI файлов, в так называемых информационных тэгах.

По большому счету программа [image] abcAVI Tag Editor работает не только с информационными тэгами, но и с другой информацией, хранимой в заголовке AVI файлов. Сюда входит и возможность просмотра структуры AVI файла, и возможность изменения некоторых технических характеристих, сохраняемых в заголовке AVI, например исправить скорость воспроизведения видео или изменить кодек которым должен проигрываться файл.


Зачем это?
Попробуйте ответить на следующие вопросы:

· Вы собираете видео записи в формате AVI? Например музыкальные клиппы или фильмы?
· А может вы к тому же сами занимаетесь сжатием видео?
· А не бывало ли у вас такого случая, когда сообщение типа "Кодек vidc.XXXX не найден" не позволяло вам просмотреть интересный фильм?
· И наконец, правда ведь интересно узнать дополнительную информацию о только что просмотренном фильме? И еще более интересно иметь эту информацию _до_ просмотра? ;))

Если вы ответили утвердительно хотя бы на пару вопросов, [image] abcAVI Tag Editor может пригодиться в решении ваших задач связанных с обработкой цифрового видео в формате AVI.

С его помощью можно подписать любой AVI файл, получить информацию о необходимых для его проигрывания кодеках (даже если он не установлен в системе), а также автоматически составить отчет с информацией по нескольким файлам одновременно - например список фильмов с описанием. Кроме того, можно переименовывать сразу несколько файлов в соответствии с информацией об этих файлах, что сильно помогает в упорядочивании большой видео коллекции.


Достоинства и ограничения
Достоинства [image] abcAVI Tag Editor'а:

· Встраивание в Windows - всплывающие подсказки с информацией об AVI файлах (без ограничения на размер файлов)
· Поддержка трех форматов тэгов - мелкомягкий стандарт RIFF INFO, тэги программы MovieID и IDivX тэги
· Распознавание более 500 аудио и видео кодеков - полное название кодеков независимо от того, установлены ли необходимые кодеки в системе
· Точное определение видео и аудио битрейтов AVI файлов
· Компактный интерфейс для редактирования более тридцати полей, а не только тэгов "Автор", "Тема" и "Авторские права".
· Открытие и одновременное редактирование большого количества AVI файлов
· Подробная информация о сжатии видео
· Детальная информация об AVI файле в виде дерева его структуры с описанием каждого параметра
· Настраиваемый импорт информации из IMDb (самой большой интернет базы данных по фильмам) и AMDbFront
· Настраиваемый экспорт информации в форматы HTML, XML, TXT, XLS и т.д.
· Встраивание в контекстное меню AVI файлов
· Поддержка Drag & Drop

Ограничения [image] abcAVI Tag Editor'а:

· Поддержка только формата AVI
· Редактирование только файлов менее 2Гб
· Только графический интерфейс (нет развитого интерфейса командной строки)
· Импорт только из IMDB и AMDbFront


Авторские права

abcAVI Tag Editor - редактор AVI тэгов
© Александр Соркин aka Киби, 2002-2004

Данная программа является свободным программным обеспечением (Freeware). Вы можете использовать и распространять данную программу по вашему усмотрению, единственное ограничение - распространение программы должно быть некоммерческим. Не связанное с распространением программы коммерческое использование разрешено. А вот продавать, сдавать в аренду, лизинг и т.д. и т.п. - можно только после получения письменного разрешения Автора.

Эта программа распространяется в надежде на то, что она будет вам полезной, однако НА НЕЕ НЕ ПРЕДОСТАВЛЕНО НИКАКИХ ГАРАНТИЙ, в том числе ГАРАНТИИ ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ и ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ. Для получения более подробной информации ознакомьтесь с Лицензией Freeware.

23.01.2004
Александр Соркин aka Киби
Электронный адрес: kibizoid@mail.ru
Интернет адрес: http://abcavi.da.ru


Freeware Лицензия
Copyright © 2002-2004 Александр А. Соркин aka Киби. Все права защищены.

ВНИМАНИЕ: ПРОЧТИТЕ ВНИМАТЕЛЬНО: Используя, копируя или распространяя идущее вместе с данной Лицензией программное обеспечение вы подтверждаете, что принимаете следующее Лицензионное Соглашение ("Соглашение").

1. ЛИЦЕНЗИЯ. Александр А. Соркин aka Киби ("Автор") передает вам (каждый лицензиат в дальнейшем именуется как "Вы") неэксклюзивную, передаваемую лицензию на использование его программного продукта и сопутствующей документации (объектный код программы и документация в целом - в дальнейшем "Программа") на следующих условиях. Вы можете:

a. использовать Программу на любом компьютере находящемся в вашем владении;

b. производить копии Программы; и

c. распространять Программу (предмет требований раздела 2, см. ниже) только в оригинальной форме (в которой Программу распространяет Автор) без каких либо изменений и/или дополнений. Если у вас есть хоть малейшие сомнения, что ваша копия Программы не является оригинальной, вы должны запросить у Автора оригинальную копию.

2. ОГРАНИЧЕНИЯ ЛИЗЕНЗИИ. Лицензия, переданная в соответствии с разделом 1 данного Соглашения передается со следующими ограничениями:

Распространение Программы разрешено только в случае, если удовлетворяются все следующие условия:

а. копия Программы должна содержать уведомление об авторском праве, настоящий список условий, нижеследующий отказ от ответственности, а так же другие материалы, идущие с оригинальной копией Программы;

б. распространение Программы должно быть бесплатным (никакой оплаты - ни прямой, ни опосредованной). Единственное исключение - может взиматься плата за пересылку копии, носитель и упаковку.

в. любое коммерческое распространение Программы возможно только с прямого письменного разрешения Автора.

3. РАСПРОСТРАНЕНИЕ: В данном Соглашении термин "Распространение" (а так же его варианты) включает в себя предоставление (умышленно или непреднамеренно) Программы в доступ для третьих лиц для копирования или использования, включая доступ с разделением времени. Всякий раз, когда вы распространяете Программу, получатель должен быть определенно согласен соблюдать условия настоящего Соглашения. Вы не в праве налагать никаких дополнительных ограничений в правах на получателя копии Программы, свыше находящихся в настоящем Соглашении. Вы не несете ответственности за то, что действия получателя копии Программы могут несоответствовать требованиям данного Соглашения.

4. ОТКАЗ ОТ ОТВЕТСТВЕННОСТИ

ТАК КАК ДАННАЯ ПРОГРАММА РАСПРОСТРАНЯЕТСЯ БЕСПЛАТНО, НА НЕЕ НЕ ДАЕТСЯ НИКАКИХ ГАРАНТИЙ, В ТОЙ МЕРЕ, В КОТОРОЙ ЭТО ТОЛЬКО ВОЗМОЖНО В РАМКАХ ДЕЙСТВУЮЩЕГО ЗАКОНОДАТЕЛЬСТВА. ВО ВСЕХ СЛУЧАЯХ, ЕСЛИ НЕ УКАЗАНО ИНОЕ В ПИСЬМЕННОЙ ФОРМЕ, АВТОР РАСПРОСТРАНЯЕТ ПРОГРАММУ "КАК ЕСТЬ", ТО ЕСТЬ БЕЗ КАКИХ-ЛИБО ГАРАНТИЙ, ПРЯМЫХ ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ, ГАРАНТИЮ ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ И ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ. ВСЕ РИСКИ СВЯЗАННЫЕ С КАЧЕСТВОМ И УДОБСТВОМ РАБОТЫ С ПРОГРАММОЙ ЛЕЖАТ ИСКЛЮЧИТЕЛЬНО НА ВАС. В СЛУЧАЕ, ЕСЛИ В ПРОГРАММЕ НАЙДУТСЯ НЕДОСТАТКИ, ВЫ ПРИНИМАЕТЕ НА СЕБЯ ВСЕ ТРАТЫ СВЯЗАННЫЕ С ТЕХНИЧЕСКИМ ОБСЛУЖИВАНИЕМ, РЕМОНТОМ или ВОССТАНОВЛЕНИЕМ.

НИ ПРИ КАКИХ ОБСТОЯТЕЛЬТВАХ, ЕСЛИ ТОЛЬКО ЭТО НЕ ПРОТИВОРЕЧИТ ДЕЙСТВУЮЩЕМУ ЗАКОНОДАТЕЛЬСТВУ ИЛИ НЕ УКАЗАНО В ПИСЬМЕННОЙ ФОРМЕ, АВТОР НЕ НЕСЕТ ОТВЕТСТВЕННОСТИ ПЕРЕД ВАМИ ЗА ПРИЧИНЕННЫЕ УБЫТКИ, ВКЛЮЧАЯ ОБЩИЕ, КОНКРЕТНЫЕ, ПОБОЧНЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ПОНЕСЕННЫЕ В РЕЗУЛЬТАТЕ ИСПОЛЬЗОВАНИЯ ИЛИ НЕВОЗМОЖНОСТИ ИСПОЛЬЗОВАНИЯ ПРОГРАММЫ (ВКЛЮЧАЯ, НО НЕ ОГРАНИЧИВАЯСЬ, ПОТЕРИ ИЛИ НЕКОРРЕКТНОЕ ИЗМЕНЕНИЕ ДАННЫХ, ВАШИ ПОТЕРИ ИЛИ ПОТЕРИ ТРЕТЬИХ ЛИЦ, НЕВОЗМОЖНОСТЬ ВЗАИМОДЕЙСТВИЯ ПРОГРАММЫ С ДРУГИМ ПРОГРАММНЫМ ОБЕСПЕЧЕНИЕМ). АВТОР НЕ НЕСЕТ ОТВЕТСТВЕННОСТИ ДАЖЕ БУДУЧИ ПРЕДУПРЕЖДЕН О ВОЗМОЖНОСТИ ПОДОБНОГО РОДА УБЫТКОВ.

5. ПРЕКРАЩЕНИЕ ДЕЙСТВИЯ. Переданная выше Лицензия имеет силу до тех пор, пока Лицензионное Соглашение не будет расторгнуто Автором. Вы можете в любое время расторгнуть Соглашение, уничтожив вашу копию Программы. Соглашение автоматически теряет силу в случае, если вы нарушаете описанные выше ограничения. При расторжении Лицензионного Соглашения вы должны уничтожить все копии Программы. В случае, если другие лицензиаты, получившие с вашим участием права на Программу, не нарушили положений настоящего Соглашения, окончание действия вашей Лицензии не приводит к отзыву их Лицензий.


Языки интерфейса
Авторы переводов интерфейса [image] abcAVI Tag Editor'а

English v.60 ( [image] abcAVI 1.8.0.113) - 100%

Alexander Sorkin
avitags@mail.ru
http://abcavi.tk
Christopher Woods
chriswoods@infinitus.co.uk
http://www.chriswoods.co.uk

Russian v.56 ( [image] abcAVI 1.8.0.113) - 100%

Alexander Sorkin
avitags@mail.ru
http://abcavi.tk

Italian v.13 ( [image] abcAVI 1.7.2.105) - 95.7%

Fabrizio "Rush" Degni
fabriziodegni@rushware.net
http://www.rushware.net
DKDIB
dkdib@dkdib.net
http://www.dkdib.net

Czech v.8 ( [image] abcAVI 1.7.2.111) - 98.4%

Milan Hruby
hruby@email.cz
http://home.tiscali.cz/~cz382002
Milan Hruby ml.
milan.hrub@tiscali.cz
http://mujweb.cz/zabava/milanh

Romanian v.15 ( [image] abcAVI 1.7.1.102) - 96.4%

Marius Ovidiu
ovidium@xnet.ro
http://ovidiu.narod.ru

Bulgarian v.2 ( [image] abcAVI 1.7.1.102) - 86.7%

JJD
jjd@abv.bg
http://jjd.cjb.net

Chinese (China and Singapore) v.16 ( [image] abcAVI 1.8.0.112) - 99.2%

Kii Ali
kiiali@cpatch.org
http://cpatch.org/kiiali/

Chinese (Taiwan and Hong Kong) v.16 ( [image] abcAVI 1.8.0.112) - 99.4%

Kii Ali
kiiali@cpatch.org
http://cpatch.org/kiiali/

Portuguese (Brasil) v.5 ( [image] abcAVI 1.7.2.111) - 91.7%

Wellington Terumi Uemura
wellingtonuemura@hotmail.com
http://www.xvidmania.kit.net

French v.14 ( [image] abcAVI 1.7.0.96) - 95.7%

Philippe Nogaret
Philippe.Nogaret@wanadoo.fr
Marius Ovidiu
ovidium@xnet.ro
http://ovidiu.narod.ru
Patrick Descamps
PATRICK.DESCAMPS5@wanadoo.fr

Hungarian v.8 ( [image] abcAVI 1.7.0.94) - 89.9%

Jakuza
jakuza001@freemail.hu
Cervid Ildiko
ovidium@xnet.ro

Japanese v.5 ( [image] abcAVI 1.6.1.63) - 52.2%

Kei AOYAMA
abcavi@nonolin.com

Norwegian v.2 ( [image] abcAVI 1.6.1.63) - 68.2%

Brendan Johan Lee aka deadcyclo
brendan@tequila.org
http://www.tequila.org

Hacker's Russian v.3 ( [image] abcAVI 1.5.0.35) - 64.1%

Alexander Sorkin
avitags@mail.ru
http://abcavi.tk

Hacker's English v.3 ( [image] abcAVI 1.5.0.35) - 64.1%

Alexander Sorkin
avitags@mail.ru
http://abcavi.tk

Hacker's Romanian v.3 ( [image] abcAVI 1.5.0.35) - 60.5%

Marius Ovidiu
ovidium@xnet.ro
http://ovidiu.narod.ru

Turkish v.4 ( [image] abcAVI 1.5.0.35) - 60.5%

divxfool
maviay35@ispro.net.tr

Polish v.2 ( [image] abcAVI 1.5.0.13) - 36.7%

Hrabia Tomasz Wojciech BAZYL
mierda@skrzynka.pl

German v.2 ( [image] abcAVI 1.3) - 38.3%

Christoph Huhn
christoph.huhn@gmx.net

Spanish v.2 ( [image] abcAVI 1.3) - 51.9%

Fl0ppy
spanishleech@yahoo.es
http://www.spanishleech.host.sk


Решение задач
С помощью [image] abcAVI можно решать следующие задачи (наиболее часто спрашиваемые):

· Получение информации об AVI
· Заполнение AVI тэгов фильма
· ...вручную
· ...информацией из IMDb
· ...информацией из AMDbFront
· Экспорт информации
· Перевод тэгов в ASX форму для Windows Media Player'а
· Создание сводного HTML файла с информацией о фильмах
· Создание базы данных в Excel формате с информацией о фильмах
· Создание базы данных в формате Ant Movie Catalog
· Изменение кодека, которым проигрывается AVI файл
· Переименование AVI файлов в соответствии с их параметрами


Получение информации об AVI
Одна из основных функций [image] abcAVI - отображение всесторонней информации о видео файлах формата AVI. Для этого нужно:
Выбрать в меню Проводника (Explorer'а) нужный AVI файл, щелкнуть правой кнопкой мыши на нем и выбрать строку "abcAVI Tag Editor".
Если [image] abcAVI уже запущен, то можно нажать кнопку [image] "Открыть файл" (Ctrl+O) в основном меню. В окне выбора файлов найти необходимый AVI и нажать кнопку "Открыть".
Также можно перетащить необходимый файл из окна Проводника (Explorer'а) на окно [image] abcAVI.
Если нужный файл уже открыт в [image] abcAVI, но не является активным, надо щелкнуть по кнопке [image] "Список файлов" и выбрать необходимый.
Краткая техническая информация будет отображена в верхней части окна [image] abcAVI.
Более подробная информация о сжатии видео находится в окошке, которое вызывается щелчком на кнопку [image] рядом с полем "качество видео".
Текстовая информация о содержимом файла находится на вкладке "AVI тэги"
Подробное физическое устройство файла в виде дерева можно просмотреть на закладке "Структура AVI"

Хитрости:
· Можно открыть файл, перетащив его из окошка результатов поиска файлов в Проводнике (Explorer'е).
· Можно одновременно открыть несколько файлов (перетащить группу файлов на окно программы, выбрать несколько в окне открытия файлов и т.п.)
· Можно открыть целую директорию с файлами за один раз - для этого нужно щелкнуть на кнопке [image] "Открыть директорию" (Ctrl+Shift+O).
· При открытии большого количества файлов можно прервать процесс, нажав на клавишу Escape.
· Быстро скопировать техническую информацию в буфер обмена можно через контекстное меню поля краткой информации.

Настройки:
· Расчет аудио и видео битрейтов
· Настройка отображения технической информации об AVI
· Поиск видео файлов
· Чтение и запись тэгов

Неполадки:
· Видео файл не открывается
· Не видно закладки "AVI тэги" или "Структура AVI"
· В контекстном меню проводника для AVI файлов нет строки "abcAVI Tag Editor"


Заполнение AVI тэгов вручную
Основная задача [image] abcAVI - правка тэгов видео файлов формата AVI. Для этого нужно:
Открыть требуемый AVI файл в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Если необходимо отредактировать несколько однотипных файлов, находящихся в одной директории, то можно нажать кнопку [image] "Открыть дирекорию" (Ctrl+Shift+O) в основном меню и выбрать нужную директорию с файлами.
Если нужный файл уже открыт в [image] abcAVI, но не является активным, надо щелкнуть по кнопке [image] "Список файлов" и выбрать необходимый файл.
Перейти на страницу "AVI тэги", щелкнув на соответствующей закладке.
Заполнить информацию на первой вкладке ("Основные тэги"). Постарайтесь вписать информацию хотя бы в три первых поля - название фильма, режиссер и авторские права. Эти три тэга используются наибольшим количеством программ.
Чтобы найти точное название фильма или имя режиссера, можно открыть текущий видео файл в плеере, нажав на кнопку [image] "Просмотреть AVI файл" (Ctrl+P).
Заполнить тэги, находящиеся на вкладке "Титры".
Необходимую информацию из титров можно получить на специальных сайтах в Интернете. Если нажать на кнопку [image] "Поиск в Интернете", то откроется меню с названиями сайтов, на которых можно осуществить поиск информации об активном файле.
Сохранить внесенные изменения, нажав на кнопке [image] "Сохранить" (Ctrl+S).

Хитрости:
· Скопировать все тэги из одного файла в другой в один прием можно с помощью кнопок [image] и [image], находящихся в панели инструментов закладки "AVI тэги". После нажатия кнопки [image] "Взять тэги файла из буфера обмена" появится окошко, в котором можно будет выбрать режим вставки новых тэгов.
· В случае, если при копировании тэгов на появляется окошка с подтверждением, то изменить режим вставки тэгов можно на вкладке "чтение и запись тэгов".
· Если у всех открытых файлов какой либо тэг должен иметь одинаковое значение (например, "жанр" или "дата оцифровки"), то нужно нажать на кнопку "размножить тэг" рядом с соответствующим полем.

Настройки:
· Поиск видео файлов
· Чтение и запись тэгов

Неполадки:
· Видео файл не открывается
· Не получается заполнить тэги
· Невозможно сохранить AVI файл
· Предупреждение об уменьшении размеров файла
· Не сохраняются теги, расположенные на вкладке "Титры"
· Не видно закладки "AVI тэги"


Заполнение тэгов фильма информацией из IMDb
Кардинально сэкономить время заполнения тэгов можно с помощью автоматизированного импорта информации из онлайновой базы данных по фильмам Internet Movie Database.

Эта база содержит информацию по более чем 300.000 фильмам со всего мира, начиная от самых первых кинолент (1890-е года), заканчивая информацией по планирующимся к выходу картинам. Единственный минус для русскоговорящего пользователя - вся информация в этой базе написана на английском языке.

Для того, чтобы заполнить тэги AVI файлов инфой из IMDb надо сделать следующее:
Открыть требуемый AVI файл в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "AVI тэги", щелкнув на соответствующей закладке.
Щелкнуть на кнопке [image] "Отправить запрос в IMDb" и исправить, если требуется, название фильма. По умолчанию, в строке запроса будет подставлен текст из поля "Название". В свою очередь, если исходный файл не имел заполненных тэгов, поле "Название" берется из имени файла. Необходимо выбрать тип запроса "поисковый". После того, как будет создан запрос, станет активна вкладка "Импорт".
Щелкнуть на кнопке [image] "Начать сеанс связи" (Ctrl+Q), после чего откроется окно Центра сообщений и все созданные запросы будут отосланы в IMDb.
Дождаться прихода ответа из IMDb с результатами поиска. В зависимости от настроек, [image] abcAVI может регулярно проверять почту. В любой момент можно принудительно запустить Центр сообщений, нажав на кнопку [image] "Начать сеанс связи" (Ctrl+Q).
Если пришел ответ с несколькими вариантами названия фильма (рядом с иконкой запроса появится знак вопроса [image]), надо уточнить запрос, нажав на кнопке [image] "Уточнить запросы", либо открыв диалог уточнения двойным щелчком мыши на нужном запросе. Если был найден только один вариант названия, выбор производится автоматически. После этого создается информационный запрос. Для того, чтобы отослать его в адрес IMDb снова щелкните на иконке [image] "Начать сеанс связи" (Ctrl+Q).
Опять надо дождаться прихода ответа из IMDb, на этот раз с информацией о необходимом фильме.
После прихода нужного письма, [image] abcAVI автоматически расшифрует его. Готовый запрос отмечается желтым смайликом [image].
Теперь осталось перейти на страницу "AVI тэги", щелкнув на соответствующей закладке. Здесь надо щелкнуть по кнопке [image] "Вставить тэги из IMDb" и выбрать из списка обработанных запросов запрос соответствующий открытому файлу.
Сохранить внесенные изменения, нажав на кнопке [image] "Сохранить" (Ctrl+S).

Хитрости:
· Можно экономить время работы в Интернете, если после отправки запросов отключаться от Интернета, так как обычно письмо с ответом приходит не сразу, а через пять-десять минут.
· Если нужно создать много запросов единовременно, то можно использовать функцию [image] "Отправить запросы в IMDb на все файлы".
· При создании нового запроса можно взвести флажок "Отправить запрос сразу после создания". В таком случае, сразу после создания запроса будет запущен Центр сообщений.
· Создать запрос можно и не открывая AVI файла. Для этого на странице "Импорт" нужно нажать на кнопке "Создать новый запрос" и вписать название фильма.
· Если вы знаете точное английское название фильма, то можно сократить количество этапов и сразу создать информационный запрос.
· При создании запросов имейте в виду, что IMDb хранит названия фильмов с артиклями в конце. То есть, вместо "The Matrix" надо искать "Matrix, The" или же просто "Matrix".
· На закладке "Настройки IMDb" можно указать сколько и какой информации будет импортировать [image] abcAVI из ответов IMDb. Например, загружать ли название фильма, жанр или ограничить количество актеров в списке ролей, оставив только самых известных.

Настройки:
· Настройки импорта из IMDb
· Параметры соединения с Интернетом
· Поиск видео файлов
· Чтение и запись тэгов

Неполадки:
· Видео файл не открывается
· Не получается заполнить тэги
· Не видно закладки "Импорт" или "AVI тэги"
· Письмо из IMDB было перехвачено почтовой программой
· Ответ из IMDB не приходит очень долго (более 30 минут)
· Невозможно послать запрос и/или получить ответ от IMDb
· Требуемый фильм не обнаружен в IMDb
· Получена информация не по нужному фильму
· Невозможно сохранить AVI файл
· Предупреждение об уменьшении размеров файла
· Не сохраняются теги, расположенные на вкладке "Титры"

Смотри также:
· Заполнение AVI тэгов вручную


Заполнение тэгов фильма информацией из AMDbFront
В случае, если у вас на компьютере установлена локальная версия IMDb - AMDbFront, можно сильно сократить время получения информации о фильмах. AMDbFront содержит практически всю информацию из IMDb, и хранит ее с помощью MySQL сервера. Единственное, что необходимо делать - так это время от времени обновлять базу данных AMDbFront.

Для того, чтобы заполнить AVI тэги информацией из AMDbFront нужно:
Открыть AMdbFront и найти в базе интересующий фильм.
Не выделяя ничего в окне с информацией о фильме, выбрать меню "File/Save as..." (Ctrl+S). Выбрать место и сохранить файл с информацией о фильме. Для этих целей можно создать папку "AMDb" внутри директории "..\abcAVI".
Открыть нужный AVI файл в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "AVI тэги", щелкнув на соответствующей закладке.
Нажать на кнопку [image] "Загрузить тэги из отчета AMDbFront" и выбрать сохраненный ранее файл с информацией о фильме (например из папки "..\abcAVI\AMDb"). Вся информация в соответствии с настройками будет извлечена из отчета и помещена в тэги текущего AVI файла.
Сохранить внесенные изменения, нажав на кнопке [image] "Сохранить" (Ctrl+S).

Хитрости:
· Если сохранять отчеты AMDbFront непосредственно в директории "..\abcAVI\queries", то при выходе из программы, во время очистки директории от лишних файлов будут удалены, в том числе, и отчеты AMDbFront. Таким образом не будет расходоваться место под уже использованные отчеты.
· При выборе режима вставки "Приоритет текущих тэгов" будут сохранены старые значения тэгов AVI файла, и информация из AMDbFront будет дописана только в пустые тэги. Этот режим удобен для сохранения названия фильма на русском языке.

Настройки:
· Настройки импорта из IMDb
· Параметры соединения с Интернетом
· Поиск видео файлов
· Чтение и запись тэгов

Неполадки:
· Не могу найти нужный фильм в AMDbFront
· AMDbFront не сохраняет всю информацию о фильме
· Не все тэги читаются из файла отчета AMDbFront
· Видео файл не открывается
· Не получается заполнить тэги
· Не видно закладки "AVI тэги"
· Невозможно сохранить AVI файл
· Предупреждение об уменьшении размеров файла
· Не сохраняются теги, расположенные на вкладке "Титры"

Смотри также:
· Где взять и как настроить AMDbFront
· Заполнение AVI тэгов вручную


Перевод тэгов в ASX форму для Windows Media Player'а
Windows Media Player начиная с версии 7.0 имеет новую систему получения информации о мультимедиа файлах. В результате недоработок этой системы в настоящий момент невозможно непосредственное отображение тэгов в последних версиях проигрывателя (см. вопросы и ответы). Однако есть выход - создать файл-компаньон с расширением ASX, который дублирует информацию из AVI тэгов. Для этого нужно:
Открыть нужный AVI файл в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "Экспорт", щелкнув на соответствующей закладке.
Нажав на кнопку [image] "Выбрать шаблон" в панели инструментов экспорта (вертикальная, слева) в открывшемся списке выбрать строку "Windows Media Player play list (ASX)" и щелкнуть левой кнопкой мыши.
Нажать на кнопку [image] "Начать экспорт" (Ctrl+E), запустив процедуру экспортирования тэгов. После этого [image] abcAVI создаст в директории с исходным AVI файлом ASX файл с таким же именем, который будет содержать информацию из тэгов видео файла.
Для проигрывания AVI файла нужно открыть в Проводнике соответствующий ASX файл.

Хитрости:
· abcAVI запоминает последний использовавшийся шаблон экспорта. Таким образом, часто после открытия AVI файла остается только нажать Ctrl+E, и ASX файл будет создан.
· Если взвести флажок "не открывать результат", то созданный ASX файл не будет запущен на проигрывание. Это имеет смысл, когда одновременно обрабатывается много файлов.
· Можно создать один ASX файл, содержащий информацию о большом количестве AVI файлов. Для этого надо произвести экспорт, открыв одновременно все нужные файлы в [image] abcAVI и подправить шаблон экспорта следующим образом: в поле "Приемник/файл" написать строку типа "$(path)\playlist.asx". В данном виде шаблон подходит для создания плейлиста для AVI файлов, находящихся в одной директории.

Настройки:
· Описание полей шаблона экспорта
· Дополнительные настройки экспорта

Неполадки:
· AVI файл не открывается
· Не видно закладки "Экспорт"
· В списке шаблонов нет "Windows Media Player ..."
· Невозможно создать экспортируемый файл
· Не все тэги показываются в Windows Media Player'е


Создание сводного HTML файла с информацией о фильмах
Если вы имеете коллекцию фильмов и хотите разместить список с подробным описанием фильмов у себя на сайте, то нужно выполнить следующие шаги:
Открыть требуемые AVI файлы в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконки файлов на окно редактора тэгов).
Перейти на страницу "Экспорт", щелкнув на соответствующей закладке.
Нажав на кнопку [image] "Выбрать шаблон" в панели инструментов экспорта (вертикальная, слева) в открывшемся списке выбрать строку "HTML report (all in one page)" и щелкнуть левой кнопкой мыши.
Нажать на кнопку [image] "Начать экспорт" (Ctrl+E), запустив процедуру экспортирования тэгов.
Выбрать директорию, в которой будет сохранен сводный HTML файл. После этого [image] abcAVI создаст HTML файл, содержащий информацию обо всех открытых видео файлах и покажет этот файл в броузере по умолчанию.

Хитрости:
· Если нужно, чтобы в результате экспорта был создан не один сводный HTML файл, а много разных HTML файлов, в каждом информация по одному фильму, то нужно выбрать шаблон "HTML report (one movie per page)"
· Если взвести флажок "не открывать результат", то созданный HTML файл не будет открыт в броузере. Это имеет смысл тогда, когда в результате экспорта создается множество файлов.
· abcAVI запоминает последний использовавшийся шаблон экспорта. Таким образом, часто после открытия AVI файла остается только нажать Ctrl+E, и HTML файл будет создан.
· Если создать несколько шаблонов экспорта, то можно создавать целые сайты с видео коллекциями. Например, первый шаблон создает сводную таблицу AVI файлов со ссылками на подробное описание фильмов, а второй шаблон создает все HTML файлы с подробным описанием фильмов.

Настройки:
· Описание полей шаблона экспорта
· Дополнительные настройки экспорта

Неполадки:
· Видео файл не открывается
· Не видно закладки "Экспорт"
· В списке шаблонов нет "HTML report ..."
· Невозможно создать экспортируемый файл


Создание базы данных в Excel формате с информацией о фильмах
Часто для хранения информации о видео коллекции и обмена данными используют программу Excel. Для того, чтобы передать тэги и техническую информацию об AVI файлах в эту программу, нужно выполнить следующие шаги:
Открыть требуемый AVI файл или группу файлов в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "Экспорт", щелкнув на соответствующей закладке.
Нажав на кнопку [image] "Выбрать шаблон" в панели инструментов экспорта (вертикальная, слева) в открывшемся списке выбрать строку "Export to Excel (CSV)" или "Export to Excel (DIF)" и щелкнуть левой кнопкой мыши.
Нажать на кнопку [image] "Начать экспорт" (Ctrl+E), запустив процедуру экспортирования информации. После этого [image] abcAVI создаст в директории для хранения временных файлов (TEMP) новый файл и откроет его в Excel'e. Конечно, Excel будет запущен только в том случае, если он установлен на вашем компьютере.

Хитрости:
· Можно произвести экспорт в Excel без создания промежуточного файла. Для этого создайте шаблон для экспорта в буфер обмена и в качестве разделителя полей используйте символ табуляции (его можно вставить с помощью контекстного меню). Тогда результат экспорта будет помещен в буфер обмена и вам останется только вставить их в Excel'e в уже существующий файл.
· abcAVI запоминает последний использовавшийся шаблон экспорта. Таким образом, часто после открытия AVI файла остается только нажать Ctrl+E, и CSV или DIF файл будет создан.

Настройки:
· Описание полей шаблона экспорта
· Дополнительные настройки экспорта

Неполадки:
· Видео файл не открывается
· При экспорте в Excel'е появляются лишние ячейки
· Не видно закладки "Экспорт"
· В списке шаблонов нет "Export to Excel ..."
· Невозможно создать экспортируемый файл


Создание базы данных в формате Ant Movie Catalog
Для управления большими видео коллекциями существуют специальные программы. Ant Movie Catalog - одна из лучших программ такого рода, к тому же полностью бесплатная. К сожалению, в настоящий момент (версия 3.4.2) эта программа не поддерживает AVI тэги и вычисляет битрейты не самым точным образом.

Однако [image] abcAVI может создать файл коллекции в формате Ant Movie Catalog содержащий как техническую информацию, так и информацию из тэгов. Для этого нужно следовать нижеприведенному алгоритму:
Открыть требуемый AVI файл или группу файлов в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O), кнопку [image] "Открыть директорию" (Ctrl+Shift+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "Экспорт", щелкнув на соответствующей закладке.
Нажав на кнопку [image] "Выбрать шаблон" в панели инструментов экспорта (вертикальная, слева) в открывшемся списке выбрать строку "Ant Movie Catalog database (XML)" и щелкнуть левой кнопкой мыши.
Нажать на кнопку [image] "Начать экспорт" (Ctrl+E), запустив процедуру экспортирования информации.
Выбрать директорию и имя сохраняемого файла. После этого [image] abcAVI создаст в выбранной директории файл с расширением .xml и запустит его на выполнение. Чаще всего XML файл открывается в Интернет-броузере по умолчанию.
Закройте броузер и откройте созданный XML файл в Ant Movie Catalog.

Хитрости:
· Если взвести флажок "не открывать результат", то созданный XML файл не будет открыт в броузере.
· abcAVI запоминает последний использовавшийся шаблон экспорта. Таким образом, часто после открытия AVI файла остается только нажать Ctrl+E, и XML файл будет создан.
· Если вас не устраевает, что при экспорте теряется информация из большого количества тэгов (большинство тэгов на закладке "AVI Тэги / Титры"), то можно изменить шаблон экспорта, передав таким образом все необходимые тэги в поле "Комментарий" в Ant Movi Catalog. Для этого найдите строку Comments="$(IMIT)" и вставьте между кавычками ключевые слова для нужных тэгов, например Comments="$(IMIT), композитор: $(IMUS)".

Настройки:
· Описание полей шаблона экспорта
· Дополнительные настройки экспорта

Неполадки:
· Видео файл не открывается
· Не видно закладки "Экспорт"
· В списке шаблонов нет "Ant Movie Catalog (XML)"
· Не экспортируются аудио и видео битрейты
· Невозможно создать экспортируемый файл


Изменение кодека, которым проигрывается AVI файл
Иногда попадаются файлы, в которых указан необычный кодек для проигрывания, в результате чего становится невозможным просмотр таких файлов. В случае, если файл закодирован каким-либо кодеком из семейства MPEG-4 (DivX, XviD и т.п.), изменение кодека может помочь просмотреть файл. Для того чтобы изменить кодек надо сделать следующее:
Открыть требуемый AVI файл в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "Правка", щелкнув на соответствующей закладке.
Поднять флаг "FCC код", сделав доступными для редактирования поля, описывающие какой кодек надо использовать при проигрывании AVI файла.
Вписать новые значения в поля "Кодек" и "Формат".
Сохранить внесенные изменения, нажав на кнопке [image] "Сохранить" (Ctrl+S).

Хитрости:
· AVI файл содержит два значения, связанных с декомпрессором: FourCC код кодека и FourCC код формата. Часто бывает, что эти два FourCC кода равны, однако это не обязательное условие. Ниже приведена таблица для наиболее часто встречающихся версий MPEG-4 декомпрессоров:

Название и версия декомпрессора | FourCC кодека | FourCC формата
DivX 5 | divx | DX50
DivX 4 | divx | DIVX
DivX 3, low motion | div4 | DIV3
DivX 3, fast motion | div4 | DIV4
XviD | xvid | XVID
Microsoft MPEG-4 V3 | mp43 | MP43

Неполадки:
· Видео файл не открывается
· Не получается изменить код кодека
· Невозможно сохранить AVI файл
· Не видно закладки "Правка"


Переименование AVI файлов в соответствии с их параметрами
abcAVI может переименовывать файлы в сооответствии с содержимым тэгов и техническими характеристиками файлов. Например можно добавить к имени файла размеры кадра или битрейт. Для того, чтобы выполнить переименование надо сделать следующее:
Открыть требуемый AVI файл или группу файлов в [image] abcAVI Tag Editor'е (например, используя кнопку [image] "Открыть файл" (Ctrl+O) или просто перетащив иконку файла на окно редактора тэгов).
Перейти на страницу "Экспорт", щелкнув на соответствующей закладке.
Нажав на кнопку [image] "Выбрать шаблон" в панели инструментов экспорта (вертикальная, слева) в открывшемся списке выбрать строку "Simple file rename" и щелкнуть левой кнопкой мыши.
Нажать на кнопку [image] "Начать экспорт" (Ctrl+E), запустив процедуру создания BAT файла для переименования открытых файлов. BAT файл должен автоматически выполниться после окончания экспорта, переименовав все необходимые файлы.
Закрыть все открытые файлы в [image] abcAVI, нажав кнопку [image] "Закрыть все файлы" (Ctrl+W). После того, как было выполнено переименование файлов, любые операции с открытими ранее файлами будут невозможны - [image] abcAVI запоминает при открытии файлов их имена, а после переименования они могут измениться.

Хитрости
· Можно изменить правила переименования подправив шаблон экспорта. Например, чтобы выполнить указанную в начале операцию надо заменить строку 'ren ...' на 'ren "$(fullname)" "$(name) ($(width)x$(height), $(kbpsvideo) Kbps).$(ext)'. Будте очень внимательны, изменяя шаблон - не создавайте такого кода, который может испортить другие файлы, например не делайте группового переименования типа *.avi.
· Если использовать команду "move" внутри создаваемого BAT файла, то можно написать шаблон не только переименовывающий файлы, но и рассортировывающий их по разным директориям, например в зависимости от жанра.

Настройки:
· Описание полей шаблона экспорта
· Дополнительные настройки экспорта

Неполадки:
· Видео файл не открывается
· Некоторые (или все) файлы не переименовываются
· В списке шаблонов нет "Rename AVI"
· Невозможно создать экспортируемый файл
· Не видно закладки "Экспорт"


Главное меню
В верхней части окна [image] abcAVI Tag Editor'a изначально находятся три панели инструментов - основная панель, панель навигации по файлам и панель помощи. Все инструменты, находящиеся на этих панелях, доступны независимо от текущего режима работы программы (будь то редактирование тэгов, импорт или экспорт информации или просмотр структуры файлов).

Если щелкнуть на любой из этих панелей правой кнопкой мыши, то в контекстном меню можно выключить не нужные для работы панели инструментов. Кроме того основная панель и панель навигации по файлам могут быть перетащены в удобное для пользователя место.


Краткая информация
В верхней части окна [image] abcAVI Tag Editor'a всегда отображается блок краткой информации о текущем файле:

Если открыто несколько файлов, то для просмотра информации о нужном файле требуется сделать его активным. Для этого можно использовать панель навигации по файлам.

Стиль отображения размера файла (показывать в байтах, килобайтах или мегабайтах) и длительности можно выбрать в соответствующем разделе на странице настроек.

В случае, если видео файл имеет более одной аудио дорожки, можно выбрать из соответствующего выпадающего списка, информацию о каком аудио треке необходимо отобразить.

Можно посмотреть длительность файла, указанную в главном заголовке AVI файла, а так же указанную в заголовках всех видео и аудио потоков. Для этого нужно выбрать необходимое значение из соответствующего выпадающего списка.

Кнопка [image] открывает окно со сводной информацией о сжатии видео, кнопка [image] позволяет узнать дату создания, изменения и последнего доступа к файлу.

С помощью контекстного меню можно скопировать всю краткую информацию или сводную информацию о сжатии видео в буфер обмена.

Смотри также:
· Язык интерфейса
· Настройки интерфейса
· Расчет битрейтов


Закладки
В центральной части окна [image] abcAVI Tag Editor'a расположен набор страниц с основными функциями программы. На каждой странице сгруппированы элементы управления одной из функций. На данный момент [image] abcAVI Tag Editor содержит следующий набор страниц:
AVI тэги - просмотр и редактирование информационных тэгов
Импорт - импорт информации о фильме из IMDb
Экспорт - экспорт информации из AVI файлов
Структура AVI - полная информация о содержимом и структуре AVI файла
Правка - набор функций для корректирования служебной информации заголовка AVI файла
Настройки - страница, где собраны все настройки [image] abcAVI Tag Editor

Смотри также:
· Управление закладками


AVI тэги
На закладке AVI тэги находится от одной до четырех страниц с тэгами, в которые можно вписать нужную информацию. В зависимости от текущих настроек интерфейса, набор страниц на этой закладке может варьироваться. Если файл открыт в режиме "только для чтения", то можно будет только просмотреть текущее значение тэгов, а отредактировать их не получится.

Смотри также:
· список поддерживаемых тэгов
· инструменты для работы с AVI тэгами
· настройки работы с тэгами


Импорт
На закладке Импорт расположены инструменты, с помощью которых можно получать информацию о фильмах из онлайновой базы данных по фильмам Internet Movie Database (IMDb). Обмен информацией происходит с помощью писем, отправляемых на адрес специального e-mail робота, так что перед началом работы надо настроить параметры соединения с Интернетом.

Список запросов можно отсортировать по статусу, имени или времени последнего изменения. Для этого нужно щелкнуть на заголовке соответствующего столбца. В нижней части закладки "Запросы" находится поле с подробным описанием выделенного запроса.

Выбрать, какую информацию и в каких объемах нужно получить из IMDb можно на странице "Настройки IMDb".

В нижней части окна находится поле описания запроса. В данном поле может быть отображена следующая информация:

· Не разобранный ответ из IMDb (полный текст письма, полученного в ответ на отправленный запрос)
· Варианты названия фильма (автоматически вытаскиваются из ответа на поисковый запрос)
· Разобранные тэги (автоматически вытаскиваются из ответа на информационный запрос)
· Служебная информация о запросе

По умолчанию производится автоматический выбор, какую информацию отобразить, однако с помощью контекстного меню или кнопки [image] можно выбрать необходимый режим отображения инфы.

Получение информации из IMDb обычно происходит по следующей схеме:

1. Создание поискового запроса
2. Отправка поискового запроса
3. Получение результатов поиска
4. Разбор полученного ответа
5. Выбор точного варианта названия (создание информационного запроса)
6. Отправка информационного запроса
7. Получение ответа с информацией о фильме
8. Разбор полученной информации

Можно также сразу создать информационный запрос, пропустив таким образом первые четыре шага. Однако, если вы ошибетесь в названии фильма (допустим, поставите лишнюю запятую), то IMDb пришлет ответ, что такого фильма нет. В таком случае попытайтесь отослать поисковый запрос с таким же названием.

Иконка запроса меняется в зависимости от этапа обработки запроса. Готовый запрос имеет иконку желтого цвета [image], и добавляется в меню [image] "Вставить тэги из IMDb" на закладке " AVI тэги". Запрос, в результате которого произошла ошибка (например, не было обнаружено подходящего фильма) имеет иконку красного цвета [image].

Разбор ответов из IMDb производится автоматически, отправка и получение информации - в зависимости от настроек. Если результаты поиска содержат названия нескольких подходящих фильмов, то требуется участие пользователя - нужно выбрать один из имеющихся вариантов (рядом с названием запроса будет стоять знак вопроса [image]).

Смотри также:
· инструменты для работы с запросами
· центр соединений
· параметры соединения с Интернетом
· настройки импорта из IMDb


Центр соединений
Управлять ходом отправки и получения информации из IMDb можно через окно центра соединений:

Это окошко можно "примагнитить" к главному окну [image] abcAVI, так что оно будет перемещаться синхронно вместе с ним. Для этого надо поднести окно центра сообщений к нужному краю главного окна на достаточно близкое расстояние и отпустить его.

Есть три режима работы центра сообщений:
· Показывать автоматически - центр сообщений открывается только на время обмена информацией
· Показывать всегда - соответственно центр сообщений не закрывается после отправки/проверки почты
· Не показывать никогда - весь обмен информации происходит в фоновом процессе

Если была выбрана настройка "не показывать центр сообщений никогда", то изменить ее можно на странице параметров Интернета.


Экспорт
С помощью инструментов, находящихся на закладке Экспорт можно создавать различные файлы, содержащие информацию об открытых AVI файлах. Например, при установке [image] abcAVI можно выбрать шаблоны для экспорта в Excel и Ant Movie Catalog, создания плейлистов Windows Media Player'а, WinAmp'а, Light Alloy'я, создания HTML страниц и так далее.

Если шаблоны вас не совсем устраивают, то их можно отредактировать, включив недостающую информацию. Кроме того, [image] abcAVI предоставляет возможность создать новый шаблон для экспорта в новый формат.

abcAVI производит экспорт информации в большое количество форматов файлов, объединенных общим свойством - все они являются текстовыми файлами, то есть состоят из букв, цифр, знаков препинания и специальных символов типа фигурных скобок и т.п. При экспорте создается файл со следующей структурой:

[заголовок]
[инфа для первого AVI файла]
[инфа для второго AVI файла]
[...]
[инфа для последнего AVI файла]
[окончание]

Каждый шаблон имеет несколько полей:
· Название - краткое наименование шаблона. Этот текст будет отображаться в списке доступных шаблонов экспорта
· Приемник - буфер обмена или имя файла, в который будет производится запись скомпилированной информации.
· Заголовок - текст, который будет помещен в начало экспортируемого файла
· Повторяющаяся часть - текст, сформированный для каждого AVI файла в отдельности.
· Окончание - текст, записываемый в конец экспортируемого файла.
· Таблица замены символов в тэгах
Рядом с названием приемника располагается кнопка [image], открывающая окно с подробным описанием шаблона.

При экспорте в файл, название приемника для каждого файла AVI вычисляется заново, и если оно будет отличаться от предыдущего, то перед записью блока информации об AVI файле будет закрыт старый файл экспорта (с дописыванием окончания), и создан новый (с записью заголовка). Таким образом за один акт экспорта можно создать множество файлов, например, по одному для каждого AVI файла (как в случае экспорта в ASX формат).

Особый случай приемника - буфер обмена - весь созданный текст будет помещен в стандартный буфер обмена, доступный для других программ.

Поля приемника, заголовка, основного блока и окончания могут содержать ключевые слова вида $(ключевое_слово). Во время экспорта на место ключевых слов подставляются соответствующие им значения, например, текст тэгов, название кодека или длительность видео.

Если взведен флажок "выполнить замены символов", то содержимое практически всех ключевых слов будет обработано в соответствии с таблицей замен (открывается после нажатия на кнопке [image]). Эта функция может потребоваться, когда необходимо предотвратить появление внутри ключевых слов последовательностей символов, которые в данном формате считаются служебными.

Например, присутствие лишнего знака "<" или ">" при экспорте в HTML формат может нарушить вид всей созданной страницы (текст после "<" скорее всего не будет показан), поэтому их нужно заменить на "&lt;" и "&gt;" соответственно.

Группа настроек "Параметры приемника" сохраняется вместе с каждым шаблоном экспорта. Если отметить "Набор символов OEM", то все тексты будут переведены в DOS кодировку. Например, такая настройка используется в шаблоне экспорта в DIF формат.

Группа "Дополнительные настройки экспорта" не сохраняется внутри файла шаблона, и является общей для всех шаблонов. Здесь можно указать не использовать какую-либо часть шаблона в экспорте. Если не требуется немедленное открытие созданного при экспорте файла, нужно взвести флажок "не открывать результат".

Смотри также:
· инструменты для работы с шаблонами
· работа со списком файлов на экспорт
· ключевые слова для экспортируемой информации


Правка
Редко, но бывают моменты, когда надо подправить технические характеристики видео файла. abcAVI позволяет подправить код декомпрессора, скорость воспроизведения видео и размеры кадра видео.

Например, иногда попадаются фильмы, сжатые с помощью обычного кодека DivX, но с измененным кодом декомпрессора. Делаться это может для того, чтобы фильм проигрывался только с помощью специализированного проигрывателя, который, например, одновременно показывает баннеры. Чтобы такой фильм сумел проиграть обычный проигрыватель, надо вернуть исходное значение FourCC.

AVI файл содержит два значения, связанных с декомпрессором: FourCC код кодека и FourCC код формата. Например, для DivX 5 они равны соответственно "divx" и "DX50", для DivX 4 - "divx" и "DIVX", для DivX 3 - "div4" и "DIV3", для XviD - "xvid" и "XVID" и т.д.

Если нужно объединить два куска видео в один, то можно использовать программу типа VirtualDub. Для объединения файлов без перекодирования видео потока оба файла должны иметь одинаковые характеристики. То есть, одинаковый код кодека и формата, одинаковый размер кадра и одинаковую скорость воспроизведения.

Внутри AVI файла скорость воспроизведения сохраняется в виде двух значений - темпа и масштаба. Количество кадров в секунду получается, если разделить темп на масштаб. Соответственно одну и ту же частоту кадров можно записать по разному, например: "25 / 1", "250 / 10" или "75 / 30". VirtualDub посчитает такие файлы несовместимыми и откажется склеивать куски. abcAVI поможет привести файлы к одинаковому виду.

Честно говоря, я не помню, для чего была введена настройка размеров кадра видео. Если увеличить размер кадра, то с правой и нижней стороны изображения появятся черные полосы. Реального изменения размеров кадра не происходит - исправляется только значение в заголовке AVI файла.


Структура AVI
Закладка структуры AVI содержит дерево с полной информацией об устройстве AVI файла. Кроме того, на этой странице находится поле отчета открытия файлов: если при чтении AVI были обнаружены какие-либо ошибки, их описание будет помещено в данное поле.

Смотри также:
· инструменты для работы с деревом AVI


Настройки
Изменить внешний вид, уровень безопасности, настроить параметры соединения с IMDb и т.д. можно на странице "Настройки". Для доступа к нужному разделу настроек необходимо щелкнуть по соответствующей ветке в дереве настроек:

· Язык - настройка шрифта и языка интерфейса [image] abcAVI
· Закладки - управление отображением закладок с функциями
· Интерфейс - настройки отображения информации об AVI
· Диалоги - выбрать какие окошки с подтверждениями и сообщениями показывать.
· Расчет битрейтов - выбор алгоритма расчета и точности экспорта битрейтов
· Чтение/запись тэгов - настройки связанные с разбором и сохранением AVI файлов
· Поиск видео файлов - настройки открытия и поиска AVI файлов
· Свойства оболочки Windows - настройка контекстного меню Проводника
· Интернет - параметры почтового ящика для подключения к IMDb

Смотри также:
· настройки импорта из IMDb
· настройки экспорта (список файлов)


Панель статистики
В нижней части окна [image] abcAVI Tag Editor'а находиться панель статистики. В ней указывается, сколько всего открыто файлов, их суммарный размер и суммарная длительность.

Стиль отображения размера и длительности файлов такой же как и в блоке краткой информации, его можно выбрать в соответствующем разделе на странице настроек.

При открытии файла в панели статистики отображается индикатор выполнения работы:


Основная панель
Открыть файл - запускает диалог открытия видео файлов. Другой способ открыть файлы - использовать Drag & Drop, бросив необходимые файлы на основную форму программы.
Открыть директорию - запускает диалог выбора директории с видео файлами. Можно указать не только директорию, но и целый дисковый раздел, например "C:". После выбора директории [image] abcAVI Tag Editor открывает все видео файлы, находящиеся в данной директории в соответствии с настройками (возможен поиск в поддиректориях и распознавание видео файлов по формату, а не по расширению)
Сохранение текущего файла - все изменения (текстовые теги и параметры воспроизведения AVI файла) сохраняются. При этом происходит физическое перезаписывание исходного файла: после сохранения нельзя отменить внесенные изменения.
Сохранение всех файлов - выполняется сохранение всех изменений для всех открытых файлов.
Закрытие файлов - выполняется закрытие всех открытых файлов. При этом, если были произведены какие-либо изменения вы должны будете выбрать - игнорировать ли их, либо сохранить измененные файлы.
Отменить все изменения - производится откат всех изменений в текущем файле - восстанавливаются первоначальные значения всех текстовых тегов и параметров воспроизведения AVI файла.
Отменить изменения во всех файлах - происходит откат изменений во всех открытых файлах.
Просмотреть AVI файл - запускается программа просмотра видео (видео проигрыватель), например Универсальный проигрыватель (в зависимости от того, с какой программой связано открытие видео файлов в вашей системе)
Поиск в Интернете - открывается меню с названиями сайтов, на которых можно осуществить поиск информации об активном файле. После выбора из меню страница с результатами поиска на соответствующем сайте будет открыта в броузере по умолчанию.
Начать сеанс связи - отправить все запросы в IMDb (если есть не отправленные запросы) и проверить почту (если ожидаются результаты запросов).
Начать экспорт - запускается экспорт информации с использованием текущего шаблона и списка файлов (по умолчанию - все открытые файлы).


Навигация по файлам
Первый файл - происходит переход к первому открытому файлу
Предыдущий файл - происходит переход к предыдущему файлу в списке
Список открытых файлов - открывается список названий открытых файлов, при выборе из которого происходит переход на необходимый файл. Файлы в списке могут быть отмечены по разному:
Нормальные файлы - AVI файлы открытые в режиме редактирования тэгов
Файлы, открытые в режиме "только для чтения". В данную категорию попадают также все файлы RIFF формата не являющиеся видео файлами - MIDI файлы, анимированные курсоры, звуковые WAV файлы и т.п.
Следующий файл - происходит переход на следующий открытый файл
Последний файл - происходит переход на последний открытый файл


Панель помощи
Помощь - при нажатии на данной кнопке открывается соответствующее меню помощи:
Вызов справки - собственно говоря, вы уже в ней находитесь. Для каждого языка интерфейса вызывается соответствующая справка (если таковая имеется в наличии). В противном случае открывается справка на английском языке.
Домашняя страница abcAVI Tag Editor'а - открывается домашняя страница программы в броузере по умолчанию.
Послать письмо автору - запускается программа отправки электронной почты с диалогом написания письма автору [image] abcAVI (запускается почтовая программа по умолчанию).
О программе - открывается окошко с краткой информацией о программе, в том числе и с точным номером сборки.
Лицензионное соглашение - открывается текст лицензии на пользование [image] abcAVI Tag Editor'ом


Закладка 'AVI тэги'
Все инструменты изменения содержимого тегов работают только с файлами, открытыми в нормальном режиме. Файлы открытые в режиме "только для чтения" игнорируются при операциях заполнения, очистки и клонирования тэгов.
Отправить запрос в IMDb - открывается диалог создания нового запроса, текст по умолчанию берется из тэга "Название". После создания запроса становится активной закладка "Импорт".
Отправить запросы в IMDb на все файлы - открывается диалог создания нескольких запросов, текст которых берется из поля "Название" каждого открытого файла. Все созданные запросы помещаются в список на странице "Импорт".
Вставить тэги из IMDb - при нажатии на этой кнопке открывается меню со списком обработанных запросов. После выбора нужного запроса в тэги текущего файла заносится информация, полученная ранее из IMDb.
Загрузить тэги из отчета AMDbFront - появляется диалог открытия отчета AMDbFront (текстовый файл). После успешного выбора происходит разбор информации и заполнение тэгов AVI файла. При импорте информации используются настройки IMDb.
Загрузить тэги из письма IMDb - появляется диалог открытия письма из IMDb (текстовый файл, сохраненный в программе получения почты). После выбора нужного файла производится анализ информации и заполнение тэгов в соответствии с настройками IMDb. Используйте эту функцию, если ваш почтовый клиент перехватил письмо для [image] abcAVI.
Скопировать тэги в буфер обмена - все теги текущего файла копируются во внутренний буфер обмена. В стандартный текстовый буфер обмена помещается отформатированная информация, которую можно использовать в других программах, например в текстовом редакторе.
Заполнить тэги из буфера обмена - теги текущего файла вставляются из внутреннего буфера обмена.
Заполнить тэги во всех файлах - тэги всех открытых файлов заполняются информацией из внутреннего буфера обмена.
Очистить тэги - происходит очистка содержимого всех тегов текущего файла.
Очистить тэги во всех файлах - происходит очистка содержимого всех тегов всех открытых файлов.
Размножить тэг - (кнопка находиться с левой стороны почти каждого поля тэга) - значение тега, рядом с которым была нажата эта кнопка, у всех открытых файлов становится таким же, как у тега текущего файла.


Закладка 'Импорт'
Начать сеанс связи - отправить все запросы в IMDb (если есть не отправленные запросы) и проверить почту (если ожидаются результаты запросов).
Уточнить запросы - будут открыты для уточнения все запросы, имеющие несколько вариантов названия фильма.
Создать новый запрос - открывается диалог создания нового запроса (поискового или информационного), после создания запрос помещается в общий список запросов. При создании запроса можно указать, чтобы он был сразу отправлен в адрес IMDb - в противном случае новый запрос будет отослан только во время очередного сеанса связи.
Клонировать запрос - если запрос имеет несколько вариантов названия, то его можно клонировать - то есть создать такой же запрос, но с другим выбранным названием. Это может быть полезно, когда хочется получить информацию по нескольким фильмам из списка предложенного при уточнении поискового запроса.
Удалить запрос - физически удалить файлы запроса. Каждый запрос может занимать на диске до нескольких сотен килобайт - в зависимости от количества импортированной из IMDb информации.
Перепослать запрос в IMDb - создается и отправляется повторное письмо с запросом информации. Эта функция бывает нужна в случае, если первое письмо не дошло по каким-либо причинам до IMDb, - то есть на протяжении длительного времени (например более часа) не приходит ответ.
Переразобрать ответ из IMDb - производится повторный анализ письма с информацией о фильме и выделение тэгов из этого письма. Данная функция может потребоваться, если были изменены настройки импорта из IMDb.
Режим просмотра запросов - открывается меню с вариантами режимов просмотра. По умолчанию стоит автоматический выбор режима.


Закладка 'Экспорт'
Начать экспорт - запускается процедура создания отчета. При этом отчет создается на основе выбранного шаблона для всех отмеченных в списке экспорта файлов.
Открыть шаблон экспорта - запускается диалог открытия шаблона экспорта (директория Template)
Перезагрузить шаблон экспорта - в случае, если открытый шаблон был изменен, загружаются первоначальные значения всех полей шаблона.
Сохранить шаблон экспорта - сохраняются все изменения в для текущего шаблона экспорта.
Сохранить шаблон как - запускается диалог сохранения измененного шаблона экспорта в новый файл.
Очистить все поля шаблона - происходит очистка всех полей шаблона (может быть полезным при написании нового шаблона экспорта).
Удалить шаблон экспорта - физическое удаление файла шаблона.
Ключевые слова для приемника - открывается меню с ключевыми словами для названия приемника. Выбранное ключевое слово вставляется в текущую позицию курсора поля "Файл".
Ключевые слова заголовка - вызывается меню с ключевыми словами для заголовка, после выбора из которого нужное ключевое слово вставляется в поле заголовка в текущую позицию курсора. Если в поле заголовка был выделен некоторый фрагмент, этот фрагмент заменяется на выбранное ключевое слово.
Ключевые слова основного блока - открывается меню с ключевыми словами для основного раздела. Выбранное ключевое слово вставляется в текущую позицию курсора, либо заменяет выделенный текст.
Ключевые слова окончания - вызывается меню с ключевыми словами для окончания (набор слов такой же как и у заголовка). Выбранное ключевое слово вставляется в текущую позицию курсора, либо заменяет выделенный текст.


Закладка 'Структура AVI'
Раскрыть дерево - раскрыть все ветки дерева структуры AVI файла
Свернуть дерево - свернуть все ветки дерева структуры до первого уровня
Сохранить дерево - открывается диалог сохранения дерева структуры AVI в текстовом виде.
Сохранить заголовок AVI - открывается диалог сохранения заголовка AVI файла (начало файла до секции movi). Заголовок AVI файла обычно имеет размер около нескольких десятков килобайт.


Настройки импорта
На этой странице сведены параметры импорта из IMDb и AMDbFront. Тут можно выбрать, какую информацию необходимо вытаскивать из письма от IMDb, и в каком количестве:

Название и альтернативное название помещаются в тег "Название" и разделяются вертикальной чертой "|". Рекламные фразы попадают в тег "тема". Информация о накладках в фильме, интересных мелочах и саундтреке заносится в поле "Дополнительная информация". Остальная информация распределяется по соответствующим тэгам .

Ответ из Internet Movie Database может содержать рейтинги различных стран, соответсвенно можно выбрать какой из рейтингов [image] abcAVI будет искать в первую очередь. В случае, если этого рейтинга обнаружено не будет, [image] abcAVI попробует найти рейтинг USA, а если и того не обнаружит, то возьмет первый найденный.

Использовать ограничения на количество импортируемых позиций имеет смысл, когда хочется, чтобы суммарный размер тэгов был не слишком большим. В таком случае INFO секция может поместиться в заголовке AVI файла (за счет сжатия JUNK разделов) и суммарный размер AVI файла не увеличится. Если теги будут занимать много места и не поместятся в заголовке файла, то они будут дописаны в конец AVI файла, что несколько увеличит его размер.


Настройки экспорта
На этой странице можно отредактировать список экспортируемых файлов. В экспорте информации будут участвовать только те файлы, которые отмеченны флажком. Порядок следования файлов при экспорте информации соответствует их порядку в списке файлов:

С помощью команд контекстного меню можно взвести или снять флажки с нескольких файлов одновременно.

Если щелкнуть на заголовке столбца какого-либо столбца, файлы будут отсортированы сначала по возрастанию параметра, а после повторного щелчка на этом же заголовке - по убыванию.

Отсортировать файлы в нужном порядке можно с помощью мыши, просто перетянув необходимые файлы в нужное место. Перемещать можно как по одному файлу, так и несколько файлов одновременно.


Группа 'Язык'
На этой странице можно выбрать нужный язык интерфейса [image] abcAVI и отрегулировать параметры шрифтов интерфейса.

Если вы не можете обнаружить в списке языков нужный вам, то проверьте, был ли он выбран в процессе установки [image] abcAVI на ваш компьютер. Запустите инсталляцию еще раз и выставьте галочки напротив нужных языков интерфейса.

При выборе нового языка настройки шрифтов меняются на те, которые указаны в INI-файле для нового языка. Если не все символы языка отображаются верно, попробуйте выбрать другое значение в поле "Набор символов".

После смены языка интерфейса может потребоваться перезагрузка программы или, как минимум, переоткрытие файлов. Без этого информация о формате видео и аудио потоков останется на том языке, который был выбран при открытии соответствующих AVI файлов.

Смотри также:
· Проблемы со шрифтами
· Полный список языков интерфейса


Группа 'Закладки'
Данная страница позволяет управлять закладками [image] abcAVI Tag Editor'а. Если снять флажок, соответсвующая закладка станет невидимой. Так же можно настроить закладки второго уровня:


Группа 'Интерфейс'
abcAVI может показывать длительность видео, размер файлов, формат аудио и видео потоков по разному. Изменить формат отображения информации об AVI файле можно на странице "Интерфейс":


Группа 'Диалоги'
При работе с [image] abcAVI выполнение множества функций сопровождается подтверждениями и сообщениями. Почти все диалоговые окна содержат опцию "не показывать в дальнейшем это окно". Если взвести этот флажок, то в следующий раз функция будет выполнена без подтверждения и/или сообщения. Изменить поведение [image] abcAVI можно с помощью настроек на соответствующих закладках:

Чем больше подтверждений будет задействовано при работе [image] abcAVI, тем меньше вероятность совершить какое-либо неверное действие. Однако, избыток подтверждений может тривиально "достать".

Если нажать на кнопке "Только критичные", будут взведены флажки только напротив наиболее опасных операций с точки зрения потери информации.


Группа 'Расчет битрейтов'
abcAVI умеет вычислять битрейт аудио и видео потоков двумя разными способами. Первый способ - вычисление на основе информации только из заголовка AVI файла. Этот способ очень быстрый (надо прочесть всего несколько десятков байт информации), но неточный. Второй способ - анализ индексной секции AVI файла. Этот способ дает наиболее точные значения битрейтов, но требует достаточно большого количества времени - надо прочитать всю индексную секцию файла (для больших файлов это несколько мегабайт).

Выбрать, какой способ будет использоваться при открытии файлов, можно на странице "Расчет битрейтов":

Если один битрейт расчитывается по данным из заголовка, а второй по данным индексной секции, то скорость расчета битрейтов будет такая же, как если бы оба битрейта считались по данным индексной секции.

Третья группа настроект не оказывает влияние на отображеня битрейта в окне краткой информации об AVI файле, а используется только при экспорте информации.

Смотри также:
· Алгоритмы расчета битрейтов


Группа 'Чтение/запись тэгов'
На этой странице находятся параметры открытия и сохранения AVI файлов, а так же другие параметры, связанные с работой с тэгами:

Первая группа настроек "RIFF INFO тэги" отвечает за то, какой набор тэгов будет использован при сохранении AVI файлов. Если выбран стандартный набор, то некоторые названия на на странице "AVI тэги" будут отмечены как неактивные.

По умолчанию [image] abcAVI записывает тэги трех форматов, однако если вы хотите съэкономить место в AVI файле и не дублировать информацию, то можно отключить запись тэгов формата IDivX и MovieID.

При этом настройки поддерживаемых форматов сказываются только на процессе сохранения измененных AVI файлов (записи тэгов). При открытии AVI файлов всегда происходит экспорт информации из всех доступных форматов тэгов.

Группа "вставка тэгов" определяет режим вставки тэгов из буфера обмена, из запроса IMDb, из отчетов AMDbFront и т.п. Обычно режим вставки можно выбрать непосредственно в диалоге подтверждения вставки. Однако если вы настроили [image] abcAVI на минимум подтверждений (указали, что в дальнейшем спрашивать подтверждение больше не надо), то изменить режим вставки можно на странице настроек.

При разборе структуры AVI файлов [image] abcAVI обычно пропускает movi раздел, составляющий основной объем видео файла. Заставить [image] abcAVI показывать полную структуру AVI файла можно с помощью соответствующего флажка. Однако в данном режиме открытие больших файлов может занимать о-о-очень много времени. Так что лучше держать эту опцию выключенной.

Смотри так же:
· Режим 'только для чтения'
· Открытие файлов с ошибками
· Чередование потоков в AVI файле
· Предупреждение об уменьшении размера AVI файла


Группа 'Поиск видео файлов'
На этой странице находятся настройки влияющие на процесс поиска видео файлов и открытия директорий:

Если нужно, чтобы при открытии директорий и дисков [image] abcAVI сканировал все вложенные директории в поисках видео файлов, отметьте флаг "искать в поддиректориях".

abcAVI может находить видео файлы двумя способами - по расширению и по структуре. В первом случае [image] abcAVI ищет только файлы с расширениями *.avi и *.divx, во втором пробует открыть все файлы подряд. Первый способ является оптимальным с точки зрения скорости сканирования директорий и находит 99 процентов видео файлов формата AVI. Однако иногда попадаются AVI файлы с измененным расширением, например с расширением *.vob, и для того, чтобы [image] abcAVI обнаружило их в процессе поиска надо использовать режим определения по структуре.


Группа 'Свойства оболочки Windows'
При установке [image] abcAVI Tag Editor прописывается в реестре, добавляя строку своего запуска в меню AVI файлов, директорий и дисков. Восстановить после какого-либо сбоя или убрать эту строку можно с помощью флажков на закладке "Свойства оболочки Windows":


Группа 'Интернет'
На этой странице находятся настройки импорта информациии связанные с отправкой и приемом электронной почты. Общение между [image] abcAVI и IMDb происходит посредством обмена письмами, так что для корректной работы надо указать правильные параметры для входящих и исходящих сообщений:

В поле "E-mail адрес" надо указать адрес, на который должен приходить ответ из IMDb.

Если указать "Показывать центр соединений автоматически", то окошко центра соединений будет видно только в момент отправки / приема электронной почты.

Группа настроек "Расписание связи" отвечает за то, как часто [image] abcAVI будет проверять почту и отправлять исходящие запросы. Если снять все флажки, то [image] abcAVI будет проверять и отправлять почту только по требованию, то есть при нажатии на кнопку [image] "Начать сеанс связи".


Вопросы и ответы
При использовании [image] abcAVI Tag Editor'a у вас могут возникнуть различные вопросы. Здесь собраны ответы на наиболее часто встречающиеся вопросы:

Работа с файлами в [image] abcAVI
· Файл не открывается
· Режим 'только для чтения'
· Файл открывается с ошибками
· При открытии файлов открывается страница 'Структура AVI'
· Не открываются файлы больше 2ГБ
· Ошибки при сохранении AVI файла
· Предупреждение об уменьшении размера файла
· Некоторые файлы не переименовываются

Другие ошибки при работе с [image] abcAVI
· Ошибки при расчете битрейтов
· Проблемы со шрифтами

Эффективная работа с [image] abcAVI
· Горячие клавиши
· Управление закладками

Импорт информации из IMDb
· Невозможно подключиться к серверу POP3 и SMTP
· Очень долго не приходит ответ из IMDb
· Письмо из IMDb было перехвачено почтовой программой
· Требуемый фильм не обнаружен в IMDb
· Получена информация не по нужному фильму
· Артикли в IMDb
· Способы работы с IMDb

Импорт информации из AMDbFront
· Где взять и как настроить AMDbFront
· Не могу найти нужный фильм в AMDbFront
· AMDbFront не сохраняет всю информацию о фильме
· Не все тэги читаются из файла отчета AMDbFront

Экспорт информации
· Отсутствует нужный шаблон экспорта
· Ошибки при экспорте в файл
· При экспорте в Excel'е появляются лишние ячейки
· Ключевые слова
· Более гибкий экспорт информации
· При экспорте в Ant Movie Catalog теряются битрейты

Другие видео программы
· Софт, поддерживающий тэги
· Задержка аудио потока
· Media Player не показывает тэги
· Media Player неправильно показывает ASX файл
· Особенности Morgan Stream Switcher

AVI Тэги
· AVI тэги
· Не сохраняются теги на вкладке 'Титры'
· Разные форматы тэгов
· Стандартные INFO тэги
· Расширенный набор INFO тэгов
· IDivX тэги
· MovieID тэги
· Сводная таблица AVI тэгов
· Есть ли тэги в DVD
· Тэги для файлов других форматов

Техническая информация
· Использованные инструменты
· Алгоритмы расчета битрейтов
· Пропорции кадра
· Чередование потоков в AVI файле
· Формат AVI файлов
· Техническая документация
· abcAVI DLL

Лирика
· История написания
· Планы на будущее


Файл не открывается
Вопрос: Ваш [image] abcAVI Tag Editor не может открыть мой файл. У вас неправильная программа!

Ответ: abcAVI имеет ряд ограничений, кроме того, проверьте, что файл который вы пытаетесь открыть не используется в данный момент другой программой.

На странице "Структура AVI" в нижней части окна находиться панель отчетов - сюда помещаются сообщения об ошибках. Может оказаться так, что ваш AVI файл на самом деле не является AVI, а только имеет такое расширение. Это часто случается при скачивании фильмов или роликов из Интернета. Например, MPEG файл переименованный в AVI будет проигрываться большинством плееров, но не будет открываться в [image] abcAVI.


Режим 'только для чтения'
Вопрос: Я открываю файл с размером около 700 мегабайт, а [image] abcAVI не хочет его редактировать - файл открыт в режиме "только для чтения". Это что, ограничение на размер обрабатываемых файлов?

Ответ: Ограничение по размеру файлов есть - 2ГБ, но тогда [image] abcAVI просто проигнорирует такой файл. У вас имеет место другая ситуация. Режим "только для чтения" активируется в следующих случаях:
1) Файл действительно имеет атрибут "только для чтения" (например, файл находится на CD или скопирован на винчестер с сохранением этого атрибута)
2) Файл является RIFF файлом, но не AVI. Например, файлы на VideoCD иногда имеют расширение AVI, однако внутри этого файла находится CDXA поток.
3) Во время открытия файла были обнаружены ошибки структуры.

Итак, что можно сделать, чтобы все-таки добиться полноценной работы с файлом.

Во-первых, нужно проверить реальные атрибуты файла. Для этого выделите файл в Проводнике и нажав правую кнопку мыши, щелкните по строке "Свойства" (либо нажмите Alt+Enter). В окне свойств надо снять флажок "только чтение", ежели он взведен.

Во-вторых, в настройках [image] abcAVI "Настройки / Файл / Чтение и запись тэгов" можно попробовать снять флажок "открывать файлы с ошибками в режиме только для чтения".

Смотри также:
· Что делать с файлами с ошибками?


Файл открывается с ошибками
Вопрос: Я хотел записать тэги файла загруженного из Интернета, а [image] abcAVI написал, что файл открыт с ошибками. Я снял в настройках галочку напротив строки "открывать файлы с ошибками в режиме только для чтения" и отредактировал тэги файла. После сохранения файл перестал проигрываться Media Player'ом, хотя раньше все было в порядке. Что не так?

Ответ: Все так... Это редкий, но очень печальный случай. Именно для того, чтобы избежать таких случаев была введена опция запрета редактирования файлов с ошибками. Чтобы не потерять ценную информацию, перед изменением таких файлов надо делать резервную копию. При чтении файла ошибка может быть обнаружена например, в середине индексной секции, и конец файла будет неверно интерпретирован. В таком случае при сохранении [image] abcAVI обрежет хвост файла и информация может быть потеряна.

Так что, если вы обнаружили файл с ошибкой, обработайте его сперва программой типа VirtualDub или NanDub (в режиме копирования аудио и видео "Direct Mode"), и лишь потом открывайте для редактирования в [image] abcAVI. Подобная обработка не изменит качества видео и звука (нет рекомпрессии), но при этом уберет ошибки структуры AVI файла. И уж если никакие другие способы не помогут избавиться от ошибки - редактируйте файл на свой страх и риск (сохранив перед этим копию).


При открытии файлов открывается страница 'Структура AVI'
Вопрос: В вашей программе глюк. Когда я открываю файлы она делает активной закладку "Структура AVI", причем это бывает не всегда. Разберитесь, пожалуйста.

Ответ: Это не глюк, это фича. Если при открытии файла была обнаружена ошибка (например, ошибка структуры), то ее описание помещается в отчет об ошибках, который находится на странице "Структура AVI". А для того, чтобы пользователь был в курсе, что произошла ошибка, соответствующая страница становится активной.

Если вам не нравится такое поведение, просто скройте закладку "Структура AVI" в настройках [image] abcAVI.


Не открываются файлы больше 2ГБ
Вопрос: Большие Файлы более 2G нельзя подписать а хотелось бы....

Ответ: Сорри... Исходный формат AVI не поддерживает файлы более 2 гектар... Есть новый формат - AVI 2.0 (Open DML), который разработан, чтобы снять данное ограничение. Однако изначально [image] abcAVI Tag Editor был написан для работы с первым форматом. Так что если и будет поддержка больших файлов, то только в следующей версии (требуется целиком переписать парсер AVI файлов).

Кроме того, обычно подпись требуется для файлов, которые передаются куда-то или складываются в архив. А они (опять же, обычно) имеют небольшой размер (менее 2 гигабайт - обычно размер CD)...


Ошибки при сохранении AVI файла
Вопрос: Пытаюсь сохранить измененный файл, а Ваша программа пишет, что произошла ошибка при записи тэгов в файл. Что делать?

Ответ: Скорее всего файл, в который производится запись либо недоступен, либо заблокирован.

Если вы открывали файл на съемном носителе, например с флеш-карты, или переносного винчестера, проверьте, что носитель на месте и повторите сохранение файла.

Проверьте, что файл не был удален, перемещен или переименован после его открытия в [image] abcAVI Tag Editor'e. Такое может случится, например, во время выполнения переименования файлов с помощью шаблона экспорта "Rename AVI files". В таком случае закройте файл без сохранения о откройте его еще раз в [image] abcAVI.

Проверьте, что файл не заблокирован на запись другой программой, например видео проигрывателем. Вы могли ранее нажать на кнопку просмотра AVI файла. Закройте блокирующую программу и попробуйте сохранить файл еще раз.


Предупреждение об уменьшении размера файла
Вопрос: Я записал большое количество тэгов, однако [image] abcAVI говорит, что файл будет усечен на какое-то количество байт. Почему это происходит?

Ответ: Дело в том, что некоторые программы записывают в конец AVI файла JUNK раздел (все программы типа VirtualDub). Этот раздел не содержит информации и может быть без потерь удален, что [image] abcAVI и делает при сохранении тэгов. Если итоговый файл получается меньшего размера, чем исходный, то [image] abcAVI выдает предупреждение (которое, в принципе, можно отключить). Это предупреждение нужно потому как усечение файла может происходить не только при удалении JUNK секции, но и при сохранении изменений в файле, при открытии которого были обнаружены ошибки.

Если усекаемый кусок подозрительно большой (более нескольких килобайт), то нажмите "Отменить" и посмотрите информацию об AVI файле на странице "Структура AVI". Во-первых, в отчете об ошибках может находится строчка, что данный файл был открыт с ошибками. Во-вторых, посмотрите дерево структуры AVI на предмет размера JUNK секции в конце файла. Если размер этой секции примерно равен или больше, чем усекаемый размер, то все в порядке - предупреждение выдается из-за этой секции. В противном случае обязательно сделайте копию изменяемого файла перед сохранением!

abcAVI может записывать тэги не только в конец файла, но и в свободное место внутри заголовка AVI. Так что, даже если вы заполнили некоторое количество тэгов, все они могут быть записаны в начало файла, а JUNK секция в конце вызовет предупреждение об уменьшении размера.


Некоторые файлы не переименовываются
Вопрос: Я запустил переименование нескольких открытых файлов, а переименовались не все. Шаблон экспорта "Rename files" я не изменял - все было как после установки. Что не так?

Ответ: В одной директории могут находится только файлы с разными именами. В случае, если в результате экспорта [image] abcAVI попытается переименовать два или более файла одинаковым образом, Windows не выполнит такого переименовывания и один из файлов останется со старым именем. Одинаковые имена могут получится, если параметры видео файлов похожи. В таком случае измените содержимое тэгов AVI файла, так чтобы итоговые имена так же различались.

Вопрос: Никакие файлы не переименовываются!

Ответ: Проверьте, что файлы открыты не в режиме "только для чтения" - [image] abcAVI не умеет переименовывать файлы на компакт диске. Кроме того, проверьте, что в параметрах экспорта снят флажок "не открывать результат". Дело в том, что [image] abcAVI Tag Editor переименовавает файлы с помощью запуска BAT файла, а указанный выше флаг запрещает запускать созданные после экспорта файлы.


Ошибки при расчете битрейтов
Вопрос: На днях я переводил в формат AVI с DVD фильм Stir (Телепат). Звук в этом фильме имел формат Dolby Digital AC3 2.1 с битрейтом 192Kbit/sec. Ваша программа правильно определила формат звука - стерео, но почему-то указала битрейт звука 384 Kbit/sec. Что бы это значило? Кроме того, видеобитрейт до склейки файла со звуком и после склейки Ваша программа показывает разный. Это глюк или я что-то не понимаю? Или я неправильно склеиваю? Привожу в качестве примера таблицу с характеристиками видеофайла без звука и со звуком. Использовалась Ваша программа [image] abcAVI Tag Editor 1.6.1.

Ответ: Ага! :) Это все происки алгоритма приблизительного расчета битрейта из заголовка AVI файла. Начиная с версии 1.7 дополнительно был введен алгоритм точного расчета битрейта (по индексной секции). В индексной секции указаны размеры каждого кадра фильма и каждого блока аудио потока. Таким образом просканировав эту секцию можно получить точный размер видео и аудио и поделив его на длину соответствующего потока узнать точный битрейт.

Так вот, идете на сайт, скачиваете последнюю версию проги, заходите в "Настройки/Файлы/Расчет битрейтов" и выбираете "на основе информации из idx1 секции (точно)". Теперь битрейты будут считаться гораздо лучше. Во всяком случае, на видео битрейт не будет влиять наличие или отсутствие аудио потоков. Но открытие файлов будет чуть более медленным (idx1 секция фильма на CD может иметь размер до 5Mb).

Вопрос: В операционной системе Windows XP я могу, щелкнув правой кнопкой мыши по файлу, выбрать пункт контекстного меню Свойства. Далее на вкладке Сводка в разделе Видео вижу пункт Скорость передачи данных, 84кбит/сек. Ваша программа в разделе Video stream также показывает эту характеристику, но число в 8 раз больше - 689,541 kbit/s. У кого глюк - у Вас или у Билла Гейтса? Или я просто не знаком с терминологией и не могу правильно интерпретировать результаты?

Ответ: Думается мне, что все-таки это ошибка даже не Билла, а наших переводчиков русской версии XP. Потому как ежели оно отличается в 8 раз, то на вкладке должно быть 84 килобайт/сек, а не 84 килобит/сек. В английской версии исходные строчки отличались очень мало - "kbps" и "kBps" - могли и перепутать.... Кстати, в Windows 98 видео битрейт показывается именно в килобайтах в секунду.

Смотри также:
· Алгоритмы расчета битрейтов


Проблемы со шрифтами
Вопрос: В [image] abcAVI все всплывающие подсказки написаны на мифодице. Вроде как работать можно, но все-таки непорядок. Как это можно исправить?

Ответ: Такая ошибка может появиться в нелокализованной версии Windows. Если у вас установлена Win2000 или WinXP и неверно отображается интерфейс программы, проверьте, правильно ли у вас выставлены языковые настройки для программ не поддерживающих UNICODE: "Regional and Language Options", закладка "Advanced".


"Горячие" клавиши
Вопрос: ...я быстрее работаю с клавиатурой, чем с мышью. Какие горячие клавиши поддерживает [image] abcAVI?

Ответ: Из любого места программы [image] abcAVI Tag Editor с помощью "горячих" комбинаций клавиш можно вызвать следующие функции:

Ctrl+O | Открыть видео файл
Ctrl+Shift+O | Открыть директорию с видео файлами
Ctrl+S | Сохранить текущий файл
Ctrl+Shift+S | Сохранить все открытые файлы
Ctrl+W | Закрыть все файлы
Ctrl+P | Просмотреть содержимое текущего файла в видео проигрывателе
Ctrl+Q | Начать сеанс связи
Ctrl+E | Начать экспорт информации
Ctrl+PgUp | Перейти к предыдущему файлу
Ctrl+PgDn | Перейти к следующему файлу
Ctrl+Shift+PgUp | Перейти к первому открытому файлу
Ctrl+Shift+PgDn | Перейти к последнему файлу
Ctrl+Tab | Открыть следующую закладку
Ctrl+Shift+Tab | Открыть предыдущую закладку

На закладке AVI тэги доступны следующие комбинации:

Ctrl+Shift+C | Скопировать все тэги текущего файла во внутренний буфер обмена
Ctrl+Shift+V | Загрузить тэги текущего файла из внутреннего буфера обмена

В англоязычной версии [image] abcAVI Tag Editor'a также работают следующие комбинации:

Alt+T | Открыть закладку "AVI тэги"
Alt+I | Открыть закладку "Импорт"
Alt+E | Открыть закладку "Экспорт"
Alt+H | Открыть закладку "Правка"
Alt+S | Открыть закладку "Структура AVI"
Alt+O | Открыть закладку "Настройки"

В любом текстовом поле ввода работают стандартные сочетания клавиш:

Ctrl+C (Ctrl+Ins) | Копировать выделенный текст в буфер обмена
Ctrl+X | Вырезать выделенный текст и поместить его в буфер обмена
Ctrl+V (Shift+Ins) | Вставить текст из буфера обмена на место выделенного фрагмента
Ctrl+Z | Отменить последнее действие
Ctrl+Left | Перейти на слово к началу текста
Ctrl+Right | Перейти на слово к концу текста
End | Переместить курсор в конец строки
Home | Переместить курсор в начало строки
Ctrl+End | Переместить курсор в конец текста
Ctrl+Home | Переместить курсор в начало текста
Shift+Left | Перенести конец выделения к началу текста на один символ
Shift+Right | Перенести конец выделения к концу текста на один символ
Ctrl+Shift+Left | Перенести конец выделения к началу текста на одно слово
Ctrl+Shift+Right | Перенести конец выделения к концу текста на одно слово
Shift+End | Перенести конец выделения в конец строки
Shift+Home | Перенести конец выделения в начало строки
Ctrl+Shift+End | Перенести конец выделения в конец текста
Ctrl+Shift+Home | Перенести конец выделения в начало текста


Управление закладками
Вопрос: Не могу обнаружить закладку "Импорт" ("Экспорт", "AVI тэги" и др.), что делать? Раньше закладка была видна.

Вопрос: В программе слишком много всего наворочено - раньше (в предыдущей версии) все было гораздо лучше. Можно ли что-то сделать?

Ответ: abcAVI позволяет настроить интерфейс пользователя - можно скрыть ненужные закладки, оставив только часто используемые. Для этого надо зайти на страницу "Настройки/Вид/Закладки" и снять галочки напротив ненужных страниц. С другой стороны, если понадобился доступ к скрытой ранее закладке, то надо восстановить флажки напротив необходимых страниц.


Невозможно подключиться к серверу POP3 и SMTP
Вопрос: Я пытаюсь получить результаты запросов, а в центре соединений написано "Подключение к POP3 серверу" и далее - ошибка "Socket Error # 11001 Host not found". Что с этим делать?

Ответ: Вы столкнулись с ошибкой невозможности подключения к POP3 серверу. abcAVI Tag Editor отправляет и получает почту как обычная почтовая программа, так что описанные ниже способы решения проблемы подходят для любой программы для работы с электронной корреспонденцией, например TheBat'а и Outlook'а:

Проверьте, есть ли доступ к Интернету на вашем компьютере. Для этого откройте броузер и наберите адрес известного сайта. Если доступа к Интернету нет, то установите соединение и запустите еще раз в [image] abcAVI сеанс связи.

Если доступ есть, но ошибка остается, проверьте параметры соединения с Интернетом [image] abcAVI Tag Editor'а. В поле "POP3 сервер" и "SMTP сервер" должны быть вписаны правильные адреса для доступа к вашему электронному почтовому ящику. Если вы не уверены в точности этих адресов, обратитесь к вашему провайдеру (если почтовый ящик поддерживается провайдером) или поставщику услуг электронной почты (если вы используете, например, почтовый ящик на сервере mail.ru, yahoo.com, hotmail.com и т.п.). Кроме того, проверьте правильность написания логина и пароля для доступа к POP3 серверу.

Иногда бывает, что доступ к ящику по протоколам POP3 и SMTP предоставляется только на платной основе. Например если вы пользуетесь услугами zmail.ru, yahoo.com или hotmail.com. В таком случае вам надо оплатить дополнительную услугу или найти другого провайдера услуг электронной почты, у которого доступ по протоколу POP3 открыт изначально (например, mail.ru).

Если все-равно не помогает, попробуйте протестировать доступ к почтовому серверу с помощью команды ping или tracert. Для этого в командной строке (Пуск / выполнить) наберите строку вида "ping pop3.yourserver.com" и "tracert pop3.yourserver.com", соответственно. Может быть просто сервер временно недоступен - администраторы проводят технические работы, пролит кофе на главный сервер, или уборщица жахнула шваброй по сетевому проводу. В общем, в таком случае надо подождать, пока не будет восстановлена связь.

Если сервер доступен, Интернет работает и настройки у [image] abcAVI верные, то проверьте, а не стоит ли у вас файрвол (брандмауэр) - программа, которая фильтрует Интернет трафик. Если такая есть, укажите в настройках файрвола, что программе [image] abcAVI можно подключаться к Интернету.


Очень долго не приходит ответ из IMDb
Вопрос: Я создал и отправил запросы по пяти фильмам, а ответ пришел только на три фильма. Где потерялись два оставшихся? Они не пришли даже через два часа.

Вопрос: Странная ситуация, я все настроил в [image] abcAVI, почта отправляется и проверяется без ошибок, но ответ от IMDb не приходит. Вообще. Пробовал отправлять всевозможные запросы - глухо. В чем дело?

Ответ: Запросы отправляются в виде электронного письма на адрес email-робота, который, в свою очередь пишет ответ тоже письмом. Так что причин, по которым не приходит ответ, может быть очень много - начиная от сбоя в самом email-роботе, и заканчивая системой фильтрации электронной корреспонденции на одном из почтовых серверов. В любом случае, попробуйте использовать функцию [image] "Перепослать запрос в IMDb" (в контекстном меню нужного запроса).

Если ответы вообще на приходят, проверьте, что вы указали правильный обратный адрес в настройках Интернета (Исходящие сообщения / e-mail адрес).

Смотри также:
· Письмо из IMDb было перехвачено почтовой программой


Письмо из IMDb было перехвачено почтовой программой
Вопрос: У меня проблема: я послал запрос в IMDb и все прошло пучком. Несколькими минутами позже я получил ответ в мой ящик в Outlook'e, а [image] abcAVI все еще показывает для моего запроса "ожидается ответ". Что я сделал не так? Дайте, пожалуйста, совет!

Ответ: Вы столкнулись с перехватом письма другой программой. Для того, чтобы не было подобных проблем, лучше всего использовать новый почтовый ящик для [image] abcAVI.

Если это по каким-либо причинам невозможно, и было перехвачено письмо с информацией о фильме (а не результат поиска), то можно сохранить перехваченное письмо в текстовый файл и обработать полученный txt-файл в [image] abcAVI. Для этого откройте нужный AVI файл и щелкните на кнопке [image] "Загрузить тэги из письма IMDb" на закладке "AVI тэги".

Если был перехвачено письмо с результатами поиска, то выделите ваш запрос, щелкните на кнопке [image] "Перепослать запрос в IMDb" на закладке "Импорт" и держите Outlook (или другую почтовую программу) в закрытом состоянии до тех пор, пока [image] abcAVI не получит ответное письмо от IMDb.

Кроме того, можно указать в настройках Outlook'а не удалять сообщения с POP3 сервера, однако наилучший вариант - отдельный почтовый ящик.


Требуемый фильм не обнаружен в IMDb
Вопрос: Я попробовал найти фильм с помощью вашей программы, а она пишет, что нет вариантов или неизвестный формат данных. Помогите, пожалуйста, скажите, где ошибка.

Ответ: Если вы создали сразу информационный, а не поисковый запрос, то если IMDb не обнаружит фильма с требуемым названием, будет выслан ответ "Unable to find direct reference to: ...". abcAVI не может вытащить информацию о фильме из такого письма и пишет, то письмо имеет неверный формат данных. Чтобы удостовериться в таком варианте, выберите в меню [image] "Режим просмотра запросов" позицию "неразобранный ответ из IMDb".

Кроме того, проверьте следующее: во-первых, название фильма надо писать на английском языке или латиницей. Во-вторых, название надо писать без ведущего артикля (в английском языке - 'The' или 'A' в начале названия). В-третьих - ошибка даже в одной букве приведет к неправильным результатам. Так что лучше написать только часть названия фильма, например первые два слова.


Получена информация не по нужному фильму
Вопрос: Я создал поисковый запрос по фильму "Matrix", после этого я выбрал первую позицию из списка точных названий, но ошибся. В результате я получил информацию не по тому фильму, который у меня в коллекции. Можно ли что-нибудь сделать, чтобы не повторять весь процесс отправки запросов?

Ответ: Да, можно. Любой запрос, содержащий несколько вариантов названий фильма можно клонировать. Выделите нужный запрос и нажмите кнопку [image] "Клонировать запрос" в панели инструментов закладки "Импорт". В открывшемся окошке выберите нужное точное название фильма. После этого будет создан информационный запрос с новым названием фильма.


Артикли в IMDb
Вопрос: Я заметил, что в IMDb названия фильмов идут с артиклем на конце, а ваша программа импортирует их с артиклями в начале? Как так получается?

Ответ: Артикли расположены в конце названия для того, чтобы фильмы могли быть легко отсортированы по названиям (так как артикли являются только вспомогательными частицами). abcAVI Tag Editor распознает и переставляет их на исходное место (в начало названия) используя список часто встречающихся артиклей.

Следующая таблица частоты встречаемости артиклей в названиях фильмов была получена на основе анализа оффлайновой базы данных IMDb по фильмам (в количестве 338212 штук):

Артикль

Кол-во

Процент

без артикля
265516
78,506
The
35027
10,357
La
6523
1,929
A
6083
1,799
El
3201
0,946
Le
3119
0,922
Die
2294
0,678
L'
2057
0,608
Der
2056
0,608
Les
1866
0,552
O
1325
0,392
Il
1158
0,342
Das
983
0,291
De
816
0,241
Los
792
0,234
I
662
0,196
Un
604
0,179
An
505
0,149
Ein
432
0,128
Las
413
0,122
Una
400
0,118
Den
245
0,072
Het
236
0,070
To
216
0,064
En
214
0,063
Os
193
0,057
Eine
163
0,048
As
150
0,044
Az
134
0,040
Een
112
0,033
Ha-
107
0,032
Gli
101
0,030
Oi
87
0,026
Det
80
0,024
Ta
68
0,020
Lo
60
0,018
Al
44
0,013
Et
35
0,010
Ett
31
0,009
Ang
27
0,008
Egy
21
0,006
Des
19
0,006
Dem
15
0,004
Ye
13
0,004
Da
9
0,003


Способы работы с IMDb
Вопрос: Почему все программы получают информацию о фильмах напрямую с сайтов, а [image] abcAVI зачем-то общается через e-mail? Это же долго и непонятно! Сделайте, пожалуйста, поддержку не только IMDb - я знаю клевый сайт, на котором куча информации о фильмах.

Ответ: IMDb является самой большой базой данных по фильмам - ей вроде как уже 13... У нее, правда есть два недостатка. Во-первых, вся информация на английском языке. Во-вторых, русских фильмов мало. А русских/советских мультфильмов так вообще раз-два и обчелся...

Но как интернациональная база фильмов - IMDb непревзойденный источник информации. Так что именно она была выбрана для подключения к [image] abcAVI в первую, и как потом выяснилось, в последнюю очередь. При разборе способов подключения к IMDb обнаружилось целых три варианта, каждый со своими плюсами и минусами:

Запрос к SQL базе данных с инфой из IMDB (по образу и подобию AMDbFront)
+ Быстрый ответ на запрос
+ Возврат с сервера рассортированных полей данных (только необходимая информация)
- Нужно организовать сервер с 1Гб места + 1Гб трафика в месяц + MySQL
- Противоречит лицензионному соглашению IMDb (организация публичных баз данных)

Доступ через Web интерфейс сайта www.imdb.com
+ Инфраструктура уже создана
+ Не противоречит лицензии
- Большое количество побочной информации (около 100КБ на страницу)
- Информация разбросана по нескольким страницам
- Необходимо делать сложный анализатор полученной инфы (семантический разбор)
- Необходимость выпуска регулярных обновлений для адаптации к текущей версии дизайна сайта www.imdb.com

Письмо на mail-server@imdb.com
+ Инфраструктура уже создана
+ Удовлетворяет лицензионному соглашению IMDb
+ Формат писем неизменен на протяжении многих лет и вряд ли будет изменяться в дальнейшем
- Долгий ответ от сервера (от 3 до 15 минут)
- Отсутствие гарантий, что запрос будет обработан (фильтр спама, проблема доставки и т.п.)
- Необходимо проводить семантический анализ письма

Вариант №1был отброшен, так как противоречит лицензии на доступ к IMDb. А выбор между №2 и №3 произошел из-за того, что для разбора web-интерфейса нужно делать сложный анализатор, который вытаскивал бы крохи нужных данных из сотен килобайт окружающего "мусора". Так как информация о фильме на сайте раскидана по разным страницам, то суммарный трафик получался до 1,5 мегабайт на фильм. Объем полезной информации - 10 килобайт, так что в случае e-mail интерфейса КПД по трафику - почти 90%, а в случае web-интерфейса - менее 1%.

Да к тому же, все программы, которые импортируют информацию с сайтов должны регулярно обновлять алгоритмы вытаскивания информации - любое изменение дизайна сайта может привести к неправильному импорту информации.

Может быть в следующей версии [image] abcAVI будет включен импорт информации через web-интерфейс. Потому как этот способ обладает неоценимым преимуществом - возможностью настройки под любой сайт, а не только IMDb.


Где взять и как настроить AMDbFront
Вопрос: А где взять и как настроить AMDbFront?

Ответ: Загрузить AMDbFront можно с сайта http://www.amdbfront.com. Кроме того понадобится программа MySQL, которую можно скачать с сайта разработчиков http://www.mysql.com/downloads/. Для удобного обновления базы данных также не помещают утилиты SyncIMDB и ApplyDif, которые можно скачать со страницы Вима Мортиера (Wim Mortier) http://home.planetinternet.be/%7Eic521102/.

Вкратце, установка локальной версии AMDbFront на движке MySQL выглядит так:
Установить сервер баз данных MySQL (распаковать архив в папку c:\mysql)
Запустив утилиту администрирования MySQL создать пустую базу данных 'imdb'
Установить программу для работы с базой фильмов AMDbFront (распаковать архив в папку c:\amdbfront, скопировать туда же файл libmySQL.dll)
Скачать с FTP сайта IMDb или с его зеркала базу данных по фильмам (более 500 Мб) - набор *.list файлов.
Перевести текущую базу IMDb в SQL формат (запустить построение базы данных в AMDbFront, проверив перед этим в настройках пути к директориям)

Для обновления базы данных нужно сделать следующее:
Скачать с помощью SyncIMDb обновление для текущей версии базы данных (имя файла со следующим обновлением можно узнать в окошке About... AMDbFront) - около 5 Мб каждую неделю.
Распаковать файлы обновления в отдельную директорию (лучше использовать RAR, т.к. после распаковки ZIP'ом могут оказаться неверными контрольные суммы файлов)
Запустить утилиту ApplyDiffs с параметрами - путь к директории с *.list файлами базы данных, путь к директории с обновлением.
В случае большого количества обновлений их необходимо последовательно применить к базе фильмов.
Повторить перевод базы данных в SQL формат в AMDbFront.

Более подробная инструкция есть на сайте AMDbFront.

Где можно скачать базу данных IMDb:
ftp://ftp.imdb.com/pub/interfaces/diffs/ - основной FTP сервер Internet Movie Database
ftp://ftp.fu-berlin.de/misc/movies/database/diffs/ - зеркало №1
ftp://ftp.funet.fi/pub/mirrors/uiarchive.cso.uiuc.edu/pub/info/imdb/diffs/ - зеркало №2 ftp://ftp.sunet.se/pub/tv+movies/imdb/diffs/ - зеркало №3


Не могу найти нужный фильм в AMDbFront
Вопрос: Почему в AMDbFront нет фильма, который легко находится в IMDb?

Ответ: По идее, база данных AMDbFront полностью дублирует содержимое IMDb, однако есть свои тонкости:

Проверьте, что вы ищите именно название фильма, а не имя персоны: перед полем ввода поисковой фразы должно быть написано "Title:", а не "Name:".

Базу данных AMDbFront надо регулярно обновлять. Информация на главном сайте IMDb обновляется ежедневно и работа по ее добавлению производится администрацией сервера. А вот следить за актуальностью информации AMDbFront должны вы сами. Каждую неделю на FTP сервер IMDb выкладывается обновление базы данных. Соответственно, эти обновления надо регулярно скачивать и добавлять в вашу локальную базу данных.

Кроме того, проверьте следующее: во-первых, название фильма надо писать на английском языке или латиницей. Во-вторых, название надо писать без ведущего артикля (в английском языке - 'The' или 'A' в начале названия). В-третьих - ошибка даже в одной букве приведет к неправильным результатам. Так что лучше написать только часть названия фильма, например первые два слова.

Смотри также:
· Где взять и как настроить AMDbFront


AMDbFront не сохраняет всю информацию о фильме
Вопрос: Почему AMDbFront сохраняет не всю информацию о фильме, а только небольшую часть?

Ответ: AMDbFront имеет хитрую систему сохранения: в случае, если вы выделили какой-либо кусок текста, эта программа сохраняет только выделенный кусок. А целиком информация сохраняется только тогда, когда ничего не выделено в окне информации по фильму. Так что, снимите выделение с текста и попробуйте сохранить отчет еще раз.


Не все тэги читаются из файла отчета AMDbFront
Вопрос: Почему при экспорте из файла созданного в AMDbFront [image] abcAVI извлекает не всю информацию? Что надо сделать, чтобы была экспортирована вся информация из файла?

Ответ: При парсинге файлов, созданных программой AMDbFront, используются такие же настройки импорта, как и для IMDb. Если вы хотите импортировать максимум информации, зайдите на страницу настройки Импорта, нажмите на кнопку "Выделить все" и снимите все ограничения на количество импортируемых позиций.


Отсутствует нужный шаблон экспорта
Вопрос: Прочел в Справке, как произвести экспорт в HTML, но не могу найти нужного шаблона!

Ответ: Может быть вы не установили шаблоны экспорта при инсталляции программы. Переустановите [image] abcAVI из дистрибутива еще раз, не забыв взвести флажки напротив необходимых вам шаблонов.

Вопрос: Раньше у меня в списке шаблонов было штук десять позиций, а теперь - ни одного! Я ничего не удалял, и в папке abcavi/template все шаблоны на месте. Это как-нибудь лечится?

Ответ: Лечится, лечится! Нажмите на кнопку "Открыть шаблон" и выберите первую позицию "Открыть другой шаблон...". В появившемся окне найдите вашу директорию с шаблонами abcAVI/template и откройте любой из находящихся там файлов. Теперь опять нажмите кнопку "Открыть шаблон" - все должно уже быть на месте.

Все дело в том, что [image] abcAVI запоминает директорию, откуда был открыт последний шаблон экспорта, а в списке находятся ссылки на все шаблоны из этой директории.


Ошибки при экспорте в файл
Вопрос: При попытке запустить экспорт информации [image] abcAVI выдает окошко с ошибкой "Невозможно создать файл такой-то" и экспорт обламывается. Раньше такого не встречалось. Что делать?

Ответ: Скорее всего шаблон экспорта настроен таким образом, что производится экспорт в файл, который находится на устройстве только для чтения (например на CD). Измените в поле "Приемник/файл" путь к файлу на следующую строку "$(askdir)/..." и укажите при экспорте альтернативную директорию.

Другой случай, когда появляется такая ошибка, бывает когда шаблон указывает, что надо перезаписать файл, в который должен производиться экспорт. Например, был создан список видео клипов, который после экспорта был автоматически открыт в видео плеере. Так вот, до тех пор, пока проигрыватель не будет закрыт, файл со списком будет оставаться заблокированным и повторный экспорт в него будет невозможен.


При экспорте в Excel'е появляются лишние ячейки
Вопрос: Я держу список своих фильмов в Excel'е и переношу в него информацию с помощью CSV файлов. Но иногда при экспорте появляются лишние ячейки или строки. Как это исправить?

Ответ: Проверьте, что на странице "Шаблон экспорта" взведен флажок "Выполнять замены символов в тэгах", а таблица замены содержит следующие правила - заменять "," на "." и заменять "^p" на " ".

Кроме того, при открытии CSV файлов созданных с помощью этого шаблона надо помнить, что разделителем ячеек является символ запятой. Так что при открытии таких файлов например в Excel'е надо правильно выбирать формат открываемого файла.

Если ничего не помогает, попробуйте воспользоваться для экспорта данных другим форматом, например DIF - этот шаблон чуть сложнее редактировать, но работает он гораздо устойчивее и позволяет сохранять запятые в тэгах.


Ключевые слова
Вопрос: Какую информацию можно экспортировать из [image] abcAVI?

Ответ: abcAVI Tag Editor поддерживает более 160 ключевых слов, все они доступны через контекстное меню редактора шаблонов экспорта:
Суммарные показатели
$(filesnum) | Кол-во файлов
$(hourtotallength) | Суммарная длина файлов, часов
$(mintotallength) | Суммарная длина файлов, минут
$(sectotallength) | Суммарная длина файлов, секунд
$(shorttotallength) | Суммарная длина файлов в краткой форме
$(mtotalsize) | Суммарный размер файлов, мегабайт
$(ktotalsize) | Суммарный размер файлов, килобайт
$(btotalsize) | Суммарный размер файлов, байт

 Имя файла
$(number) | Номер файла
$(fullname) | Полное имя файла
$(path) | Путь к файлу
$(name) | Имя файла без расширения
$(ext) | Расширение файла
$(dosfullname) | Короткое полное имя файла
$(dospath) | Короткий путь к файлу
$(dosname) | Короткое имя файла без расширения
$(dosext) | Короткое расширение файла

 Длина и размер файла
$(hourlength) | Длина файла, часов
$(minlength) | Длина файла, минут
$(seclength) | Длина файла, секунд
$(hmsz_length) | Длина файла, ч+м+с+мс
$(msz_length) | Длина файла, м+с+мс
$(sz_length) | Длина файла, с+мс
$(shortlength) | Длина файла в краткой форме
$(mbsize) | Размер файла, мегабайт
$(kbsize) | Размер файла, килобайт
$(bsize) | Размер файла, байт

 Спросить пользователя
$(askdir) | Путь к директории
$(askfilename) | Полное имя файла
$(askfilename_path) | Путь к файлу
$(askfilename_name) | Имя файла без расширения
$(askfilename_ext) | Расширение файла
$(askcomment) | Общий комментарий
$(askeverycomment) | Комментарий для каждого файла

 Дата и время
$(exportdate) | Дата экспорта
$(exporttime) | Время экспорта
$(filecreateddate) | Дата создания файла
$(filecreatedtime) | Время создания файла
$(filechangeddate) | Дата последнего изменения файла
$(filechangedtime) | Время последнего изменения файла
$(fileaccessddate) | Дата последнего доступа к файлу
$(fileaccessdtime) | Время последнего доступа к файлу

 Системные переменные
$(temp) | Путь к временной директории
$(abcaviversion) | Версия abcAVI Tag Editor'а

 Видео параметры
$(videoformat) | Сводная информация о видео
$(videoquality) | Качество видео
$(videocompress) | Информация о сжатии видео
$(videocompress_ext) | Сводный отчет о сжатии видео
$(width) | Ширина, пикселей
$(height) | Высота, пикселей
$(aspect_ratio) | Соотношение сторон кадра
$(frame_proportion) | Пропорции кадра
$(frames) | Кол-во кадров
$(framespersec) | Кадров в секунду
$(bpsvideo) | Видео битрейт, бит/с
$(kbpsvideo) | Видео битрейт, кбит/с
$(bytepsvideo) | Видео битрейт, байт/с
$(kbytepsvideo) | Видео битрейт, кбайт/с
$(fcchandler) | FourCC код формата видео
$(namehandler) | Название формата видео
$(fcccodec) | FourCC код видео кодека
$(namecodec) | Название видео кодека
$(bpp) | Глубина цвета, бит/пикс
$(effbpp) | Сжатие, эфф.бит/пикс
$(videocompress_pers) | Сжатие видео, %

 Аудио параметры
$(audioformat) | Сводная информация об аудио
$(audiostreams) | Кол-во аудио потоков
$(bpsaudio) | Аудио битрейт, бит/с
$(kbpsaudio) | Аудио битрейт, кбит/с
$(bytepsaudio) | Аудио битрейт, байт/с
$(kbytepsaudio) | Аудио битрейт, кбайт/с
$(hz) | Частота дискретизации аудио, Гц
$(khz) | Частота дискретизации аудио, кГц
$(bitspersample) | Бит на сэмпл
$(tccaudio) | TwoCC код аудио кодека
$(codecaudio) | Название аудио кодека
$(channels) | Кол-во каналов звука

 Второй аудио поток
$(audioformat2) | Сводная информация об аудио
$(bpsaudio2) | Аудио битрейт, бит/с
$(kbpsaudio2) | Аудио битрейт, кбит/с
$(bytepsaudio2) | Аудио битрейт, байт/с
$(kbytepsaudio2) | Аудио битрейт, кбайт/с
$(hz2) | Частота дискретизации аудио, Гц
$(khz2) | Частота дискретизации аудио, кГц
$(bitspersample2) | Бит на сэмпл
$(tccaudio2) | TwoCC код аудио кодека
$(codecaudio2) | Название аудио кодека
$(channels2) | Кол-во каналов звука

 Третий аудио поток
$(audioformat3) | Сводная информация об аудио
$(bpsaudio3) | Аудио битрейт, бит/с
$(kbpsaudio3) | Аудио битрейт, кбит/с
$(bytepsaudio3) | Аудио битрейт, байт/с
$(kbytepsaudio3) | Аудио битрейт, кбайт/с
$(hz3) | Частота дискретизации аудио, Гц
$(khz3) | Частота дискретизации аудио, кГц
$(bitspersample3) | Бит на сэмпл
$(tccaudio3) | TwoCC код аудио кодека
$(codecaudio3) | Название аудио кодека
$(channels3) | Кол-во каналов звука

 Основные тэги
$(INAM) | Название
$(IART) | Режиссер
$(ICOP) | Авторские права
$(IPRD) | Продукт
$(ICRD) | Дата создания
$(crd_year) | Дата создания, ГГГГ
$(IGNR) | Жанр
$(ISGN) | Жанр 2
$(all_genres) | Все жанры
$(ISBJ) | Тема
$(IKEY) | Ключевые слова
$(ICMT) | Заметки

 Титры
$(IWRI) | Автор сценария
$(IPRO) | Продюсер
$(ICNM) | Оператор
$(IPDS) | Постановщик
$(IEDT) | Монтажер
$(ICDS) | Художник по костюмам
$(IMUS) | Композитор
$(ICMS) | По заказу
$(ISTD) | Производство
$(IDST) | Дистрибьютер
$(ICNT) | Страна-производитель
$(ILNG) | Язык
$(IRTD) | Ограничения
$(ISTR) | В ролях

 Дополнительные тэги
$(IPRT) | Часть
$(IFRM) | Кол-во частей
$(ISFT) | Программа
$(IENG) | Оцифровщик
$(ITCH) | Кодировщик
$(IDIT) | Дата и время оцифровки файла
$(IWEB) | Интернет адрес
$(ISRF) | Исходная форма
$(IMED) | Носитель
$(ISRC) | Источник
$(IARL) | Место хранения
$(IMIU) | Интернет адрес доп. информации
$(IMIT) | Доп. информация

 Тэги Stream Switcher'а
$(ICAS) | Номер аудио потока по умолчанию
$(IAS1) | Язык аудио потока 1
$(IAS2) | Язык аудио потока 2
$(IAS3) | Язык аудио потока 3
$(IAS4) | Язык аудио потока 4
$(IAS5) | Язык аудио потока 5
$(IAS6) | Язык аудио потока 6
$(IAS7) | Язык аудио потока 7
$(IAS8) | Язык аудио потока 8
$(IAS9) | Язык аудио потока 9

 Непонятные тэги
$(ICRP) | Обрезано
$(ISHP) | Четкость
$(IDIM) | Размеры
$(ILGT) | Освещенность
$(IDPI) | Точек на дюйм
$(IPLT) | Палитра
$(ILGU) | Интернет адрес логотипа
$(ILIU) | Интернет адрес пиктограммы логотипа
$(IWMU) | Интернет адрес водяных знаков
$(IMBI) | Интернет адрес картинки банера
$(IMBU) | Интернет адрес банера


Более гибкий экспорт информации
Вопрос: Использую вашу программу для ведения каталога фильмов. Очень не хватает при экспорте информации сортировки файлов по значению тэгов. Сделайте, пожалуйста, более гибкий экспорт!

Ответ: Программа [image] abcAVI Tag Editor - это в первую очередь редактор тэгов. Для поддержки видео коллекции есть целый класс специализированных программ под названием "Movie Managers" или "Movie Organizers". На www.divx-digest.com их с десяток всяких и разных. На мой взгляд, одна из лучших - это Ant Movie Catalog.


При экспорте в Ant Movie Catalog теряются битрейты
Вопрос: Я запустил экспорт в XML формат, однако Ant Movie Catalog почему-то не показывает битрейты. Я смотрел - битрейты внутри XML записаны, все делал как написано в руководстве, однако битрейты все-равно не передаются.

Ответ: Ant Movie Catalog импортирует только целочисленные значения битрейтов, то есть значения без дробной части. Откройте настройки [image] abcAVI "Расчет битрейтов" и выберите "использовать при экспорте округленные значения битрейтов (без дробной части)".


Софт, поддерживающий тэги

Софт, поддерживающий INFO тэги
Вопрос: Ваша программа поддерживает разные тэги, но я ни разу не видел других программ, которые бы читали их.

Ответ: Перечислю известный мне на данный момент софт:

Стандартный набор INFO тэгов распознают:
AviUtl - небольшой редактор видео
NanDub - монтаж и обработка видео
NanDub BRC - NanDub с битрейт калькулятором
Sound Forge - программа для редактирования звука
Windows Media Player 6.x - мультимедиа проигрыватель
Windows 98 - на странице "Сведения" в свойствах AVI файлов
Yet Another Avi Info - просмотр информации об AVI

Полный набор Extended INFO тэгов поддерживают следующие программы:
abcAVI Info Tips - расширение оболочки Windows - инфа об AVI файлах во всплывающих подсказках
abcAVI DLL - COM/OLE библиотека для чтения и записи AVI тэгов
DivxCataloger - каталог фильмов
getID3 - PHP библиотека для получения технической инфы о различных файлах
GSpot - просмотр технической инфы о видео
Light Alloy - мультимедиа проигрыватель
MeD's Movie Manager - каталог фильмов, написан на Java
MMAviInfo - просмотр и редактирование AVI тэгов
VirtualDubMod - монтаж и обработка видео
WhereIsIt - каталог файлов

Формат IDivX поддерживается меньше:
IDivX 1.0 - редактор тэгов
IDivX Tagger - редактор тэгов

И, наконец, MovieID практически неизвестен:
MID Tag Editor 1.3 - редактор тэгов


Задержка аудио потока
Вопрос: Некоторые AVI файлы записаны в VirtualDub'e с использованием параметра "Delay audio track by ___ ms" отличным от нуля. А вот как определить с помощью [image] abcAVI, какая задержка была использована при его создании? И вообще возможно ли это? Ведь плееры же как-то определяют нужную задержку?

Ответ: Да, в некоторых случаях задержку определить можно. Если при записи AVI файла было использовано отрицательное значение задержки (изображение опережало звук), то при записи файла в VirtualDub и подобных ему программах аудио поток становится короче видео потока на величину задержки. Просмотреть длительность аудио и видео потоков можно в поле краткой информации об AVI файле, выбрав в выпадающем меню рядом с полем длительности нужный поток.

При склеивании двух таких файлов (с отрицательной задержкой) может произойти рассинхронизация звука во всех фрагментах, кроме первого. Чтобы избежать такой рассинхронизации, нужно перед склейкой файлов обрезать все фрагменты на величину задержки, сделав длину всех аудио и видео потоков одинаковой.

В случае, если при создании исходного AVI файла была использована положительная задержка (звук опережал изображение), то при записи файла VirtualDub добавляет в начало аудио потока тишину, а хвост обрезает. Таким образом длина аудио и видео потоков остается равной и определить задержку из структуры AVI не удается. О наличии положительной задержки можно косвенно судить в случае, если первые несколько аудио блоков имеют ненормально большую величину (особенно актуально для формата VBR MP3).

Склеивание файлов с положительной задержкой в VirualDub или NanDub может не получится - данные, добавленные в начало потока и интерпретируемые аудио кодеком как тишина не всегда могут быть правильно поняты как самим VirtualDub'ом или NanDub'ом, так и другими программами. Подобная ситуация может произойти, например, с VBR MP3 файлами. В таком случае попробуйте сохранить аудио потоки в отдельные файлы и осуществить склейку с последующей синхронизацией отдельно аудио и видео потоков. Склеить MP3 файлы без перекодирования можно с помощью специализированных звуковых редакторов, например Mp3 Direct Cut.


Media Player не показывает тэги
Вопрос: Все круто, но вот почему MS Media Player 8 не показывает тэги записанные [image] abcAVI Tag Editor'ом?

Вопрос: Тэги ИМХО хорошо - только вот WMP 6.4 показывает только три основных, WMP 8.0 имеет возможность показывать больше, но ни одного из них не обнаружил :-(. В общем все тэги прочитать я смог только в СаундФордже...

Ответ: Чтобы Windows Media Player 6.xx стал показывать все возможные тэги (а не только три), надо установить Morgan Stream Switcher. Это плагин для переключения аудио потоков в видео файлах, который ко всему прочему, закрывает недоработку связанную с неполным отображением тэгов. После его установки будут показаны все теги, включая "Оценку" и "Описание":

На счет последующих версий проигрывателя - WMP 7.01, WMP 8.0 и WMP 9.0 - это странная политика товарища Билла, который не поддерживает свои же собственные стандарты. В MSDN так и написано - "есть интерфейс IAMMediaContent для передачи инфы о мультимедиа содержимом, есть парсер для AVI файлов "AVI Splitter", который получает необходимую инфу из INFO тэгов и реализует интерфейс обмена, и есть Windows Media Player, который этот интерфейс при показе данных не использует":

The IAMMediaContent interface provides methods for retrieving metadata from a stream. Applications can use this interface to retrieve information encoded into a stream, such as the author, title, and copyright. This interface is typically exposed by parser filters, such as the AVI Splitter filter and the MPEG-1 Stream Splitter filter.

Depending on the stream type, a filter might support a subset of the methods on this interface. For example, the AVI Splitter retrieves the copyright, author name, and title from INFO chunks in the AVI file. The remaining methods return E_NOTIMPL.

Note: Microsoft® Windows Media™ Player does not use this interface to display metadata.

WMP 6.xx поддерживал интерфейс, а более поздние версии, почему-то - нет. Так что с непосредственным чтением/отображением тэгов - проблемы :((. Есть два варианта, известные автору сей Справки, которые помогают отобразить-таки информацию в WMP 7-9

1) Экспорт AVI тэгов в файл формата ASX - что-то типа плейлиста для Media Player'а.
2) Установка Morgan Stream Switcher. Внимание! После этого информация о проигрываемом файле будет находиться на закладке "Playlist", а не "Content". Кроме того, при проигрывании плейлистов информация будет доступна только для активного файла (тот, что проигрывается в данный момент).

Смотри также:
· Особенности Morgan Stream Switcher


Media Player неправильно показывает ASX файл
Вопрос: Я создал с помощью Вашей программы ASX файл, но он неправильно показывается Media Player'ом. Все делал так, как указано в Справке, а поле "Rating" в WMP остается пустым, хотя в AVI файле соответствующий тэг заполнен. В чем проблема?

Ответ: Windows Media Player 7.0 и старше запрашивает значение поля "Rating" из локальной базы данных Media Library. Фактически же данная база присутствует только в Windows XP, так что это поле остается пустым.

Если установить программу Morgan Stream Switcher, то на закладке "Playlist" в поле "Rating" будет помещено значение из AVI тэгов.

Смотри также:
· Особенности работы Morgan Stream Switcher


Особенности Morgan Stream Switcher
Вопрос: Установил Morgan Stream Switcher 0.99 как вы советовали, теперь в WMP9 показываются тэги. Но есть несколько вопросов:

Во-первых, закладка с описанием файла остается пустой, а информация находится на закладке с описанием списка файлов (playlist). Это за глюк?

Во-вторых, поле "more info" содержит ссылку http://www.imdb.com/Find?for="что-то-там", вместо той, которую я вписал в [image] abcAVI.

Ответ: Так как WMP9 не поддерживает интерфейс получения информации о файлах, то автор MMSwitch пошел на хитрость - использовал интерфейс получения информации о списке файлов. В результате AVI тэги попали на страницу описания плейлиста.

По части второго вопроса. К сожалению, MMSwitch не читает тэги IWEB и IMIU, которые содержат ссылки на сайты кодировщика файла и дополнительной информации о содержимом файла. Однако, если экспортировать тэги в ASX формат, Media Player покажет нужную ссылку на странице инфы о файле.

Кроме того, MMSwitch перезаписывает страницу о плейлисте при открытии любых, а не только AVI файлов. Например, при открытии ASX файла созданного в [image] abcAVI на этой странице должно находиться название списка файлов и инфа о том, с помощью какой версии был произведен экспорт. А MMSwitch сотрет всю эту информацию и плейлист приобретет название, взятое из тэга "Название" текущего файла, либо из имени файла, если тегов нет.

И последняя обнаруженная особенность - при проигрывании списка открытых файлов информацию можно получить только об активном файле, который показывается в данный момент.

Если вас не устраивает такое поведение StreamSwitcher'а, то можно установить предыдущую версию MMSwitch 0.98, которая не помещает информацию из тэгов на страницу инфы о плейлисте.


AVI тэги
Вопрос: А какие тэги поддерживает [image] abcAVI? Все ли они нужны? И вообще, что кроме [image] abcAVI работает с тэгами?

Ответ: abcAVI позволяет редактировать следующие тэги:

Основные тэги
Название
Режиссер
Авторские права
Продукт
Дата создания
Жанр
Второстепенный жанр
Тема
Ключевые слова
Заметки

Оцифровка
Программа
Дата оцифровки
Оцифровщик
Кодировщик
Интернет адрес
Часть
Общее кол-во частей

Титры
Автор сценария
Продюсер
Кинооператор
Постановщик
Монтажер
Композитор
Художник по костюмам
Производство
Страна
По заказу
Дистрибьютер
Язык
Ограничения по возрасту
В ролях

Дополнительная информация
Интернет адрес дополнительной информации
Дополнительная информация
Источник
Исходная форма
Носитель
Источник
Место хранения

Для маньяков
Размеры
Четкость
Палитра
Освещенность
Разрешение, dpi
Обрезано

Для интернет маньяков
URL логотипа
URL мини-логотипа
URL водяных знаков
URL изображения баннера
URL под баннером

Наиболее востребованные тэги - это первые три штуки - "название", "режиссер" и "авторские права". Именно эти тэги показываются в окне MS Media Player'а:

Тэги из стандартного набора INFO тэгов можно просмотреть в свойствах AVI файла в Windows. Расширенный набор INFO тэгов на момент написания ответа полностью поддерживается лишь небольшим количеством программного обеспечения (в основном проги для управления коллекциями файлов). Однако количество программ с полноценной поддержкой всех тэгов постоянно увеличивается.


Не сохраняются теги на вкладке 'Титры'
Вопрос: Я заполнил информацию на странице "Титры", сохранил файл, но вся моя работа почему-то потерялась - при повторном открытии AVI файла оказалось, что теги пустые.

Ответ: Скорее всего работаете в режиме "Стандартный набор INFO тэгов". Зайдите в настройки "Настройки / Чтение и запись тэгов / RIFF INFO тэги" и выберите "Расширенный набор тэгов".


Разные форматы тэгов
Вопрос: В настройках [image] abcAVI я могу указать, теги какого формата записывать в файл. А какая разница между разными форматами тэгов? Какой формат лучше? Я не хочу хранить внутри файла лишнюю информацию.

Ответ: С точки зрения пользователя, а не программиста, разница между форматами заключается в том, сколько программ поддерживают каждый формат, и сколько информации может сохранить каждый из форматов.

Наиболее широко сейчас используется формат RIFF INFO, расширенный набор INFO тэгов - реже, а программ, работающих с IDivX или MovieID практически нет (смотри вопрос о софте).

Разница между исходным набором INFO тэгов и расширенным набором состоит в наличии новых полей, предназначенных для хранения специфичной для видео и кино продукции информации, например о ролевом составе, монтажере, авторе сценария, продюсере, дизайнере и т.д.

Все тэги, которые может редактировать [image] abcAVI, полностью сохраняются только с помощью расширенного набора INFO тэгов. Другие форматы могут сохранить лишь небольшую часть введенной информации (смотри сводную таблицу AVI тэгов).

Так что, если не хочется увеличивать размер редактируемых файлов - отключите запись MovieID и IDivX тэгов.

Смотри также:
· Тэги RIFF INFO
· Расширенный набор INFO тэгов
· Тэги IDivX
· Тэги MovieID


Стандартные INFO тэги
Вопрос: Скажите, пожалуйста, кто разработал INFO тэги, и как они устроены?

Ответ: Стандартный набор INFO тэгов является частью RIFF формата и был разработан в 1991-1993 годах компанией Микрософт в основном для описания графических и аудио файлов. INFO тэги должны находятся в секции LIST INFO внутри AVI файла, хотя некторые программы помещают информацию в другие части AVI файла. Микрософт определил только небольшое количество тэгов, однако была оставлена возможность добавлять новые тэги. Собственно сам тэг является строкой оканчивающейся символом нуля, и практически не имеет ограничения по размеру. Первоначально был определен следующий набор тэгов:

FourCC код | Описание
IARL | Archival Location - место хранения. Показывает, где хранится объект связанный с файлом. Для AVI файлов это чаще всего место хранения исходной записи.
IART | Artist - автор. Список авторов изображенного объекта, например Микилианжело. В случае с AVI файлами - это чаще всего режиссер фильма.
ICMS | Commissioned - заказчик. Список имен людей или названий организаций, по заказу которых было создано исходное произведение. Например, Папа Юлиан II. В случае с видео файлами, это чаще всего название компаний-заказчиков.
ICMT | Comments - комментарий. Этот тэг содержит общие комментарии о файле или исходном произведении. Микрософт предлагал не использовать в описании символы перевода строки, однако большинство программ работающих с тэгами обрабытавает и комментарии состоящие из нескольких строк.
ICOP | Copyright - авторские права. Описание владельцев авторских прав на исходное произведение и дата возникновения авторского права. Например, "Авторские права Международная Энциклопедия, 1991". Если надо записать несколько обладателей авторских прав, разделите их точкой с запятой.
ICRD | Creation date - дата создания. Определяет дату создания исходного произведения. Микрософт предлагал следующий формат даты ГГГГ-ММ-ДД, например 1553-05-03 для 3 мая 1553 года, однако различные программы по разному записывают даты в этот тэг.
ICRP | Cropped - кадрировано. Описывает было ли изображение обрезано и каким образом. Например, "нижний правый угол". Очевидно, этот тэг был внесен для описания графических файлов - репродукций картин
IDIM | Dimensions - размеры. Определяет размер оригинального произведения, например "8 дюймов в высоту, 11 дюймов в ширину". Обычно для описания видео файлов не используется.
IDPI | Dots Per Inch - разрешение, точек на дюйм. В тэг записываются параметры устройства, на котором было оцифровано изображение, например 300. Опять же, тег актуальный только для графических файлов.
IENG | Engineer - специалист. Хранит имена людей, которые работали над созданием данного файла. В случае AVI файлов этот тэг часто хранит имена людей, которые занимались сжатием оцифрованного видео.
IGNR | Genre - жанр. Описывает оригинальное произведение, например, ландшафт, портрет, натюрморт и т.д. В случае AVI файлов это чаще всего боевик, вестерн, комедия и т.п.
IKEY | Keywords - ключевые слова. Список слов, характеризующих исходное произведение. Например, Сиэтл; вид с высоты птичьего полета; пейзаж.
ILGT | Lightness - яркость. Описывает изменения настроек яркости на оцифровывающем устройстве, которые были использованы при создании файла. Формат информации данного тэга зависит от устройства которое было использовано при оцифровке.
IMED | Medium - носитель. Описывает носитель, на котором было сделано оригинальное произведение, например компьютерное изображение, рисунок, литография и т.д. Применительно к видеофайлам носителем чаще всего бывает DVD, VCD, видео кассета, вещание ТВ и т.п.
INAM | Name - название. Содержит название оригинального произведения, например "Матрица: Революция"
IPLT | Palette Setting - палитра. Указывает количество цветов, использованное при оцифровке изображения, например 256. В AVI файлах практически не используется.
IPRD | Product - продукт. Содержит название продукта, для которого было предназначено оригинальное произведение, например "Энциклопедия Британика". В случае AVI файлов данный тэг чаще всего характеризует сам предмет, как то фильм, мультфильм, реклама, анонс фильма, телепередача и т.п.
ISBJ | Subject - тема. Описывает содержимое файла, например "Аэрофотосъемки Сиэтла" или "Проблема отцов и детей как источник увеличивающегося социального расслоения общества".
ISFT | Software - программное обеспечение. Содержит название программ, использованных при создании данного файла, например Microsoft WaveEdit или NanDub.
ISHP | Sharpness - резкость. Описывает изменения настроек резкости на оцифровывающем устройстве, которые были использованы при создании файла. Формат информации данного тэга зависит от устройства которое было использовано при оцифровке.
ISRC | Source - источник. Название организации или имя человека, который предоставил оригинал произведения для создания данного файла. Например, "Телеканал РенТВ".
ISRF | Source Form - исходная форма. Указывает на материал, с которого было оцифровано оригинальное произведение, например, пленка, бумага, карта и т.д. Данный тэг может не совпадать с тэгом IMED - носитель. Например, исходная форма "цифровое видео", а носитель - "диск DVD".
ITCH | Technician - технический специалист. Имя человека, который оцифровывал исходное произведение.
Чуть позже было добавлено еще два тэга, описывающих время оцифровки исходного материала и тайм код источника записи:

FourCC код | Описание
IDIT | Дата и время начала оцифровки. Дата и время должны быть записаны как ASCII строка длиной 26 символов следующего формата "Wed Jan 02 02:03:55 1990\n\0". Для создания такой строки можно использовать функции ctime и asctime.
ISMP | Этот тэг хранит метку времени SMPTE для начала записи. Метка времени - это ASCII строка следующего формата HH:MM:SS.FF и уникальна для каждого кадра в видео последовательности. Тэг ISMP обычно соответствует метке времени для первого кадра захватываемой последовательности кадров, взятой с оригинального источника.

Из-за того, что тэги представляют собой обычные текстовые строки, оказалось невозможным жестко контролировать формат данных, хранящихся внутри тэгов. В результате получилось, что дата создания может быть записана не только в виде ГГГГ-ММ-ДД, для разделения ключевых слов используются запятые вместо точек с запятой, а тэг с комментариями может содержать несколько строк. Однако, тэги изначально предназначены исключительно для информационных целей, и программы не должны использовать их как источник информации при отображении содержимого файлов. Короче говоря - тэги нужны для того, чтобы их читали люди, пишут их тоже люди, так что ежели программы не могут разобрать содержимое тэгов - это проблема программ.

Приведенный выше набор тэгов не самым лучшим образом подходит для описания содержимого видео файлов. Конечно, есть тэги для названия и авторских прав, но негде сохранить информацию об актерах, операторе, композиторе, монтажере и многих других... В результате был разработан расширенный набор INFO тэгов.


Расширенный набор INFO тэгов
Вопрос: А чем отличается расширенный набор INFO тэгов от стандартного? И зачем он нужен?

Ответ: Расширенный набор INFO тэгов включает в себя все стандартные тэги, и определяет три десятка новых тэгов добавленных специально для описания видео файлов.

Дело в том, что стандартный набор тэгов был разработан для хранения информации о графических и аудио файлах и не позволял подробно описать видео информацию.

В результате анализа уже имеющихся альтернативных форматов тэгов (MovieID и IDivX) и баз данных по фильмам были предложены следующие тэги:

FourCC код | Описание
ICDS | Costume Designer - художник по костюмам.
ICNM | Cinematographer - кинооператор
ICNT | Country - страна, где находятся студии, создавшие фильм. В случае совместного производства указывается несколько стран.
IDST | Distributed by - дистрибьютор, он же распространитель. Название компании, официально уполномоченной заниматься распространение фильма на какой-либо территории. Обычно дистрибьютеров бывает несколько: в каждой стране свой.
IEDT | Edited by - монтажер. Имя человека монтировавшего фильм или возглавляющего отдел монтажа.
IENC | Encoded by - кодировщик. Имя человека занимавшегося сжатием оцифрованного видео при создании AVI файла.
IFRM | Total Number of Parts - общее количество частей. В случае, если сжатый фильм находится на нескольких носителях, данный тэг хранит общее количество частей фильма.
ILNG | Language - язык. Данный тэг предназначен для хранения информации о том, какие языки были использованы в оригинальной озвучке фильма. Не путайте, пожалуйста, с языком перевода - для этого есть целый ряд тэгов IAS1-IAS9.
IMUS | Music by - композитор. Имя человека, написавшего музыку для фильма. В случае, если в фильме звучит музыка различных композиторов, этот тэг содержит имена всех авторов исходных музыкальных произведений.
IPDS | Production Designer - постановщик
IPRO | Produced by - продюсер. Имя человека занимавшегося продюсированием фильма. Продюсеров несколько, их имена указываются через запятую.
IPRT | Part - номер части. В случае, если сжатый фильм находится на нескольких носителях, то этот тэг указывает номер текущей части.
IRIP | Ripped by - оцифровщик. Этот тэг используется для указания имени человека занимавшегося непосредственно "рипованием" DVD диска, то есть снятием защиты и перенесением видео на другой носитель.
IRTD | Rating - ограничения. Этот тэг хранит информацию о возрастных ограничениях на просмотр фильма. Содержимое тэга зависит от того, рейтинг какой страны был использован. Чаще всего здесь записан рейтинг USA: G, PG, PG-13, R, NC-17, Unrated.
ISGN | Secondary Genre - второстепенный жанр. Тег введен для более точного описания жанра фильма и используется совместно с тэгом IGNR. Таким образом удается формально описать сложные жанры типа "комедийный боевик" (основной жанр - боевик, второстепенный - комедия).
ISTD | Production Studio - студия производитель
ISTR | Starring - в ролях. В данном теге указываются имена людей, игравших в фильме. Чаще всего этот тэг содержит информацию только по ролям первого и второго плана, однако ничто не мешает сохранить в этом тэге полный список ролей. Так же этот тэг может содержать имя человека, занимавшегося подбором актеров. Информация записывается в следующем формате - "имя актера (сыгранная роль); имя второго актера (вторая роль)". Имена актеров могут быть разделены символом перевода строки.
IWEB | Internet Address - интернет адрес. Адрес ресурса, связанного с данным видео файлом. Обычно это сайт компании или людей предоставивших данный видео файл.
IWRI | Written by - автор сценария. Этот тег содержит имена сценаристов и авторов первоначальной идеи. В случае, если фильм снят на основе какой-либо книги, то этот тэг содержит информацию и по автору исходного произведения.

Далее были добавлены десять тэгов, введенных программой Morgan Multimedia Stream Switcher для описания языков аудио потоков:

FourCC код | Описание
IAS1 | First language - язык первого аудио потока. Этот тэг хранит либо строку на английском языке, либо цифровой код языка. Например "english", "russian", 0401 и т.п.
IAS2 | Second language - язык второго аудио потока
IAS3 | Third language - язык третьего аудио потока
IAS4 | Fourth language - язык четвертого аудио потока
IAS5 | Fifth language - язык пятого аудио потока
IAS6 | Sixth language - язык шестого аудио потока
IAS7 | Seventh language - язык седьмого аудио потока
IAS8 | Eighth language - язык восьмого аудио потока
IAS9 | Ninth language - язык девятого аудио потока
ICAS | Default audio stream - номер потока, используемого по умолчанию
Немного позже Guillaume de Bailliencourt (автор MMStreamSwitcher) предложил добавить для совместимости с интерфейсом IAMMediaContent еще восемь тэгов:

FourCC код | Описание
IBSU | Base URL - основной интернет адрес. Обычно здесь хранится адрес официального сайта фильма или адрес компании, выпустившей фильм.
ILGU | Logo URL - URL логотипа
ILIU | Logo Icon URL - URL мини-логотипа
IMBI | More Info Banner Image - URL картинки банера
IMBU | More Info Banner URL - URL под банером
IMIT | More Info Text - дополнительная информация. Обычно сюда помещается второстепенная информация о фильме: о том, как и где его делали, саундтрек, интересные заметки и т.п.
IMIU | More Info URL - ссылка на сайт с дополнительной информацией. Адрес сайта с информацией о фильме - часто официального сайта фильма.
IWMU | Watermark URL - URL водяных знаков. Этот тэг используется, если видео файл содержит цифровые водяные знаки.


IDivX тэги
Вопрос: А чем так хороши IDivX тэги? И зачем столько разных форматов AVI тэгов?

Ответ: К достоинствам IDivX тэгов относится только их относительная простота. Все IDivX тэги занимают ровно 128 байт в конце AVI файла и могут быть быстро добавлены к любому файлу. Сделаны они были по образу и подобию ID3 тэгов первой версии для MP3 файлов.

Однако у них есть врожденные недостатки - жестое ограничение на количество информации, хранимой в тэгах. Кроме того, эти тэги не совместимы с INFO тегами и нарушают структуру файла RIFF формата.

Формат IDivX 0.1 был предложен в 2001 году неким Грегом Фрайзером (Greg Frazier / DSG) как открытый формат подписывания AVI файлов. Блок содержащий тэги имеет длину 128 байт, место между тэгами распределяется следующим образом:

Положение
Длина
Тип данных
Описание
1..32
32
array [1..32] of char
Название фильма
33..60
28
array [1..28] of char
Имя автора фильма
61..64
4
array [1..4] of char
Год создания фильма
65..112
48
array [1..48] of char
Комментарий
113..115
3
array [1..3] of char
Жанр
116
1
byte
Ограничения по возрасту, система RIAA
117..121
5
array [1..5] of char
пустое место, оставлено на будущее
122..128
7
array [1..7] of char
Подпись "DIVXTAG"

Из этого следует, что если, например, название фильма короче 32 смволов, его надо дополнить до необходимой длины пробелами или символами #0.

Все тэги записываются в виде ASCII строк, единственное исключение - ограничения по возрасту, которые хранятся как байт. Байт ограничений по возрасту может принимать следующие значения:

Значение
Описание
0
Unrated - не проходило оценку
1
G - без ограничений
2
PG - до 13 со взрослыми
3
PG-13 - до 13 запрещено
4
R - до 17 со взрослыми
5
NC-17 - до 17 запрещено

Жанр фильма хранится в ASCII строке в виде трехзначного числа и может принимать следующие значения:

Значение
Жанр
000
Action - боевик
001
Action/Adventure - приключенческий боевик
002
Adventure - приключения
003
Adult - эротика/порно
004
Anime - аниме
005
Cartoon - мультфильм
006
Claymation - мыльная опера
007
Comedy - коммедия
008
Commercial - реклама
009
Documentary - документальный
010
Drama - драма
011
Home Video - домашнее видео
012
Horror - ужастик
013
Infomercial - обучающий
014
Interactive - интерактивное шоу
015
Mystery - мистика
016
Music Video - музыкальный
017
Other - другой жанр
018
Religion - религиозный
019
Sci Fi - научная фантастика
020
Thriller - триллер
021
Western - вестерн

Для того, чтобы IDivX тэги были совместимы с RIFF форматом, надо поместить их в RIFF контейнер. FourCC код, определяющий блок IDviX тэгов это - IDVX, длина RIFF контейнера - 128 байт. Выглядит это как добавление 8 байт заголовка перед IDivX тэгами:

Положение
Длина
Тип данных
Описание
1..4
4
array [1..4] of char
FourCC код IDivX тэгов, равен "IDVX"
5..8
4
longword
Длина блока информации с тэгами - 128
9..136
128
см. устройство IDivX тэгов
IDivX тэги


MovieID тэги
Вопрос: Расскажите, пожалуйста, о тэгах MovieID. Какие программы поддерживают эти тэги?

Ответ: Этот формат очень похож на INFO тэги, информация хранится в специальном LIST разделе. Список называется 'MID ', устроен так же как 'INFO' секция, однако должен находится в конце файла, то есть после секции 'movi' и 'idx1'. Автор формата пишет, что записывать тэги в конец файла он решил, так как в противном случае придется переписывать весь файл, а это будет очень долго. Автор был не совсем прав - можно использовать место занятое секциями-затычками (JUNK), ну да ладно. :))

The MID-Tag is located directly behind the AVI Index (idx1-chunk). If it would be written to the top of the AVI-file, it would take a lot of time because the whole file has to be written new.

Формат позволяет записывать следующие тэги:

FourCC код | Описание
AGES | Возрастные ограничения
CODE | Кодировщик
COMM | Комментарий
DIRC | Режиссер
GENR | Жанр
LANG | Язык
PRT1 | Номер части
PRT2 | Общее количество частей
STAR | В ролях
TITL | Название
YEAR | Год создания

Родной сайт формата - http://www.mid-tag.com. Там же находится программа для редактирования MovieID тэгов.

Несовместимость формата со стандартными INFO тегами предопределила его судьбу - сейчас практически отсутствуют какие-либо программы, поддерживающие этот формат.


Сводная таблица AVI тэгов
Вопрос: Перечислите, пожалуйста, все AVI тэги разом. Хочется посмотреть, что к чему и самому сравнить различные форматы.

Ответ: Подробно сравнить возможности каждого из форматов можно с помощью сводной таблицы AVI тэгов:

Расширеный набор INFO тэгов |  | Стандартный набор INFO тэгов |  | Тэги MovieID |  | Тэги IDivX
Место хранения | IARL | Место хранения | IARL |  |  |  |
Режиссер | IART | Автор | IART | Режиссер | DIRC | Автор | 33..60
По заказу | ICMS | По заказу | ICMS |  |  |  |
Комментарий | ICMT | Комментарий | ICMT | Комментарий | COMM | Комментарий | 65..112
Авторские права | ICOP | Авторские права | ICOP |  |  |  |
Дата создания | ICRD | Дата создания | ICRD | Год создания | YEAR | Год | 61..64
Обрезано | ICRP | Обрезано | ICRP |  |  |  |
Размеры | IDIM | Размеры | IDIM |  |  |  |
Разрешение, dpi | IDPI | Разрешение, dpi | IDPI |  |  |  |
Инженер-механик | IENG | Инженер-механик | IENG |  |  |  |
Жанр | IGNR | Жанр | IGNR | Жанр | GENR | Жанр | 113..115
Ключевые слова | IKEY | Ключевые слова | IKEY |  |  |  |
Яркость | ILGT | Яркость | ILGT |  |  |  |
Носитель | IMED | Носитель | IMED |  |  |  |
Название | INAM | Название | INAM | Название | TITL | Название | 1..32
Цветность фильма | IPLT | Настройки палитры | IPLT |  |  |  |
Продукт | IPRD | Продукт | IPRD | Жанр | GENR | Жанр | 113..115
Тема | ISBJ | Тема | ISBJ |  |  |  |
Программа | ISFT | Программа | ISFT |  |  |  |
Резкость / четкость | ISHP | Резкость / четкость | ISHP |  |  |  |
Источник | ISRC | Источник | ISRC |  |  |  |
Исходная форма | ISRF | Исходная форма | ISRF |  |  |  |
Техник-оцифровщик | ITCH | Техник-оцифровщик | ITCH |  |  |  |
Дата и время начала оцифровки | IDIT | Дата и время начала оцифровки | IDIT |  |  |  |
Метка времени SMPTE начала записи | ISMP | Метка времени SMPTE начала записи | ISMP |  |  |  |
Художник по костюмам | ICDS |  |  |  |  |  |
Кинооператор | ICNM |  |  |  |  |  |
Страна-производитель | ICNT |  |  |  |  |  |
Дистрибьютер / распространитель | IDST |  |  |  |  |  |


Есть ли тэги в DVD
Вопрос: Кроме коллекционирования фильмов, я сейчас занялся риппованием DVD на компакт-диски. Поэтому у меня возникают вопросы:
а). Есть ли тэги в DVD формате?
б). Есть ли программы, которые позволяют их увидеть?
в). Есть ли программы, которые позволяют перенести тэги из DVD в *.avi файл?

Ответ: Тэгов вроде нет, но обычно на DVD идет большое количество сопутствующей информации в текстовом и графическом виде, которую можно и нужно попытаться разместить в AVI тэгах. Так как исходный формат инфы на DVD - простой текст, то автоматизировать заполнение AVI тэгов вряд ли получится.

Кроме того, на DVD часто имеются субтитры. На этот случай существует целый класс утилит для автоматизированного выдирания субтитров и вклеивания их внутрь AVI файлов (как в виде текста, так и в графическом виде).


Тэги для файлов других форматов
Вопрос: В моей коллекции, кроме собственно файлов формата *.avi есть и диски формата videocd и файлы с расширением *.mpg, *.mpeg, *.rm . Определение характеристик этих файлов я делаю с помощью разнообразных плейеров, причем каждый плейер позволяет определить лишь какой-то свой набор характеристик и не дает их полного набора. Поэтому я хочу Вас спросить: есть ли другие программы, аналоги Вашей, которые могут помочь мне? Или, быть может, Ваша программа научится это делать? Или, быть может, Вы напишете для этого новую программу?

Ответ: Полного аналога я, к сожалению, не знаю. Однако есть активно развивающаяся библиотека на PHP, которая помогает вытаскивать технические характеристики из мультимедиа файлов - GetID3. У меня есть желание сделать более универсальную утилиту, поддерживающую не только AVI формат, однако это будет скорее всего другая программа - [image] abcAVI устроена внутри так, что поддержку нового формата файлов включить очень сложно. Это следствие того, что исходно программа проектировалась исключительно как редактор тэгов для AVI файлов.


Использованные инструменты
Вопрос: А на чем написана программа?

Ответ: При создании [image] abcAVI Tag Editor'а были использованы следующие инструменты:

Borland Delphi 5.0 - мощная среда для быстрой разработки программ
VCL Toolbar2000 by Jordan Russell - компопнент для создания панели инструментов
VCL TDCTree by Dream Company - быстрый компонен TreeView
VCL Internet Direct (Indy) 9.0 - набор компонентов для работы с Интернетом (реализована куча современных протоколов связи)
VCL TMemoEx by TMemoEx.com team - компонент Memo без ограничений на размер текста
Inno Setup Wizard - гибкий инструмент для создания установочных дистрибутивов

К указанным выше инструментам был приложен джентельменский набор разработчика:

Brain.sys
Internet.inf
Hands.drv


Алгоритмы расчета битрейтов
Вопрос: Я только недавно начал работать с AVI и DivX файлами. У меня есть вопрос по части битрейтов, которые показывает [image] abcAVI Tag Editor. abcAVI показывает вычисленные значения или они хранятся где-то внутри файла? И если вычисляет, то как?

Ответ: В заголовке AVI файла содержится достаточно много информации, но, к сожалению, не вся желаемая... Например, отсутствует инфа о битрейте видео потока, что является основным недостатком. Кроме того, на основе базовых технических параметров можно рассчитать ряд второстепенных характеристик, например, степень сжатия видео.

Есть несколько способов вычислить видео битрейт. Первый - подсчитать его на основе информации из заголовка файла. При этом отталкиваются от величины битрейта аудио потока. Однако точность такого рода вычислений оставляет желать лучшего. Другой - прочесать индексную секцию файла, которая содержит точный размер каждого кадра видео и блока аудио. Второй способ гораздо точнее, но времени на вычисление требуется сильно больше - для файла размером 700 мегабайт индексная секция может занимать до пяти мегабайт, а заголовок AVI - это около 10 килобайт.

Расчет скорости воспроизведения видео и аудио на основе информации из заголовка AVI файла

· FramesPerSec - скорость видео (кадр/секунда)
· dwRate - темп (кадр/секунда)
· dwScale - масштаб (---)

· BlocksPerSec - скорость аудио (блок/секунда)
· dwRate - темп (блок/секунда)
· dwScale - масштаб (---)

Расчет видео и аудио битрейтов на основе информации из заголовка AVI файла (без сканирования всего файла)

· SizeOfAudio - суммарный размер аудио (байт)
· CountOfAudioStreams - количество аудио потоков (---)
· nAvgBytesPerSec - средний аудио поток (байт/секунда)
· dwLength - длина аудио (блок)
· BlocksPerSec - скорость аудио (блок/секунда)

· SizeOfHeaders - размер служебной информации в "movi" секции (допускаем, что чередование аудио и видео информации - VAVAVAЕ либо в случае нескольких аудио потоков VA1A2VA1A2Е)
· dwTotalFrames - общее количество кадров видео (допускаем, что длительности аудио и видео одинаковые)
· BytesPerFrameHeader - кол-во байт для хранения заголовка кадра в "movi" секции (8 байт/кадр)
· CountOfAudioStreams - количество аудио потоков (---)

· SizeOfVideo - суммарный размер видео (байт)
· MoviChunkSize - размер секции "movi" (байт)
· SizeOfAudio - суммарный размер аудио (байт)

· AudioKilobitsPerSec - средний аудио поток (килобит/секунда)
· nAvgBytesPerSec - средний аудио поток (байт/секунда)

· VideoKilobitsPerSec - средний видео поток (килобит/секунда)
· SizeOfVideo - суммарный размер видео (байт)
· FramesPerSec - скорость видео (кадр/секунда)
· dwTotalFrames - общее количество кадров видео (кадр)

Расчет точных видео и аудио битрейтов на основе сканирования idx1 секции

· SizeOfVideo - суммарный размер видео (байт)
· CountOfIndexEntries - общее количество элементов в секции idx1 (---)
· ckid - тип данных элемента в movi секции (00dc - первый поток, сжатое видео) (---)
· dwChunkLength - длина элемента данных в movi секции (байт)

· SizeOfAudio - суммарный размер аудио (байт)
· CountOfIndexEntries - общее количество элементов в секции idx1 (---)
· ckid - тип данных элемента в movi секции (0xwb - все аудио потоки) (---)
· dwChunkLength - длина элемента данных в movi секции (байт)

· VideoKilobitsPerSec - средний видео поток (килобит/секунда)
· SizeOfVideo - суммарный размер видео (байт)
· FramesPerSec - скорость видео (кадр/секунда)
· dwTotalFrames - общее количество кадров видео (кадр)

· AudioKilobitsPerSec - средний аудио поток (килобит/секунда)
· SizeOfAudio - суммарный размер аудио (байт)
· BlocksPerSec - скорость аудио (блок/секунда)
· dwTotalBlocks - общее количество блоков аудио (блок)

Расчет описательных характеристик видео потока

· EffBitsPerPixel - сжатие видео (бит/точка)
· VideoKilobitsPerSec - средний видео поток (килобит/секунда)
· dwWidth - ширина кадра видео (точка)
· dwHeight - высота кадра видео (точка)
· FramesPerSec - скорость видео (кадр/секунда)

· VideoCompression - сжатие видео (%)
· EffBitsPerPixel - сжатие видео (бит/точка)
· BitsPerPixel - глубина цвета видео (бит/точка)

· PowerOfVideoCompression - степень сжатия видео (---)
· BitsPerPixel - глубина цвета видео (бит/точка)
· EffBitsPerPixel - сжатие видео (бит/точка)

· QualityOfVideo - эффективное качество видео (бит/кадр 3х4) - допускаем, что исходный кадр подгоняется под размер экрана 3х4 без искажения пропорций.
· dwWidth - ширина кадра видео (точка)
· dwHeight - высота кадра видео (точка)
· VideoKilobitsPerSec - средний видео поток (килобит/секунда)
· FramesPerSec - скорость видео (кадр/секунда)


Пропорции кадра
Вопрос: А как [image] abcAVI определяет пропорции кадра?

Ответ: В первую очередь расчитывается соотношение сторон кадра - ширина/высота, а потом подбирается наиболее близкое значение из таблицы известных пропорций. Таблица эта представляет собой отчет по базе AMDbFront, и собрана на основе характеристик более чем 60.000 фильмов:

Соотношение сторон | Пропорция | Количество фильмов
1,00 | 1x1 | ---
1,20 | 5x6 | 94
1,33 | 3x4 | 20465
1,36 | 11x15 | 1521
1,37 | 19x26 | 24223
1,44 | 9x13 | 196
1,50 | 2x3 | 12
1,66 | 3x5 | 2008
1,75 | 4x7 | 123
1,78 | 9x16 | 1123
1,85 | 13x24 | 5682
1,96 | 23x45 | 56
2,00 | 1x2 | 93
2,20 | 5x11 | 157
2,35 | 17x40 | 7260
2,55 | 11x28 | 130

Кстати, из таблицы видно, что пятерка самых распространенных форматов фильмов получается следующая: 1.37; 1,33; 2,35; 1,85 и 1,66.


Чередование потоков в AVI файле
Вопрос: А как просмотреть реальное чередование потоков внутри AVI файлов? Я слышал, что NanDub и VirtualDub имеют разные алгоритмы чередования.

Ответ: Для этого надо указать в настройках "Показывать структуру movi раздела". Однако открытие больших файлов в таком режиме может быть очень долгим (до нескольких минут), так что не забудте вернуть настройки в исходное положение.

Различие в чередовании видно только на файлах, в которых имеется MP3 аудио дорожка с переменным битрейтом. VirtualDub всегда чередует потоки "один блок аудио - один кадр видео", в то время как NanDub вставляет аудио блоки, ориентируясь на структуру MP3 потока. В результате NanDub создает файлы, в которых средняя частота получается 38,28125 блоков в секунду, независимо от количества кадров видео в секунду.


Формат AVI файлов
Вопрос: А как устроен AVI файл?

Ответ: AVI файлы - это файлы формата RIFF (Resource Interchange File Format). RIFF это стандарт, введенный компанией Microsoft для хранения мультимедийной информации. RIFF файлами так же являются звуковые WAV файлы, MIDI файлы, файлы иконок и курсоров ICO и ANI и т.д.

AVI файл содержит четырехзначный код (FourCC) 'AVI ' в начале файла. Каждый AVI файл должен состоять как минимум из двух обязательных LIST разделов. Первый определяет формат видео и/или аудио потоков, а второй содержит данные для этих потоков. Кроме того, AVI файл может иметь индексную секцию, в которой описывается расположение всех фрагментов аудио и видео данных.

Все LIST секции являются подразделами главной RIFF 'AVI ' секции. Раздел LIST 'hdrl' определяет формат потока данных, и может присутствовать в нескольких экземплярах - по количеству аудио и видео потоков. Второй обязательный раздел - LIST 'movi' содержит чередующиеся блоки данных аудио и видео потоков. Наконец раздел 'idx1' содержит таблицу смещений и размер аудио и видео блоков. Все три раздела должны находится в указанном выше порядке. Разделы LIST 'hdrl' и LIST 'movi' содержат данные в виде подразделов. Необязательный раздел LIST 'INFO' содержит текстовую информацию о содержимом AVI файла и может находится практически в любом месте файла (обычно - после раздела LIST 'hdrl').

RIFF ('AVI '
      LIST ('hdrl'
            'avih'(<Главный заголовок AVI>)
            LIST ('strl'
                  'strh'(<Заголовок потока>)
                  'strf'(<Формат потока>)
                  'strd'(<Дополнительные данные заголовка>)
                  'strn'(<Название потока>)
                  ...
                 )
            ...
           )
      LIST ('INFO'
            'INAM'(<Название фильма>)
            'IART'(<Автор (режиссер фильма)>)
            'ICOP'(<Авторские права>)
            ...
           )
      LIST ('movi'
            ...(<Видео и аудио данные>)
           )
      'idx1'<Индексная секция>
     )


Техническая документация
Вопрос: Какой информацией вы пользовались, когда писали свою программу? И где достать информацию о тэгах MovieID IDivX? Дело в том что есть громадный архив фильмов и БД (собственная) с описанием, хотелось бы встроить функции экспорта описаний из БД в AVI. Cо стандартными тэгами вроде как все пронятно о них есть инфа в Multimedia Programming Interface а вот с MovieID IDivX не могу пока найти информацию.

Ответ: Тэги MovieID и IDivX - это два разных формата. IDivX сделан по образу и подобию ID3 1.0 для MP3 и имеет все соотвествующие недостатки (жесткое ограничение на размер сохраняемой инфы). MovieID - формат, который не имеет таких ограничений по размеру (автор пишет, что ограничений нет совсем, но тут он чуток преувеличивает). Однако MovieID не получил широкого распространения, так как он не совместим со стандартными информационными тэгами RIFF INFO формата. В результате был предложен расширенный набор INFO тэгов, который включает в себя все RIFF INFO тэги и позволяет подробно описать видео файлы.

На счет документации. Во время создания [image] abcAVI была накоплена маленькая библиотечка документов. Вся она выложена на сайте http://abcavi.tk (как вариант - http://abcavi.da.ru), здесь же я приведу только список:

· DV Data in the AVI File Format (HTM)
· RFC 2361 "WAVE and AVI Codec Registries" (TXT)
· Video For Windows Programmer's Guide (HLP), 1992-1993
· Specification of the Broadcast Wave Format (PDF), July 1997
· Multimedia Registration Kit revision 3.0, April 15, 1994
· Microsoft Multimedia Standards Update, rev 2.0 (DOC), March 13, 1993
· Microsoft Multimedia Standards Update, rev 3.0 (PDF), April 15, 1994
· OpenDML AVI File Format Extensions (PDF), February 28, 1996
· The Microsoft Audio/Video Interleaved (AVI) file format (DOC), 02/10/1993

Кроме того, хорошим подспорьем являлись исходники стандартных Мелкомягких библиотек написанные на C, откуда было вытащено множество информации о всевозможных константах и флагах:

· AVIFMT.H - библиотека для поддержки AVI формата
· MMSYSTEM.H - библиотека Multimedia API
· MMREG.H - библиотека Multimedia Registration
· AVIFILE.H - библиотека разбора стандартных AVI файлов

Смотри также:
· Обзор строения AVI файлов
· Тэги RIFF INFO
· Расширенный набор INFO тэгов
· Тэги IDivX
· Тэги MovieID


abcAVI DLL
Вопрос: Я создаю небольшую базу данных по фильмам и хотел бы использовать функции из вашей программы. Не могли бы вы выслать исходный код процедуры получения информации об AVI файлах?

Ответ: Как раз для вашего случая была написана и опубликована с открытым исходным кодом DLL библиотека, реализующая чтение и запись AVI тэгов. Первая версия этой библиотеки умела работать только с текстовыми тэгами, однако вторая версия содержит полноценные процедуры анализа AVI файлов и записи тэгов. Библиотека представляет собой COM сервер (объект OLE automation), так что ее можно использовать при программировании на любом языке, поддерживающем технологию COM/OLE.

Скачать DLL вместе с ее исходным кодом и примером использования можно на сайте http://abcavi.tk. Там же находится справка по использованию этой библиотеки.

Если вы найдете ошибку в исходном коде библиотеки, то пришлите, пожалуйста ее описание на адрес avitags@mail.ru, чтобы я ее мог исправить в будущих версиях библиотеки.


История написания
Вопрос: А откуда пришла идея написания вашей утилиты?

Ответ: В начале 2002 года я столкнулся с необходимостью как-то упорядочить достаточно большую коллекцию видео записей AVI формата (около 200 записей моей любимой телевизионной передачи "Тушите Свет"). С одной стороны мне было нужно составить список имеющихся у меня записей, причем желательно с детальным описанием как технических характеристик, так и темы передачи, списка участников, даты выпуска и т.п. А с другой стороны, мне хотелось подписать каждую запись таким образом, чтобы при проигрывании в видеоплеере высвечивалась хотя бы краткая информация о записи (название, автор и авторские права).

Поиски в Интернете не привели к сколь-нибудь удовлетворительному результату - нужной мне программы на тот момент просто не существовало. Точнее кое-что я нашел... Например, что программа NanDub позволяет сохранить текстовую информацию в видео файле, но для этого надо сделать столько пассов руками, что... Да к тому же NanDub теряет текстовую информацию записанную в AVI ранее... Так же обнаружилась программа для просмотра информации о видео файлах - AVI Info. Но эта программа из-за какого-то глюка не записывала новые поля "Автор", "Авторские права" и т.д., а позволяла изменять только существующие значения... Были обнаружены две программки "MovieIDentifier - Tag Editor" и "IDivX Tag Editor", которые позволяли и читать и писать текстовые тэги, но исключительно в своем формате, несовместимом с Media Player'ом... То есть вроде как информация в файле есть, но прочитать ее можно только с помощью этих утилит... В общем, обнаружился разброд и шатание в рядах видео софта для подписывания AVI файлов.

В результате переписки с авторами сайта Divx-Digest.com (этот сайт содержит одну из самых полных коллекций программ для работы с видео) мои опасения были подтверждены - полноценная программа для редактирования текстовой информации внутри AVI файлов еще не обнаружена. Товарищи посоветовали попробовать написать свой вариант, коли мне это так нужно, с чем я и согласился. Через месяц работы я выпустил первый релиз редактора тэгов, назывался он "Total AVI Tags Editor" - потому как в него была встроена поддержка всех обнаруженных мной форматов записи тэгов (RIFF INFO, MovieID и IDivX). Кроме того я позволил себе смелость несколько расширить набор RIFF INFO тэгов от Microsoft, включив специфичные для видео записей текстовые поля (например "В ролях", "Продюсер", "Автор сценария" и т.д.). Смена названия на [image] abcAVI Tag Editor, год работы по вечерам и выходным, несколько релизов и в итоге получилось то, что вы установили на своей машине. :))


Планы на будущее
Вопрос: ...мне в программе не хватает того-то и того-то. А когда будет сделана такая-то вещь?

Ответ: Привожу список функций, которые могут появится в следующих версиях [image] abcAVI Tag Editor'а:

· Редактирование TwoCC кодов аудио формата.
· Получение информации о фильмах из различных сайтов (не только IMDb).
· Импорт информации напрямую из SQL базы данных AMDbFront
· Работа с файлами большого объема (более 2 гигабайт).
· Функция глобального отката (возврат в исходное состояние изменененных ранее файлов).
· Работа с файлами других форматов (не только AVI).
· Мастер экспорта и/или визуальное редактирование шаблонов экспорта

Точной даты выхода, к сожалению, не могу определить: abcAVI - некоммерческий проект, соотвественно, работы в его рамках ведутся в свободное от основной работы время.


Перевод интерфейса
abcAVI Tag Editor имеет многоязычный интерфейс (со сменой языка "на лету"). Сответственно, вы можете помочь этому проекту переведя интерфейс программы на свой родной язык, например украинский или белорусский. Если вы считаете себя экспертом по какому-либо языку, вы также можете откорректировать уже существующие версии интерфейсов.

INI файлы, содержащие описание интерфейса [image] abcAVI находятся в папке "/abcAVI/language" на вашем компьютере. Наиболее полные переводы - английский и русский, так что лучше всего использовать для основы именно их.

Пожалуйста, переведите на свой язык все строчки INI файла (за исключением описаний кодеков - их можно оставить как есть). Я могу не знать языка, на который вы переведете интерфейс [image] abcAVI, однако уверен, что пользователи будут рады получить полный, а не частичный перевод на родном языке. Пользуйтесь программами проверки орфографии для вашего языка - это сильно увеличит качество перевода и уберет досадные опечатки.

И еще одна просьба - проверьте ваш перевод на предмет того, как он смотрится в программе. Некоторые длинные строчки могут быть обрезаны при отображении, в таком случае используйте сокращения или более короткий вариант перевода.

Для перевода ini-файлов вы можете воспользоваться специальной программой "Translator", написанной Джернеем Симоником. Загрузить последнюю версию этой программы можно с его домашней страницы.

При переводе можно оставлять некоторые переменные неизменными (обычно - описания кодеков). В программе такие переменные будут отображены в английском варианте. Новые или отредактированные старые INI файлы отправляйте на адрес avitags@mail.ru.


Шаблоны
Если вы создали новый и полезный шаблон экспорта и хотите поделится им с другими пользователями [image] abcAVI Tag Editor'a, то пришлите его на адрес avitags@mail.ru, - с большой вероятностью он будет включен в дистрибутив [image] abcAVI.

Кроме того вы можете перевести существующие шаблоны на свой язык, и выслать измененные шаблоны. Файлы шаблонов имеют расширение .exp и находятся в директории "abcavi\template".


Поддержка AVI тэгов
Если вы являетесь разработчиком программы, работающей с AVI файлами (например, проигрывателя AVI, видео редактора, менеджера фильмов и т.д.), то вы можете включить поддержку расширенного набора INFO тэгов (Extended INFO tags) в ваш продукт.

Если вы делаете видео плеер, то поддержка тэгов - это показывание (и возможно правка) информации из тэгов в свойствах видео файла. Если вы работаете на видео редактором, то минимальная поддержка - это сохранение при перезаписи AVI файлов уже имеющихся в них тэгов, а оптимальная - дать пользователю возможность исправить теги при записи файлов. Если же вы создаете программу для ведения видео коллекции, то поддержка - это импорт информации из тэгов при добавлении файла в базу данных.

 | Сохранение тэгов при перезаписи файлов | Чтение тэгов | Запись тэгов | Редактирование тэгов пользователем
Видео плееры | - | + | - | -
Редакторы видео | + | + | + | +
Видео базы данных | + | + | + | -
Редакторы тэгов | + | + | + | +
Поисковые системы | - | + | - | -

Тэги дают возможность удобно сохранять внутри AVI файлов текстовую информацию, причем сохранять ее в машинно-ориентированном виде. То есть вместо одного большого куска текста используется множество различных полей. Фактически, каждый AVI файл может содержать структурированную запись из базы данных.

Таким образом AVI файлы созданные с помощью вашей программы будут содержать мета информацию пользователя. А если видео файл содержит мета информацию, то становится возможным автоматизированное индексирование видео файлов по содержимому (поиск по ключевым словам), создание больших видео коллекций с описаниями, ведение баз данных с описаниями фильмов и т.д.

Быстро добавить поддержку тэгов можно с помощью DLL библиотеки [image] abcAVI.DLL (COM, OLE Automation совместимая). abcAVI.DLL распростряняется с исходным кодом на условиях лицензии GNU Lesser General Public License, то есть вы можете использовать ее как в коммерческих, так и в некоммерческих проектах.


История программы
(-) Исправлена ошибка в abcAVI.dll, приводящая к большим задержкам при переименовании AVI файлов с установленным расширением оболочки Windows [image] abcAVI Info Tips.
(-) Исправлена русскоязычная справка - на некоторых системах содержание отображалось неверно - все кирилические символы заменялись квадратиками.
(*) Доработан алгоритм анализа файлов в abcAVI.dll - файлы с расширением .avi, не являющиеся нормальными AVI файлами, а например MPEG файлами, теперь обрабатываются гораздо быстрее.
(*) Подпись в JUNK секции остаётся в одном экземпляре (раньше повторялась каждые 256 байт)

abcAVI Tag Editor 1.8
25 марта 2004

(-) Исправлен баг - при нажатии на кнопку "Сохранить все файлы" сохранялись все файлы, в том числе и открытые в режиме "только для чтения"
(-) Индикатор загрузки файлов соответствует количеству открытых файлов (раньше два последних файла открывались на 100%)
(-) Исправлено отображение имени файла при открытии множества файлов
(-) Исправлен глюк range check error при открытии несуществующих файлов.
(-) Исправлен глюк range check error при открытии битых файлов.
(-) Все биты ASCII символов запроса IMDb передаются без изменений (раньше передавались только 7 бит)
(-) Кнопка "Начать" в Центре сообщений не работала до первой отправки сообщений.
(-) При создании директории при экспорте вылетала ошибка при наличии символов '/' в нужном пути. Теперь все такие символы принудительно заменяются на '\'
(*) Автоматическое переключение на закладку "Импорт" после создания нового запроса происходит только когда эта закладка видна.
(*) Кнопка "Запустить центр сообщений" не активна во время открытия файлов
(*) Если при чтении настроек произошла ошибка, то во время выхода из программы настройки сохраняются не будут.
(*) Название запроса содержит информацию о годе выпуска фильма
(*) Усовершенствован алгоритм создания запросов в IMDb - раньше письма от [image] abcAVI могли интерпретироваться как спам.
(*) Исправлены ключевые слова длительности файла - теперь они выводят именно то, что должны - соответствующее цифровое значение:
$(hourlength) - длина файла, часов
$(minlength) - длина файла, минут
$(seclength) - длина файла, секунд
(+) Добавлено расширение оболочки Windows - Info Tips для AVI файлов
(+) Написан русскоязычный хелп + контекстное открытие справки
(+) Добавлен расчет пропорций кадра и соотношения сторон
(+) Добавлен расчет пикового битрейта
(+) Добавлено окошко с инфой о дате и времени файла
(+) Добавлены ключевые слова:
$(hmsz_length) - длина файла, ч+м+с+мс
$(msz_length) - длина файла, м+с+мс
$(sz_length) - длина файла, с+мс
$(frame_proportion) - пропорции кадра
$(aspect_ratio) - соотношение сторон кадра
$(crd_year) - дата создания, ГГГГ
$(all_genres) - все жанры
(+) Для каждого языка интерфейса вызывается своя справка
(+) Настройка точности экспортируемых значений аудио и видео битрейтов
(+) Экспорт в формат DIF Excel
(+) Экспорт в формат XML Ant Movie Catalog
(+) Экспорт в формат ASX Windows Media Player
(+) Сделана таблица подстановок при экспорте - возможность заменять недопустимые для конкретного формата символы.
(+) IDivX тэги сохраняются не нарушая структуры AVI файла - в RIFF контейнере с названием IDVX
(+) Добавлено 28 описаний FourCC видео кодов (спасибо http://www.kmstudio.com.ua)
ASLC - AlparySoft Lossless Codec
DC25 - MainConcept ProDV Codec
FFDS - FFDShow supported
FFV1 - FFDShow supported
IDM0 - IDM Motion Wavelets 2.0
FRLE - SoftLab-NSK Y16 + Alpha RLE
MDVF - Pinnacle DV/DV50/DVHD100
MVI1 - Motion Pixels MVI
MVI2 - Motion Pixels MVI
MYUV - Media-100 844/X Uncompressed
NO16 - Theory None16 64bit uncompressed RAW
PNG1 - Corecodec.org CorePNG Codec
SHR0 - BitJazz SheerVideo (realtime lossless)
SHR1 - BitJazz SheerVideo (realtime lossless)
SHR2 - BitJazz SheerVideo (realtime lossless)
SHR3 - BitJazz SheerVideo (realtime lossless)
SHR4 - BitJazz SheerVideo (realtime lossless)
SHR5 - BitJazz SheerVideo (realtime lossless)
SHR6 - BitJazz SheerVideo (realtime lossless)
SHR7 - BitJazz SheerVideo (realtime lossless)
SL25 - SoftLab-NSK DVCPRO
SL50 - SoftLab-NSK DVCPRO50
SLIF - SoftLab-NSK MPEG2 I-frames
SLMJ - SoftLab-NSK Forward MJPEG
VP61 - On2 TrueCast VP6.1
VP62 - On2 TrueCast VP6.2
VSSH - Vanguard VSS H.264
YMPG - YMPEG Alpha (dummy for MPEG-2 compressor)
(+) Добавлено 2 новых описания аудио TwoCC кодов (спасибо http://www.kmstudio.com.ua)
0x0700 - YMPEG Alpha (dummy for MPEG-2 compressor)
0x3313 - makeAVIS (ffvfw fake AVI sound from AviSynth scripts)

abcAVI Tag Editor 1.7.2
25 октября 2003

(-) Исправлен баг, возникающий при открытии больших файлов (более 2 гигабайт). abcAVI теперь просто игнорирует такие файлы, а не зависает.
(-) Отловлен баг в процедуре вставки тэгов из буфера обмена. Тэги "Композитор" и "Художник по кастюмам" теперь должны обрабатываться корректно.
(-) Исправлена процедура парсинга ответов из IMDb - слова в тэге "Дополнительная информация" могли иногда "слипаться".
(-) Исправлено несколько опечаток в INI файлах с переводами интерфейса.
(*) Уточнены описания 1 видео FourCC кода и 1 аудио TwoCC кода (спасибо http://www.kmstudio.com.ua)
(*) В случае, если в процессе открытия файлов обнаруживается ошибка, открывается страница "Структура AVI", где находится поле отчета об ошибках становится. Если такое поведение не устраивает, снимите галочку "Структура AVI" в настройках ("Вид / Закладки / ...").
(+) Полностью переделан инсталлятор [image] abcAVI. Для создания дистрибутива использован мощный пакет Inno Setup Wizard.
(+) Добавлены новые горячие клавиши:
Ctrl+Shift+C - копировать все тэги текущего файла в буфер обмена
Ctrl+Shift+V - взять все тэги текущего файла из буфера обмена
Ctrl+Shift+Z - отменить все изменения для текущего файла
(+) Добавлен список серверов, на которых можно запустить поиск фильма - более 20 ссылок (спасибо Энтони Поттену, автору Ant Movie Catalog).
(+) Добавлено 20 новых описаний видео FourCC кодов (спасибо http://www.kmstudio.com.ua)
CSCD - CamStudio lossless codec
DFSC - DebugMode FrameServer VFW Codec
DV10 - BlueFish444 (lossless RGBA, YUV 10-bit)
DVAN - Pinnacle miroVideo DV300 SW only codec
DVH1 - Pinnacle DVHD100
DVOR - BlueFish444 (lossless RGBA, YUV 10-bit)
DVR1 - TARGA2000 Codec
EKQ0 - Elsa graphics card quick codec
HD10 - BlueFish444 (lossless RGBA, YUV 10-bit)
LOCO - LOCO Lossless Codec
NTN2 - Nogatech Video Compression 2 (GrabBee hardware coder)
THEO - FFVFW Supported Codec
VBLE - MarcFD VBLE Lossless Codec
VIDM - DivX 5.0 Pro Supported Codec
VP60 - On2 TrueCast VP6
WMVP - Windows Media Video V9
WRLE - Apple QuickTime BMP Codec
WVLT - IllusionHope Wavelet 9/7
YU12 - ATI YV12 4:2:0 Planar
YU92 - Intel - YUV
(+) Добавлено 8 новых описаний аудио TwoCC кодов (спасибо http://www.kmstudio.com.ua и Ant Movie Catalog)
0x0009 - Microsoft DRM
0x0170 - UNISYS NAP ADPCM
0x0171 - UNISYS NAP ULAW
0x0172 - UNISYS NAP ALAW
0x0173 - UNISYS NAP 16K
0x0215 - Ulead DV ACM
0x0241 - ESST AC3
0xDFAC - DebugMode SonicFoundry Vegas FrameServer ACM Codec

abcAVI Tag Editor 1.7.1
2 июля 2003

(-) Отловлен глюк экспорта - дата и время создания и изменения файла экспортируется без ошибок.
(-) Убит глюк импорта - альтернативные названия фильма импортируются без ошибок
(-) Исправлен глюк интерфейса - множество диалоговых окон не реагировало на смену параметров шрифтов
(*) Невостребованные письма от mail-server@imdb.com уничтожаются автоматически (такие пиьма могут прийти, если пользователь несколько раз использовал повторную отправку запросов).
(*) После создания нового запроса становится активной страница импорта
(+) [image] abcAVI может выделять тэги из писем IMDb (http://www.imdb.com). Теперь перехваченное обычной почтовой программой письмо можно сохранить в текстовый файл и загрузить из него тэги.
(+) [image] abcAVI может выделять тэги из отчетов AMDbFront (http://www.amdbfront.com) - локальной версии Internet Movie Database.
(+) Добавлена функция сохранения заголовка AVI файла в отдельный файл.

abcAVI Tag Editor 1.7
20 июня 2003

(-) Исправлен глюк при записи: теперь при выходе [image] abcAVI сохраняет только измененные файлы, а не все подряд.
(-) Исправлены глюки интерфейса: некоторые диалоговые окна показывали некорректные надписи для китайского и японского языков.
(*) Изменен алгоритм записи тэгов - так, чтобы не использовать выравнивающий байт. Длина всех тэгов теперь кратна 2, что дает совместимость с программами, не полностью реализующими требования RIFF формата.
(*) Уточнено описание 20 FourCC видео кодов и 1 TwoCC аудио кода (спасибо http://www.kmstudio.com.ua)
(*) Уточнен алгоритм быстрого расчета видео битрейта (расчет на основании информации только из заголовка AVI файла)
(*) Введены подробные описания ошибок, происходящих при разборе структуры AVI файлов.
(*) Характеристика "Сжатие видео" была заменена на "Качество видео" в группе краткой информации об AVI файле
(*) Предупреждение об уменьшении размера файла может быть отключено (см. настройки "Чтение и запись тэгов").
(*) Можно выбрать, с каким набором тэгов будет работать [image] abcAVI - со стандартным или с расширенным.
(*) В окошко информации о программе добавлена строка с точным номером версии [image] abcAVI.
(+) Добавлен импорт тэгов из IMDb:
Создание поискового запроса
Отправка запросов на почтовый сервер IMDb
Получение ответов от почтового сервера IMDb
Уточнение результатов поиска и создание информационного запроса
Настраиваемый разбор информационных запросов
Управление запросами (сортировка, удаление, повторный разбор, повторная отправка, получение дополнительной информации)
Применение результатов запросов к AVI файлам (собственно, вставка информации в AVI файлы)
(+) Добавлено 9 INFO тэгов:
ICNM - кинооператор
IMIT - дополнительная информация
IMIU - ссылка на дополнительную информацию
ILGU - URL логотипа
ILIU - URL мини-логотипа
IWMU - URL водяных знаков
IMBI - URL картинки банера
IMBU - URL под банером
Все тэги, за исключением первого, были введены для совместимости с Morgan Multimedia Stream Switcher, который добавляет поддержку интерфейса IAMMediaContent в WMP.
(+) Добавлены новые ключевые слова в шаблоны экспорта:
Качество видео - $(videoquality)
Сводный отчет о сжатии видео - $(videocompress_ext)
Сжатие видео, % - $(videocompress_pers)
(+) При экспорте информации можно автоматически заменять символы конца строки на другие символы, например на "<br>" или ";". Это актуально для тэгов, содержащих многострочную информацию.
(+) Добавлена возможность просмотра структуры movi секции AVI файлов. Бывает полезна, когда хочется узнать реальное чередование потоков
(+) Добавлено окно с подробной информацией о сжатии видео, вызывается нажатием на кнопку в поле краткой информации об AVI файле.
(+) Добавлен алгоритм расчета точного видео и аудио битрейтов (на основе информации из индексной секции AVI файла)
(+) Сделаны несколько режимов вставки тэгов. Теперь доступны режимы: обычная вставка, приоритет новых тэгов и приоритет старых тэгов (смотри "Настройки / Чтение и запись тэгов / Вставка тэгов")
(+) Пользователь может изменять размеры окна редактора тэгов
(+) Добавлено 45 новых описаний FourCC видео кодов (спасибо http://www.kmstudio.com.ua)
2VUY - Optibase VideoPump 8-bit 4:2:2 Component Y'CbCr
8BPS - Apple QuickTime Planar RGB with Alpha-channel
ACTL - Streambox ACT-L2
AEIK - Intel Indeo Video 3.2 (Vector Quantization)
AP42 - AngelPotion Definitive (hack MS MP43)
AVID - Avid Motion JPEG
AVR - Avid ABVB/NuVista MJPEG with Alpha-channel
AVUI - Avid Meridien Uncompressed with Alpha-channel
AZRP - Quicktime Apple Video
BHIV - BeHere iVideo
BXBG - BOXX BGR
BXRG - BOXX RGB
BXY2 - BOXX 10-bit YUV
BXYV - BOXX YUV
DM4V - Dicas MPEGable MPEG-4
DTMT - Media-100 Codec
DTNT - Media-100 Codec
DVIS - VSYNC DualMoon Iris DV codec
DVL - Radius SoftDV 16:9 NTSC
DVLP - Radius SoftDV 16:9 PAL
DVPN - Apple QuickTime DV (DV NTSC)
DVPP - Apple QuickTime DV (DV PAL)
DVRS - VSYNC DualMoon Iris DV codec
GLCC - GigaLink AV Capture codec
IMJG - Accom SphereOUS MJPEG with Alpha-channel
IPJ2 - Image Power JPEG2000
KPCD - Kodak Photo CD
MCZM - Theory MicroCosm 64bit RGB with Alpha-channel
PNG - Apple PNG
PVWV - Pegasus Imaging Wavelet 2000
QDGX - Apple QuickDraw GX
R411 - Radius DV NTSC YUV
R420 - Radius DV PAL YUV
RAVI - GroupTRON ReferenceAVI codec (dummy for MPEG compressor)
RAV_ - GroupTRON ReferenceAVI codec (dummy for MPEG compressor)
SJPG - CUseeMe Networks Codec
SLDV - SoftLab-NSK Forward DV Draw codec
SPRK - Sorenson Spark
TGA - Apple TGA (with Alpha-channel)
TIFF - Apple TIFF (with Alpha-channel)
UYVU - SoftLab-NSK Forward YUV codec
V210 - Optibase VideoPump 10-bit 4:2:2 Component Y'CbCr
VP40 - On2 TrueCast VP4
VP50 - On2 TrueCast VP5
YUV2 - Apple Component Video (YUV 4:2:2)
(+) Добавлено 5 новых описаний TwoCC аудио кодов (спасибо http://www.kmstudio.com.ua)
0x0402 - Ligos Indeo Audio
0x181E - Lucent elemedia AX24000P Music codec
0x1C07 - Lucent SX8300P speech codec
0x1C0C - Lucent SX5363S G.723 compliant codec
0x1F03 - CUseeMe DigiTalk (ex-Rocwell)

abcAVI Tag Editor 1.6.1
9 февраля 2003

(-) Исправлен глюк экспорта: при экспорте в буфер обмена могли возникать ошибки и создавалось множество пустых файлов с именем "clipboard"
(-) Исправлен глюк в настройках: разделитель десятичных разрядов и разделитель дробной и целой частей сохранялись некорректно
(*) Введена настройка, как отображать информацию об аудио и видео кодеках - с использованием или без кодов FourCC и TwoCC
(*) Теперь шрифт интерфейса можно выбрать из всех доступных в системе, а не только MS Sans Serif и Arial.
(*) Небольшие перестройки на странице настроек
(+) Теперь можно делать невидимыми редко используемые закладки [image] abcAVI Tag Editor'а
(+) Файлы с переводом теперь содержат настройки по умолчанию для стиля и размера шрифта, а так же используемой кодировки.

abcAVI Tag Editor 1.6
21 января 2003

(-) Исправлен глюк с неверной обработкой ключевых слов $(fcchandler), $(namehandler), $(fcccodec) и $(namecodec)
(-) Исправлен глюк с неверным сохранением файлов шаблонов экспорта (обрезались пустые строки и строки, содержащие табуляцию)
(-) Имена файлов, содержащие символ "&" верно отображаются в списке быстрого доступа
(-) Исправлена ошибка записи - JUNK секция могла попадать на видео данные.
(-) Исправлен код для DV compressed in SD (SDL) с "DVS1" на "DVSL"
(*) Усовершенствован алгоритм экспорта (проверки на перезапись других файлов, создание всех необходимых директорий и т.д.)
(*) Группы ключевых слов имеют различные иконки (для облегчения навигации по меню)
(*) Ключевые слова заголовка и окончания теперь доступны и в основном блоке шаблона.
(*) Усовершенствован интерфейс страницы экпорта
(*) Кнопка "Начать экспорт" перенесена в основное меню, её горячая кнопка - Ctrl+E
(*) Отображается полный список авторов перевода [image] abcAVI Tag Editor'а, а не только автор последних изменений
(*) Настройки отображения подтверждений и сообщений по умолчанию - оптимальный набор, а не "все включено".
(*) В поля видео и аудио формата добавлена информация о кодах FourCC и TwoCC
(*) Уточнены 46 описаний видео кодеков + 3 описания аудио кодеков
(*) Добавлено предупреждение об обрезании AVI файлов
(+) Специальные ключевые слова для опроса пользователя при экспорте информации
(+) Путь к приемнику также может содержать ключевые слова
(+) Добавлено окно с описанием шаблона
(+) Добавлена куча новых ключевых слов (общее кол-во - 150 штук)
(+) Кнопка "Сохранить шаблон как", "Сохранить шаблон", "Удалить шаблон"
(+) Добавлен список быстрого доступа к шаблонам экспорта
(+) Добавлен краткий формат отображения времени
(+) Создана сравнительная таблица различных форматов тэгов (описание расширенного набора INFO тэгов)
(+) Добавлено 95 новых определений видео кодеков:
3IVD - FFmpeg DivX ;-) (MS MPEG-4 v3)
AAS4 - Autodesk Animator codec (RLE)
ADV1 - Loronix WaveCodec (used in various CCTV products)
ADVJ - Avid M-JPEG Avid Technology Also known as AVRn
AVI1 - MainConcept Motion JPEG Codec
AVI2 - MainConcept Motion JPEG Codec
BGR - Uncompressed BGR32 8:8:8:8
BGR(#15) - Uncompressed BGR15 5:5:5
BGR(#16) - Uncompressed BGR16 5:6:5
BGR(#24) - Uncompressed BGR24 8:8:8
BITM - Microsoft H.261
BLZ0 - FFmpeg MPEG-4
CLPL - Format similar to YV12 but including a level of indirection.
COL0 - FFmpeg DivX ;-) (MS MPEG-4 v3)
COL1 - FFmpeg DivX ;-) (MS MPEG-4 v3)
DCAP - Pinnacle DV25 Codec
DP02 - DynaPel MPEG-4
DRWX - Pinnacle DV25 Codec
DVCS - MainConcept DV Codec
FLIC - Autodesk FLI/FLC Animation
GEPJ - White Pine (ex Paradigm Matrix) Motion JPEG Codec
GPJM - Pinnacle ReelTime MJPEG Codec
GREY - Apparently a duplicate of Y800
IF09 - Microsoft H.261
IMC1 - As YV12 except the U and V planes each have the same stride as the Y plane
IMC2 - Similar to IMC1 except that the U and V lines are interleaved at half stride boundaries
IMC3 - As IMC1 except that U and V are swapped
IMC4 - As IMC2 except that U and V are swapped
JBYR - Kensington Video Codec
JFIF - Motion JPEG (FFmpeg)
L261 - Lead Technologies H.261
L263 - Lead Technologies H.263
LCMW - Lead Technologies Motion CMW Codec
LGRY - Lead Technologies Grayscale Image
LZO1 - LZO compressed (lossless codec)
MC24 - MainConcept Motion JPEG Codec
MP2A - Media Excel MPEG-2 Audio
MP2T - Media Excel MPEG-2 Transport Stream
MP2V - Media Excel MPEG-2 Video
MP41 - Microsoft MPEG-4 V1 (enhansed H263)
MP4A - Media Excel MPEG-4 Audio
MP4T - Media Excel MPEG-4 Transport Stream
MP4V - Media Excel MPEG-4 Video
MSS2 - Windows Media 9
MTGA - Motion TGA images (24, 32 bpp)
NHVU - NVidia Texture Format (GEForce 3)
NV12 - 8-bit Y plane followed by an interleaved U/V plane with 2x2 subsampling
NV21 - As NV12 with U and V reversed in the interleaved plane
NVDS - NVidia Texture Format
NVHS - NVidia Texture Format (GEForce 3)
PIXL - MiroVideo XL (Motion JPEG)
RGB(#15) - Uncompressed RGB15 5:5:5
RGB(#16) - Uncompressed RGB16 5:6:5
RGB(#24) - Uncompressed RGB24 8:8:8
RGB1 - Uncompressed RGB332 3:3:2
RGBO - Uncompressed RGB555 5:5:5
RGBP - Uncompressed RGB565 5:6:5
RGBQ - Uncompressed RGB555X 5:5:5 BE
RGBR - Uncompressed RGB565X 5:6:5 BE
ROQV - Id RoQ File Video Decoder
RTV0 - NewTek VideoToaster (uncompressed)
RV40 - RealVideo 9
SAN3 - MPEG-4 codec (direct copy of DivX 3.11a)
SP44 - SunPlus Aiptek MegaCam Codec
SP53 - SunPlus Aiptek MegaCam Codec
SP54 - SunPlus Aiptek MegaCam Codec
SP55 - SunPlus Aiptek MegaCam Codec
SP56 - SunPlus Aiptek MegaCam Codec
SP57 - SunPlus Aiptek MegaCam Codec
SP58 - SunPlus Aiptek MegaCam Codec
SWC1 - MainConcept Motion JPEG Codec
TIM2 - Pinnacle RAL DVI
TVJP - TrueVision Field Encoded Motion JPEG (Targa emulation)
UMP4 - UB Video MPEG 4
VDST - VirtualDub remote frameclient ICM driver
VSSV - Vanguard Software Solutions Video Codec
VTLP - Alaris VideoGramPixel Codec
VYU9 - ATI Technologies YUV
VYUY - ATI Packed YUV Data
WMV3 - Windows Media 9
WNVA - Winnov hw compress
WRPR - VideoTools VideoServer Client Codec (wrapper for AviSynth)
XVIX - Based on XviD MPEG-4 codec
XWV0 - XiWave Video Codec
XWV1 - XiWave Video Codec
XWV2 - XiWave Video Codec
XWV3 - XiWave Video Codec (Xi-3 Video)
XWV4 - XiWave Video Codec
XWV5 - XiWave Video Codec
XWV6 - XiWave Video Codec
XWV7 - XiWave Video Codec
XWV8 - XiWave Video Codec
XWV9 - XiWave Video Codec
XXAN - Origin Video Codec (used in Wing Commander 3 and 4)
ZYGO - ZyGo Video Codec
(+) Добавлен 1 новый аудио формат
0x0216 - Ulead DV ACM

abcAVI Tag Editor 1.5.1
27 ноября 2002

(-) Исправлен глюк с открытием файлов, содержащих в имени символ ";". Теперь такие файлы обрабатываются нормально.
(*) Усовершенствованы диалоги (добавлен перевод + возможность отключить диалог "на лету")
(*) Распознаются файлы DV с несовместимым с VfW форматом (поток iavs вместо vids и auds)
(+) Включено распознавание версий Virtual Dub
(+) Добавлено определение INFO тэгов Morgan Multimedia Stream Switcher
IAS1 - The language of the audio stream number 1
IAS2 - The language of the audio stream number 2
IAS3 - The language of the audio stream number 3
IAS4 - The language of the audio stream number 4
IAS5 - The language of the audio stream number 5
IAS6 - The language of the audio stream number 6
IAS7 - The language of the audio stream number 7
IAS8 - The language of the audio stream number 8
IAS9 - The language of the audio stream number 9
ICAS - Identifies the common audio stream (1-9)

abcAVI Tag Editor 1.5
18 октября 2002

(-)Убит глюк при записи инфы в файлы с большими заголовками (более 65536 байт)
(-)Исправлена тема письма, создаваемого из окна "О программе"
(-)Исправлен глюк при открытии файлов и одновременном изменении настроек программы
(-)Отловлен глюк сохранения шаблона экспорта - появлялись лишние переносы строк.
(*)Все диалоги (в т.ч. открытия/записи) отцентрированы относительно главной формы
(*)Поиск по расширению теперь находит файлы *.avi и *.divx
(*)Обработка поддиректорий в диалоге открытия AVI файлов
(*)Запоминается состояние "свернутое/развернутое дерево структуры AVI"
(*)Усовершенствована процедура встраивания в контекстное меню (теперь обрабатывается не только тип avifile)
(*)Усовершенствован сценарий инсталляции
(*)Статистика по открытым файлам изменяется в ходе открытия новых файлов, а не только в конце открытия
(+)Добавлен просмотр длительности проигрывания не только для всего файла в целом, но и для каждого из потоков по отдельности.
(+)Добавлены флаги стран в списке языков интерфейса
(+)Открытие директории с видео файлами
(+)Передача информации об открываемых файлах между экземплярами программы - открывается одно окно со всеми файлами, а не по одному файлу на окно
(+)Испанский, польский, чешский языки
(+)Создана DLL для чтения/записи тэгов + справка + пример использования DLL в среде Delphi
(+)Программа установки создает ярлыки на [image] abcAVI в меню программ
(+)Настраиваемая система подтверждений и сообщений (24 опции)
(+)Добавлены контекстные меню в окне редактирования шаблона экспорта
(+)Сохранение дерева структуры AVI
(+)Открытие страницы в IMBD.com
(+)Добавлены ключи программы:
-r зарегистрировать [image] abcAVI Tag Editor в контекстных меню (avi, divx, directory, drive)
-u удалить [image] abcAVI Tag Editor из контекстных меню (avi, divx, directory, drive)
-q закрыть [image] abcAVI Tag Editor
(+)Появилась настройка символов разделителей групп разрядов, а также целой и дробной части чисел.
(+)Добавлена возможность отменить загрузку файлов

abcAVI Tag Editor 1.4
16 июля 2002

(-)Уточнен расчет видео битрейта - теперь ошибка расчетов около 0,5%
audio_size:=(strf_auds.nAvgBytesPerSec*strh_auds.dwLength*strh_auds.dwScale/strh_auds.dwRate)+(strh_auds.dwLength*v_framespersec*8*strh_auds.dwScale/strh_auds.dwRate);
video_size{bytes}:=movi_size+(idx1_size/count_of_streams)-audio_size_stream1-audio_size_stream2-...;
v_kilobitspersec:=((video_size*v_framespersec*8)/(v_frames*1000));
Можно, конечно, пробежаться по всему AVI, просуммировать размер всех кадров и поделить на длину видео, но это будет очень долго.
(-)Убит глюк с записью тэгов, выбираемых из списков (при записи добавлялось по два символа #0 в конец каждого такого тэга)
(*)Уточнено 9 описаний видео кодеков
(*)Уточнено 32 описания аудио кодеков (спасибо сайту http://www.mplayerhq.hu)
(*)Перепланирован интерфейс - выделена отдельная страница под AVI тэги, которые в свою очередь делятся на основные тэги, титры и дополнительные тэги
(*)Добавлены иконки в закладки первого уровня
(+)Добавлено 8 новых AVI тэгов (для будущей совместимости с IMDB.com):
IMUS - композитор
ICDS - художник по костюмам
ICNT - страна-производитель
IDST - распространитель
IEDT - монтажер
ISGN - жанр 2
IPRO - продюсер
IPDS - постановщик
(+)Новая кнопка - просмотреть AVI файл (Ctrl+P)
(+)Добавлены языки - английский хацкор, румынский хацкор, французский, венгерский
(+)Отображение информации о нескольких аудио потоках
(+)Добавлено 26 новых FourCC кодов (спасибо сайту http://www.mplayerhq.hu)
AVDJ - Avid Motion JPEG
AZPR - Quicktime Apple Video
DIV1 - FFmpeg-4 V1 (hacked MS MPEG-4 V1)
DIV2 - FFmpeg-4 V2 (hacked MS MPEG-4 V2)
DVC - MainConcept DV Codec
DVCP - Sony Digital Video (DV)
M4S2 - Microsoft MPEG-4 (hacked MS MPEG-4)
MJPB - Motion JPEG codec
MPG1 - FFmpeg-1
MPG2 - FFmpeg-1
MPNG - Motion PNG codec
MSS1 - Windows Screen Video
NUV1 - NuppelVideo
Q1.0 - Q-Team QPEG 1.0
Q1.0 - Q-Team QPEG 1.1
RMP4 - REALmagic MPEG-4 Video Codec
RUD0 - Rududu video codec
RV10 - RealVideo codec
RV13 - RealVideo codec
SMC - Apple Graphics (SMC) codec (256 color)
SVQ3 - Sorenson Video 3 (Apple Quicktime 5)
TM2A - Duck TrueMotion Archiver 2.0
VIV1 - Vivo H.263
VIV2 - Vivo H.263
WMV1 - Windows Media Video 7
WMV2 - Windows Media Video 8
(+) Добавлено 30 новых TwoCC кодов (спасибо сайту http://www.mplayerhq.hu)
0x0008 - Microsoft DTS
0x0093 - MediaSonic G.723
0x0094 - Aculab 8KBPS
0x00A0 - Malden Electronics PHONYTALK
0x0125 - Sanyo ADPCM
0x0131 - Sipro Lab Telecom ACELP.4800
0x0132 - Sipro Lab Telecom ACELP.8V3
0x0133 - Sipro Lab Telecom ACELP.G.729
0x0134 - Sipro Lab Telecom ACELP.G.729A
0x0135 - Sipro Lab Telecom ACELP.KELVIN
0x0140 - Dictaphone G.726 ADPCM
0x0150 - Qualcomm PUREVOICE
0x0151 - Qualcomm HALFRATE
0x0155 - Ring Zero Systems TUBGSM
0x0210 - UHER informatic GmbH ADPCM
0x0230 - I-link Worldwide ILINK VC
0x0240 - Aureal Semiconductor RAW SPORT
0x0250 - Interactive Products HSX
0x0251 - Interactive Products RPELP
0x0260 - Consistent Software CS2
0x0270 - Sony ATRAC3
0x0681 - AT&T Labs TPC
0x0401 - Intel Music Coder (IMC)
0x1101 - Lernout & Hauspie CELP codec
0x1102 - Lernout & Hauspie SBC codec
0x1103 - Lernout & Hauspie SBC codec
0x1104 - Lernout & Hauspie SBC codec
0x181C - VoxWare RT24 speech codec
0x1FC4 - ALF2
0xFFFE - Extensible wave format

abcAVI Tag Editor 1.3
25 июня 2002

(-) Исправлен глюк с распознаванием FCC кодов, содержащих пробел ("RLE ", "DIB " и т.п.)
(-) Исправлен глюк с неправильным отображением инфы idx1 тэга
(-) Исправлен глюк с пропуском заголовка AVI, если раздел очень большой. Теперь игнорируются только большие тэги, но не списки (за исключением "movi").
(-) Убран глюк при обработке файлов без секции idx1 (затирался заголовок файла)
(-) Убран глюк с записыванием файла без тэгов - теперь не пишутся пустышки "LIST INFO" и "LIST MID"
(-) Исправлен глюк с установкой программы поверх предыдущих версий (теперь при установке подчищаются ключи реестра и файлы от предыдущих версий программы)
(-) Исправлен глюк с чтением инфы из read only файлов (не позволяло читать инфу из файлов на CD в WinXP)
(-) Убит баг при записи тэгов - теперь файлы после перезаписи остаются доступными для других программ.
(-) Отловлен глюк с неправильным определением открыт ли уже данный файл (глючило на CD с длинными именами).
(*) Ускорена загрузка файлов (более чем в 10 раз - заменен компонент TreeView на DCTree)
(*) Создан инсталлятор программы, добавлено подтверждение при деинсталяции программы
(*) Сохранение настроек программы в INI файле (положение окна и страниц, страница настроек, шаблон экспорта, рабочие директории)
(*) Программа имеет свою директорию [image] abcAVI в Program Files, а не располагается в системной папке Windows
(*) Оптимизирован интерфейс программы - статус бар содержит статистику по файлам
(*) Отлажен алгоритм активации кнопок - доступны только те кнопки, нажатие на которые приводит к какому-либо результату.
(*) Уточнено 50 описаний видео кодеков (спасибо сайту http://www.kmstudio.com.ua)
(+) Добавлено 28 новых FourCC кодов (спасибо сайту http://www.kmstudio.com.ua)
3IVX - MPEG4-based codec 3ivx
AVRN - Avid Motion JPEG
BTVC - Conexant Composite Video
DPS0 - DPS Reality Motion JPEG
DPSC - DPS PAR Motion JPEG
DSVD - Microsoft DirectShow DV
DV25 - Matrox DVCPRO codec
DV50 - Matrox DVCPRO50 codec
DVMA - Darim Vision DVMPEG
DX50 - DivX 5.0 codec
EM2V - Etymonix MPEG-2 I-frame
FRWT - Darim Vision Forward Motion JPEG
FRWU - Darim Vision Forward Uncompressed
FVFW - ff MPEG-4 based on XviD codec
IYUV - Intel Indeo iYUV 4:2:0
LSVM - Vianet Lighting Strike Vmail (Streaming)
MJ2C - Morgan Multimedia JPEG2000 Compression
MJPA - Pinnacle Motion JPEG with Alpha-channel
MMES - Matrox MPEG-2 I-frame
MSZH - Lossless codec (ZIP compression)
NAVI - nAVI video codec (hacked MS MPEG-4)
NT00 - NewTek LigtWave HDTV YUV with Alpha-channel
RPZA - Apple Video 16 bit
SJPG - White Pine (ex Paradigm Matrix) Motion JPEG
T420 - Toshiba YUV 4:2:0
TVMJ - Field Encoded Motion JPEG (Targa emulation)
U263 - UB Video StreamForce H.263
XVID - XviD MPEG-4 codec
(+) Добавлено 8 новых TwoCC кодов
0x0043 - IBM AVC ADPCM
0x674f - Ogg Vorbis (mode 1)
0x676f - Ogg Vorbis (mode 1+)
0x6750 - Ogg Vorbis (mode 2)
0x6770 - Ogg Vorbis (mode 2+)
0x6751 - Ogg Vorbis (mode 3)
0x6771 - Ogg Vorbis (mode 3+)
0xFFFF - In Development / Unregistered
(+) При открытии файлов с атрибутом "только для чтения" возможен только просмотр информации
(+) Добавлено чтение и запись шаблонов экспорта
(+) Добавлена работа со списком экспортируемых файлов (сортировка, drag & drop, отметка флажками)
(+) Добавлено создание отчетов по шаблону экспорта
(+) Двухуровневое меню ключевых слов в редакторе шаблонов экспорта
(+) Сделан многоязыковой интерфейс с возможностью смены языка "на лету" (английский, русский, румынский, немецкий, 2 китайских)
(+) Добавлены настройки "искать в поддиректориях", "игнорировать ошибки в заголовке AVI", выбор формата времени
(+) Добавлены настройки шрифтов интерфейса и набора символов
(+) Создана русская версия сайта программы http://abcavi.da.ru
(+) Добавлен выбор формата отображения размера файла (байт / КБ / МБ)
(+) Добавлен выбор формата отображения длины файла (XX ч XX мин XX.XX с/ XX мин XX.XX с / XX.XX с)

abcAVI Tag Editor 1.2
17 мая 2002

(-) Убрана заморозка программы при открытии файлов
(-) Исправлен глюк при обработке кода языка
(-) Исправлен глюк при расчете битрейтов - 1 килобит = 1000 бит, а не 1024 бита
(-) Исправлен глюк при сохранении MovieID тэгов (тэги полагается записывать только после idx1 секции)
(-) Исправлен FCC код формата аудио Vivo G.723 - 0x0111
(-) Исправлен глюк при добавлении новых файлов (после открытия активным файлом становится первый из новых, а не просто первый)
(-) Исправлен глюк при открытии файлов через командную строку (при загрузке списка файлов имена файлов становились короткими, при этом возможно было открыть один файл два раза)
(*) Оптимизирован код сохранения и распознавания тэгов
(*) Увеличен максимальный размер тэга с 32000 до 65536 байт
(*) Оптимизирован интерфейс программы
(*) Подключены иконки в дереве полной информации
(*) Изменено название программы на [image] abcAVI tag - Add, Browse & Change AVI tags
(+) Добавлено 3 новых FourCC кода
MDVD - Alex MicroDVD Video
MPG3 - Same as Low motion DivX MPEG-4
VIFP - Virtual Frame API codec (VFAPI)
(+) Добавлено 3 новых TwoCC кода
0x0130 - Sipro Lab Telecom ACELP.net audio codec
0x0160 - Windows Media Audio V1
0x0161 - Windows Media Audio V2 (Alex AC3 Audio Decoder)
(*) Добавлено четыре новых жанра
ужасы/мистика
фантастический боевик
психологический триллер
мелодрама
(+) Распознавание информации Virtual Dub (в секции JUNK)
(+) Информация о степени сжатия видео потока
(+) Дублирование внутреннего буфера с тегами в общий текстовый Виндоуз буфер
(+) Страница "Настройки" - выбор fcc кода декомпрессора, изменение скорости проигрывания видео, изменение размера кадра
(+) Открытие файлов в поддиректориях (закинутый список директорий, список в строке загрузки)
(+) Возможность отключения записи MovieID и IDivX тэгов (экономия места в файле)
(+) Детектирование второй копии программы
(+) Список быстрого доступа к файлу
(+) Сохранение положения панелей инструментов
(+) Создан сайт программы http://abcavi.da.ru (English version)

Total AVI Tags Editor 1.1
12 февраля 2002

(+) Полноценный графический интерфейс
(+) Поддержка информационных тэгов трех форматов: RIFF INFO, MovieID и IDivX
(+) Группа краткой информации о файле содержит следующие поля: имя файла, длительность, размер файла, формат звука, формат видео
(+) Страница "Все тэги" содержит полную информацию об AVI файле в древовидной форме
(+) Страница "Основные тэги" содержит следующие поля: название, режиссер, автор сценария, тема, производство, в ролях, продукт, дата создания, жанр, ограничения, авторские права, язык, ключевые слова, номер части, общее кол-во частей и заметки.
(+) Страница "Дополнительные тэги" содержит следующие поля: программа, кодировщик, дата оцифровки, интернет, исходная форма, носитель, источник, место хранения, по заказу, инженер и т.д.
(+) Программа позволяет открывать несколько файлов одновременно, есть панель перемешения между открытыми файлами
(+) Можно размножить содержимое одного поля между всеми открытыми файлами
(+) Можно выбрать значения некоторых полей из списка готовых вариантов (поля продукт, жанр, ограничения, язык, исходная форма, носитель)
(+) Можно скопировать одновременно все тэги во внутренний буфер обмена и вставлять из него информацию как в отдельные файлы так и во все сразу.
(+) Можно очищать все тэги отдельного файла, либо всех файлов одним нажатием кнопки
(+) Есть функция отмены всех изменений для каждого файла в отдельности, либо для всех файлов одновременно
(+) Работает Drag & Drop файлов и загрузка файлов через командную строку
(+) База FourCC и кодов содержит описание 276 видео форматов (спасибо сайту http://webartz.com/fourcc)
3IV0 - MPEG4-based codec 3ivx
3IV1 - MPEG4-based codec 3ivx
3IV2 - MPEG4-based codec 3ivx
AASC - Autodesk Animator codec
ABYR - Kensington codec
AEMI - Array VideoONE MPEG1-I Capture
AFLC - Autodesk Animator FLC (256 color)
AFLI - Autodesk Animator FLI (256 color)
AMPG - Array VideoONE MPEG
ANIM - Intel RDX
AP41 - AngelPotion Definitive (hack MS MP43)
ASV1 - Asus Video V1
ASV2 - Asus Video V2
ASVX - Asus Video 2.0
AUR2 - Aura 2 Codec - YUV 422
AURA - Aura 1 Codec - YUV 411
BINK - Bink Video (RAD Game Tools) (256 color)
BT20 - Conexant (ex Brooktree) ProSummer MediaStream
BTCV - Conexant Composite Video
BW10 - Data Translation Broadway MPEG Capture/Compression
CC12 - Intel YUV12 Codec
CDVC - Canopus DV Codec
CFCC - Conkrete DPS Perception Motion JPEG
CGDI - Camcorder Video (MS Office 97)
CHAM - WinNow Caviara Champagne
CJPG - Creative Video Blaster Webcam Go JPEG
CLJR - Cirrus Logic YUV 4:1:1
CMYK - Common Data Format in Printing
CPLA - Weitek YUV 4:2:0 Planar
CRAM - Microsoft Video 1
CVID - Cinepak by Radius YUV 4:2:2
CWLT - Microsoft Color WLT DIB
CYUV - Creative Labs YUV 4:2:2
CYUY - ATI Technologies YUV
D261 - H.261
D263 - H.263
DIB - Full Frames (Uncompressed)
DIV3 - Low motion DivX MPEG-4
DIV4 - Fast motion DivX MPEG-4
DIV5 - DivX MPEG-4
DIV6 - DivX MPEG-4
DIVX - OpenDivX (DivX 4.0 and later)
DMB1 - Matrox Rainbow Runner hardware compression (Motion JPEG)
DMB2 - Motion JPEG codec used by Paradigm
DUCK - True Motion 1.0
DVE2 - DVE-2 Videoconferencing Codec
DVHD - DV 1125 lines at 30.00 Hz or 1250 lines at 25.00 Hz
DVS1 - DV compressed in SD (SDL)
DVSD - Sony Digital Video (DV) 525 lines at 29.97 Hz or 625 lines at 25.00 Hz
DVX1 - DVX1000SP Video Decoder
DVX2 - DVX2000S Video Decoder
DVX3 - DVX3000S Video Decoder
DXT1 - DirectX Compressed Texture
DXT2 - DirectX Compressed Texture
DXT3 - DirectX Compressed Texture
DXT4 - DirectX Compressed Texture
DXT5 - DirectX Compressed Texture
DXTC - DirectX Texture Compression
EKQ0 - Else graphics card codec
ELK0 - Else graphics card codec
ESCP - Eidos Technologies Escape codec
ETV1 - eTreppid Video Codec
ETV2 - eTreppid Video Codec
ETVC - eTreppid Video Codec
FLJP - Field Encoded Motion JPEG (Targa emulation)
FRWA - Darim Vision Forward Motion JPEG with Alpha-channel
FRWD - Darim Vision Forward Motion JPEG
FVF1 - Fractal Video Frame
GLZW - Motion LZW by gabest@freemail.hu
GPEG - Motion JPEG by gabest@freemail.hu (with floating point)
GWLT - Microsoft Greyscale WLT DIB
H260 - H.260
H261 - H.261
H262 - H.262
H263 - Intel ITU H.263
H264 - H.264
H265 - H.265
H266 - H.266
H267 - H.267
H268 - H.268
H269 - H.263 for POTS-based videoconferencing
HFYU - Huffman Lossless Codec YUV and RGB formats (with Alpha-channel)
HMCR - Rendition Motion Compensation Format
HMRR - Rendition Motion Compensation Format
I263 - Intel ITU H.263
I420 - Intel Indeo 4 H.263
IAN - Indeo 4 (RDX) Codec
IAVS - interleaved audio and video stream
ICLB - CellB Videoconferencing Codec
IGOR - Power DVD
IJPG - Intergraph JPEG
ILVC - Intel Layered Video
ILVR - ITU H.263+ Codec
IPDV - Giga AVI DV Codec
IR21 - Intel Indeo 2.1
IRAW - Intel YUV Uncompressed
IUYV - Interlaced version of UYVY (line order 0, 2, 4,....,1, 3, 5....)
IV30 - Intel Indeo Video 3
IV31 - Intel Indeo Video 3.1
IV32 - Intel Indeo Video 3.2
IV33 - Intel Indeo Video 3.3
IV34 - Intel Indeo Video 3.4
IV35 - Intel Indeo Video 3.5
IV36 - Intel Indeo Video 3.6
IV37 - Intel Indeo Video 3.7
IV38 - Intel Indeo Video 3.8
IV39 - Intel Indeo Video 3.9
IV40 - Intel Indeo Video 4.0
IV41 - Intel Indeo Video 4.1
IV42 - Intel Indeo Video 4.2
IV43 - Intel Indeo Video 4.3
IV44 - Intel Indeo Video 4.4
IV45 - Intel Indeo Video 4.5
IV46 - Intel Indeo Video 4.6
IV47 - Intel Indeo Video 4.7
IV48 - Intel Indeo Video 4.8
IV49 - Intel Indeo Video 4.9
IV50 - Intel Indeo Video 5.0 Wavelet
IY41 - Interlaced version of Y41P (line order 0, 2, 4,....,1, 3, 5....)
IYU1 - 12 bit format used in mode 2 of the IEEE 1394 Digital Camera 1.04 spec
IYU2 - 24 bit format used in mode 2 of the IEEE 1394 Digital Camera 1.04 spec
JPEG - Still Image JPEG DIB
JPGL - DIVIO JPEG Light for WebCams
KMVC - Karl Morton Video Codec
LEAD - LEAD Video Codec
LJPG - LEAD Motion JPEG Codec
M261 - Microsoft H.261
M263 - Microsoft H.263
MC12 - ATI Motion Compensation Format
MCAM - ATI Motion Compensation Format
MJPG - IBM Motion JPEG including Huffman Tables
MP42 - Microsoft MPEG-4 V2
MP43 - Microsoft MPEG-4 V3
MP4S - Microsoft MPEG-4 (hacked MS MPEG-4)
MP4V - Microsoft MPEG-4 (hacked MS MPEG-4)
MPEG - Chromatic MPEG 1 Video I Frame
MPG4 - Microsoft MPEG-4 V1
MPGI - Sigma Design MPEG-1 I-frame
MRCA - FAST Multimedia MR Codec
MRLE - Microsoft Run Length Encoding
MSVC - Microsoft Video 1
MSVC - Microsoft Video 1
MTX1 - Matrox codec
MTX2 - Matrox codec
MTX3 - Matrox codec
MTX4 - Matrox codec
MTX5 - Matrox codec
MTX6 - Matrox codec
MTX7 - Matrox codec
MTX8 - Matrox codec
MTX9 - Matrox codec
MWV1 - Aware Motion Wavelets
NTN1 - Nogatech Video Compression 1
NVS0 - Nvidia texture compression format
NVS1 - Nvidia texture compression format
NVS2 - Nvidia texture compression format
NVS3 - Nvidia texture compression format
NVS4 - Nvidia texture compression format
NVS5 - Nvidia texture compression format
NVT0 - Nvidia texture compression format
NVT1 - Nvidia texture compression format
NVT2 - Nvidia texture compression format
NVT3 - Nvidia texture compression format
NVT4 - Nvidia texture compression format
NVT5 - Nvidia texture compression format
PDVC - Panasonic DV codec
PGVV - Radius Video Vision Telecast (adaptive JPEG)
PHMO - Photomotion
PIM1 - Pegasus Imaging codec
PIM2 - Pegasus Imaging codec
PIMJ - Pegasus Imaging PICvideo Lossless JPEG
PVEZ - Horizons Technology PowerEZ codec
PVMM - PacketVideo Corporation MPEG-4
PVW2 - Pegasus Imaging Wavelet 2000
QPEG - Q-Team QPEG 1.1
QPEQ - Q-Team QPEG 1.1
RAW - Full Frames (Uncompressed)
RGB - Full Frames (Uncompressed)
RGBA - Raw RGB with alpha
RGBT - Uncompressed RGB with transparency
RLE - Raw RGB with arbitrary sample packing within a pixel
RLE4 - Run length encoded 4bpp RGB image
RLE8 - Run length encoded 8bpp RGB image
RT21 - Intel Real Time Video 2.1
RV20 - RealVideo G2
RV30 - RealVideo 8
RVX - Intel RDX
S422 - VideoCap C210 YUV Codec
SDCC - Sun Digital Camera Codec
SFMC - Crystal Net SFM Codec
SMSC - Radius proprietary codec
SMSD - Radius proprietary codec
SMSV - WorldConnect Wavelet Streaming Video
SPIG - Radius Spigot
SPLC - Splash Studios ACM Audio Codec
SQZ2 - Microsoft VXTreme Video Codec V2
STVA - ST CMOS Imager Data (Bayer)
STVB - ST CMOS Imager Data (Nudged Bayer)
STVC - ST CMOS Imager Data (Bunched)
STVX - ST CMOS Imager Data (Extended)
STVY - ST CMOS Imager Data (Extended with Correction Data)
SV10 - Sorenson Media Video R1
SVQ1 - Sorenson Video (Apple Quicktime 3)
TLMS - TeraLogic Motion Infraframe Codec A
TLST - TeraLogic Motion Infraframe Codec B
TM20 - Duck TrueMotion 2.0
TM2X - Duck TrueMotion 2X
TMIC - TeraLogic Motion Intraframe Codec 2
TMOT - TrueMotion Video Compression
TR20 - Duck TrueMotion RT 2.0
TSCC - TechSmith Screen Capture Codec
TV10 - Tecomac Low-Bit Rate Codec
TY0N - Trident Decompression Driver
TY2C - Trident Decompression Driver
TY2N - Trident Decompression Driver
UCOD - ClearVideo (fractal compression-based codec)
ULTI - IBM Corp. Ultimotion
UYNV - A direct copy of UYVY registered by NVidia to work around problems in some old codecs which did not like hardware which offered more than 2 UYVY surfaces
UYVP - YCbCr 4:2:2 extended precision 10-bits per component in U0Y0V0Y1 order
UYVY - YUV 4:2:2 (Y sample at every pixel, U and V sampled at every second pixel horizontally on each line)
V261 - Lucent VX2000S
V422 - Vitec Multimedia YUV 4:2:2 as for UYVY but with different component ordering within the u_int32 macropixel
V655 - Vitec Multimedia 16 bit YUV 4:2:2 (6:5:5) format
VCR1 - ATI VCR 1.0
VCR2 - ATI VCR 2.0 (MPEG YV12)
VCR3 - ATI VCR 3.0
VCR4 - ATI VCR 4.0
VCR5 - ATI VCR 5.0
VCR6 - ATI VCR 6.0
VCR7 - ATI VCR 7.0
VCR8 - ATI VCR 8.0
VCR9 - ATI VCR 9.0
VDCT - Video Maker Pro DIB
VDOM - VDOnet VDOWave
VDOW - VDOLive (H.263)
VDTZ - Darim Vision VideoTizer YUV
VGPX - Alaris VGPixel Codec
VIDS - Vitec Multimedia YUV 4:2:2 codec
VIVO - Vivo H.263
VIXL - miroVideo XL
VLV1 - VideoLogic codec
VP30 - On2 (ex Duck TrueMotion) VP3
VP31 - On2 (ex Duck TrueMotion) VP3
VX1K - Lucent VX1000S Video Codec
VX2K - Lucent VX2000S Video Codec
VXSP - Lucent VX1000SP Video Codec
WBVC - Winbond W9960 codec
WHAM - Microsoft Video 1
WINX - Winnov Software Compression
WJPG - Winbond JPEG
WNV1 - WinNow Videum Hardware Compression
X263 - Xirlink H.263
XLV0 - NetXL Inc. XL Video Decoder
XMPG - XING MPEG (I frame only)
Y211 - Packed YUV format with Y sampled at every second pixel across each line and U and V sampled at every fourth pixel
Y411 - YUV 4:1:1 Packed
Y41B - YUV 4:1:1 Planar
Y41P - Conexant (ex Brooktree) YUV 4:1:1 Raw
Y41T - Format as for Y41P but the lsb of each Y component is used to signal pixel transparency
Y422 - Direct copy of UYVY as used by ADS Technologies Pyro WebCam firewire camera
Y42B - YUV 4:2:2 Planar
Y42T - Format as for UYVY but the lsb of each Y component is used to signal pixel transparency
Y8 - Simple grayscale video
Y800 - Simple grayscale video
YC12 - Intel YUV12 Codec
YUNV - A direct copy of YUY2 registered by NVidia to work around problems in some old codecs which did not like hardware which offered more than 2 YUY2 surfaces
YUV8 - Winnov Caviar YUV8
YUV9 - Intel YUV9
YUVP - YCbCr 4:2:2 extended precision 10-bits per component in Y0U0Y1V0 order
YUY2 - YUV 4:2:2 as for UYVY but with different component ordering within the u_int32 macropixel
YUYV - Canopus YUV format
YV12 - ATI YVU12 4:2:0 Planar
YVU9 - Brooktree YVU9 Raw (YVU9 Planar)
YVYU - YUV 4:2:2 as for UYVY but with different component ordering within the u_int32 macropixel
ZLIB - Lossless codec (ZIP compression)
ZPEG - Metheus Video Zipper
(+) База TwoCC кодов содержит описание 105 аудио форматов (спасибо сайту http://webartz.com/fourcc)
0x0000 - Microsoft Unknown Wave Format
0x0001 - Microsoft PCM Format
0x0002 - Microsoft ADPCM Format
0x0003 - IEEE Float
0x0004 - Compaq Computer VSELP (codec for Windows CE 2.0 devices)
0x0005 - IBM CVSD
0x0006 - Microsoft ALAW (CCITT A-Law)
0x0007 - Microsoft MULAW (CCITT u-Law)
0x0010 - OKI ADPCM
0x0011 - Intel DVI ADPCM (IMA ADPCM)
0x0012 - Videologic MediaSpace ADPCM
0x0013 - Sierra Semiconductor ADPCM
0x0014 - Antex Electronics G.723 ADPCM
0x0015 - DSP Solutions DIGISTD
0x0016 - DSP Solutions DIGIFIX
0x0017 - Dialogic OKI ADPCM
0x0018 - MediaVision ADPCM
0x0019 - HP CU codec
0x0020 - Yamaha ADPCM
0x0021 - Speech Compression SONARC
0x0022 - DSP Group True Speech
0x0023 - Echo Speech EchoSC1
0x0024 - Audiofile AF36
0x0025 - APTX
0x0026 - AudioFile AF10
0x0027 - Prosody 1612 codec for CTI Speech Card
0x0028 - Merging Technologies S.A. LRC
0x0030 - Dolby Labs AC2
0x0031 - Microsoft GSM 6.10
0x0032 - MSNAudio
0x0033 - Antex Electronics ADPCME
0x0034 - Control Resources VQLPC
0x0035 - DSP Solutions Digireal
0x0036 - DSP Solutions DigiADPCM
0x0037 - Control Resources Ltd CR10
0x0038 - Natural MicroSystems VBXADPCM
0x0039 - Roland RDAC (Crystal Semiconductor IMA ADPCM)
0x003A - Echo Speech EchoSC3
0x003B - Rockwell ADPCM
0x003C - Rockwell Digit LK
0x003D - Xebec Multimedia Solutions
0x0040 - Antex Electronics G.721 ADPCM
0x0041 - Antex Electronics G.728 CELP
0x0042 - Microsoft MSG723
0x0050 - Microsoft MPEG1 layer 1,2
0x0052 - InSoft RT24 (ACM codec is an alternative codec)
0x0053 - InSoft PAC
0x0055 - MPEG1 Layer 3 (MP3)
0x0059 - Lucent G.723
0x0060 - Cirrus Logic
0x0061 - ESS Technology ESPCM / Duck DK4 ADPCM
0x0062 - Voxware file-mode codec / Duck DK3 ADPCM
0x0063 - Canopus Atrac
0x0064 - APICOM G.726 ADPCM
0x0065 - APICOM G.722 ADPCM
0x0066 - Microsoft DSAT
0x0067 - Microsoft DSAT Display
0x0069 - Voxware Byte Aligned (bitstream-mode codec)
0x0070 - Voxware AC8 (Lernout & Hauspie CELP 4.8 kbps)
0x0071 - Voxware AC10 (Lernout & Hauspie CBS 8kbps)
0x0072 - Voxware AC16 (Lernout & Hauspie CBS 12kbps)
0x0073 - Voxware AC20 (Lernout & Hauspie CBS 16kbps)
0x0074 - Voxware MetaVoice (file and stream oriented)
0x0075 - Voxware MetaSound (file and stream oriented)
0x0076 - Voxware RT29HW
0x0077 - Voxware VR12
0x0078 - Voxware VR18
0x0079 - Voxware TQ40
0x0080 - Softsound
0x0081 - Voxware TQ60
0x0082 - Microsoft MSRT24 (ACM codec is an alternative codec)
0x0083 - AT&T Labs G.729A
0x0084 - Motion Pixels MVI MV12
0x0085 - DataFusion Systems G.726
0x0086 - DataFusion Systems GSM610
0x0088 - Iterated Systems ISIAudio
0x0089 - Onlive
0x0091 - Siemens Business Communications SBC24
0x0092 - Sonic Foundry Dolby AC3 SPDIF
0x0097 - ZyXEL ADPCM
0x0098 - Philips LPCBB
0x0099 - Studer Professional Audio AG Packed
0x0100 - Rhetorex ADPCM
0x0101 - BeCubed Software IRAT
0x0111 - Vivo G.723
0x0112 - Vivo Siren
0x0123 - Digital G.723
0x0200 - Creative Labs ADPCM
0x0202 - Creative Labs FastSpeech8
0x0203 - Creative Labs FastSpeech10
0x0220 - Quarterdeck
0x0300 - Fujitsu TOWNS SND
0x0400 - BTV Digital (Brooktree digital audio format)
0x0450 - QDesign Music
0x0680 - AT&T Labs VME VMPCM
0x1000 - Olivetti GSM
0x1001 - Olivetti ADPCM
0x1002 - Olivetti CELP
0x1003 - Olivetti SBC
0x1004 - Olivetti OPR
0x1100 - Lernout & Hauspie codec
0x1400 - Norris Communication
0x1401 - ISIAudio
0x1500 - AT&T Labs Soundspace Music Compression
0x2000 - FAST Multimedia AG DVM (Dolby AC3)

AVI tags 1.0
14 января 2002

(+) Консольная программа
(+) Чтение и запись AVI тэгов RIFF INFO
(+) Построение дерева структуры AVI файла
(+) При записи новых тэгов информация записывается на место избыточных JUNK секций (сжатие AVI заголовка)


Благодарности
Хочу выразить благодарность людям, без которых не получилось бы этого проекта:

Татьяне Соркиной - за моральную поддержку и терпение, когда я долгими ночами занимался программированием, а так же за желание разобраться, на что-же все-таки было потрачено столько времени;

Александру Зудину - за отлов багов, идеи по усовершенствованию программы и кучу дисков с Сипсонами, великолепно снимающими напряжение;

Мариусу Овидию - за помощь в построении многоязычного интерфейса, хороший практикум по английскому языку и поразительную гостепреимность;

Всем авторам переводов - за работу по переводу более чем 1000 строк, а особенно Ки Али - автору перевода на китайский, за самый полный перевод;

Гийему де Байенкуру - за создание заплатки для Windows Media Player'а, с которой WMP таки показывает AVI тэги.

Сергею Мартыненко - за интересные и познавательные программистские беседы, без которых вряд ли осуществилась добрая половина функций [image] abcAVI;

Борису Гордейчику - за настойчивость, в результате которой было отловлено большое количество багов;

Работодателям - за то что не заметили моего маниакального пристрастия к программированию, которое порой шло в ущерб основной работе;

А так же всем остальным, которых я по плохой памяти не упомянул в этом списке, но которые помогли (или не мешали) работе над [image] abcAVI Tag Editor'ом.